New Question
 
 
PRTG Network Monitor

Intuitive to Use.
Easy to manage.

200.000 administrators have chosen PRTG to monitor their network. Find out how you can reduce cost, increase QoS and ease planning, as well.

Free PRTG
Download >>

 

What is this?

This knowledgebase contains questions and answers about PRTG Network Monitor and network monitoring in general. You are invited to get involved by asking and answering questions!

Learn more

 

Top Tags


View all Tags


Using tags in HTML request

Votes:

0

Your Vote:

Up

Down

I need to post xml to a webpage to get a result. But I'm not allowed to enter the XML POST data, because it contains < and >.

Is there a way around this?

http tags xml

Created on Nov 12, 2010 10:22:51 AM by  rluten (50) 1 1



Best Answer

Accepted Answer

Votes:

0

Your Vote:

Up

Down

To answer my own question. I also escaped all spaces.. so %3c, %3e en %20 for the spaces. And that worked with the GET.-

Created on Nov 15, 2010 3:38:51 PM by  rluten (50) 1 1



4 Replies

Votes:

0

Your Vote:

Up

Down

Hello,

could you please drop a few more details? Are you referring to HTTP Sensors in PRTG? To the PRTG API?

Best Regards.

Created on Nov 12, 2010 1:41:50 PM by  Torsten Lindner [Paessler Support]



Votes:

0

Your Vote:

Up

Down

Hi, does it work, when you encode the special characters as &lt; for < and &gt; for >?

Created on Nov 12, 2010 4:53:17 PM by  Jens Kalski (170) 3 1



Votes:

0

Your Vote:

Up

Down

I'll try to supply more info, the sensor I'm trying to configure is a HTTP sensor in PRTG.

I'm trying to access a webpage called http:/some.link/xmllink.asp I need to either POST or GET xml data to it in this form. In simplified form:

XMLDATA=<?xml version="1.0"?><OadBookingRequest>Data</OadBookingRequest>

I've tried using &lt; and &gt;. I've also tried to use %3c and %3e.

The error message I get is:

The validation of the data provided failed due to the following:
Postdata: Character sequences ('&lt;...&gt;') which can potentially form a tag are not allowed here

Is there perhaps some DontBlamePRTG registry setting, so I can use < and > in my Postdata?

Created on Nov 15, 2010 9:19:31 AM by  rluten (50) 1 1

Last change on Nov 15, 2010 10:36:23 AM by  Daniel Zobel [Paessler Support]



Accepted Answer

Votes:

0

Your Vote:

Up

Down

To answer my own question. I also escaped all spaces.. so %3c, %3e en %20 for the spaces. And that worked with the GET.-

Created on Nov 15, 2010 3:38:51 PM by  rluten (50) 1 1



Please log in or register to enter your reply.


Disclaimer: The information in the Paessler Knowledge Base comes without warranty of any kind. Use at your own risk. Before applying any instructions please exercise proper system administrator housekeeping. You must make sure that a proper backup of all your data is available.