New Question
 
 
PRTG Network Monitor

Intuitive to Use.
Easy to manage.

200.000 administrators have chosen PRTG to monitor their network. Find out how you can reduce cost, increase QoS and ease planning, as well.

Free PRTG
Download >>

 

What is this?

This knowledgebase contains questions and answers about PRTG Network Monitor and network monitoring in general. You are invited to get involved by asking and answering questions!

Learn more

 

Top Tags


View all Tags


PDF Report does not work

Votes:

0

Your Vote:

Up

Down

Hello all

I'm not able to get a PDF report working. HTML works fine.

I always get an error Report with following content:

ERROR 
The requested URL could not be retrieved 
While trying to retrieve the URL: http://127.0.0.1:8085/api/genreport.htm?  
The following error was encountered:  
l Connection to 127.0.0.1 Failed  
The system returned:  
    (111) Connection refused 
The remote host or network may be down. Please try the request again.  
Your cache administrator is proxy­[email protected]  
Generated Tue, 14 Dec 2010 10:07:22 GMT by netfilter.XXXXX.ch (squid/2.6.STABLE5)  

1. I already tried to change the port address without success. The strange thing for me is that the port in the generated PDF "URL: http://127.0.0.1:8085/api/genreport.htm?" was still 8085 and not the one I configured. (I rebooted the server to test)

2. I disabled all proxy settings at Internet Explorer and Firefox. Nothing changed.

Question:

Why does PRTG forwards anything to our proxy server when nothing is configured?

System: Windows Server 2008/64bit running on a virtual XEN platform.

Do you have any succession how to fix this?

Best regards Roger

pdf proxy prtg report

Created on Dec 14, 2010 10:31:23 AM by  roger_wahl (0) 1

Last change on Dec 14, 2010 4:09:10 PM by  Torsten Lindner [Paessler Support]



5 Replies

Votes:

0

Your Vote:

Up

Down

Dear Roger,

just to check, did you change the port used for PRTGs PDF-Report generation already (Article)? If yes, please bear in mind that under a 64bit Windows the registry key is in fact:

HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Paessler\PRTG Network Monitor\

Created on Dec 14, 2010 4:11:47 PM by  Torsten Lindner [Paessler Support]

Last change on Dec 14, 2010 4:11:55 PM by  Torsten Lindner [Paessler Support]



Votes:

0

Your Vote:

Up

Down

Dear Torsten Thanks for your answer. I first made a mistake with the registry path, this was the reason, why under point 1. the port did not changed from 8085 to the new configured port.

This changed now after i selected the correct path for the registry change. The error message is still the same except the port. (While trying to retrieve the URL: http://127.0.0.1:7777/api/genreport.htm?)

I checked also that the proxy server is nowhere configured in groups, device properties.

Any other succession?

Thanks Roger

Created on Dec 15, 2010 9:55:45 AM by  roger_wahl (0) 1



Votes:

0

Your Vote:

Up

Down

I'm afraid the only other suggestion would be to exclude the Proxy for this.

Created on Dec 15, 2010 12:06:04 PM by  Torsten Lindner [Paessler Support]



Votes:

0

Your Vote:

Up

Down

Hi Torsten What do you mean with exclude the proxy? Where should i exclude it? At PRTG or the proxy server itself?

I think, I do not have any proxy server entries configured in the PRTG server.

Thanks Roger

Created on Dec 15, 2010 1:57:44 PM by  roger_wahl (0) 1



Votes:

0

Your Vote:

Up

Down

I'm sorry, I meant exclude PRTG from the Proxy. Or only the localhost-address with this particular port that PRTG uses for its reports.

Created on Dec 15, 2010 2:45:23 PM by  Torsten Lindner [Paessler Support]



Please log in or register to enter your reply.


Disclaimer: The information in the Paessler Knowledge Base comes without warranty of any kind. Use at your own risk. Before applying any instructions please exercise proper system administrator housekeeping. You must make sure that a proper backup of all your data is available.