New Question
 
 
PRTG Network Monitor

Intuitive to Use.
Easy to manage.

200.000 administrators have chosen PRTG to monitor their network. Find out how you can reduce cost, increase QoS and ease planning, as well.

Free PRTG
Download >>

 

What is this?

This knowledgebase contains questions and answers about PRTG Network Monitor and network monitoring in general. You are invited to get involved by asking and answering questions!

Learn more

 

Top Tags


View all Tags


SSH sensor failed with open solaris. What can I do?

Votes:

0

Your Vote:

Up

Down

I tried to add a ssh meminfo sensor for our opensolaris system, failed, got following error: [ID 800047 auth.crit] fatal: Client and server could not agree on a common cipher: client "blowfish-cbc,cast128-cbc,aes128-cbc,3des-cbc", server "aes128-ctr,aes192-ctr,aes256-ctr,arcfour128,arcfour256,arcfour".

I ve tried to enable ssh version 1 and add cbc cyphers on the opensolaris server, didnt solve the issue.

Wondering if there is way for PRTG to enable ctr ciphers on the ssh sensors?

Thanks

cbc cipher ctr opensolaris prtg sensor ssh

Created on Dec 14, 2010 11:16:08 PM by  BRENTON BROWN (0) 1

Last change on Dec 15, 2010 1:43:49 PM by  Daniel Zobel [Paessler Support]



4 Replies

Accepted Answer

Votes:

0

Your Vote:

Up

Down

Hallo Brenton,

after enabling cbc-ciphers have you properly configured sshd to use at least the blowfish-cbc-cipher in /etc/ssh/sshd_config (sshd needs to be restarted here)?

Here is my explicit cipher configuration on opensolaris which is working for PRTG-SSH-Sensors:

$ egrep '^Ciphers|^Protocol' /etc/ssh/sshd_config
Protocol 2
Ciphers blowfish-cbc,aes128-ctr,aes192-ctr,aes256-ctr,arcfour128,arcfour256,arcfour

As you can see in my output you don't need to set 'Protocol 1' in the sshd configuration IMHO.

Created on Dec 15, 2010 1:11:53 PM by  Michael Zeidler [Paessler Support] (112) 3 1



Votes:

0

Your Vote:

Up

Down

Hello, thx for the fast response.

I added the following line to the sshd_config file.

"Ciphers blowfish-cbc,aes128-ctr,aes192-ctr,aes256-ctr,arcfour128,arcfour256,arcfour"

restarted sshd, tried the PRTG ssh sensor. Got the following error on PRTG,

"The negotiation of host key verification algorithm is failed"

Following error on opensolaris server

"[ID 800047 auth.crit] fatal: no hostkey alg"

Please advice, thx again.

Created on Dec 16, 2010 10:47:21 PM by  BRENTON BROWN (0) 1



Votes:

0

Your Vote:

Up

Down

pls ignore my last reply, prtg can connect to opensolaris server with ssh sensor after I re made the ssh keys.

but the ssh sensors aint working for opensolaris. got following error,

"The host's system is unable to process PRTG's command: "cat /proc/meminfo". (code: PE096)"

Opensolaris file system is different than Linux that /proc/meminfo doesnt exist. Is there anyway I can monitor Opensolaris with PRTG ssh sensor?

Thanks

Created on Dec 16, 2010 11:23:18 PM by  BRENTON BROWN (0) 1



Votes:

0

Your Vote:

Up

Down

For those who are interested, please refer to the article Which encryption algorithms does PRTG SSH sensors suppor" which shows an overview over the currently supported encryption algorithms.

Best regards,
Sven

Created on Jan 23, 2018 1:54:16 PM by  Sven Roggenhofer [Paessler Technical Support]



Please log in or register to enter your reply.


Disclaimer: The information in the Paessler Knowledge Base comes without warranty of any kind. Use at your own risk. Before applying any instructions please exercise proper system administrator housekeeping. You must make sure that a proper backup of all your data is available.