What is this?

This knowledgebase contains questions and answers about PRTG Network Monitor and network monitoring in general. You are invited to get involved by asking and answering questions!

Learn more

PRTG Network Monitor

Intuitive to Use. Easy to manage.
300.000 administrators have chosen PRTG to monitor their network. Find out how you can reduce cost, increase QoS and ease planning, as well.

Free Download

Top Tags


View all Tags

Monitoring standalone Windows Server 2008 R2 64-bit Edition

Votes:

0

Your Vote:

Up

Down

I cannot seem to be able to get this to work. It works on all other servers on my network. The only difference is the OS and it is a virtual server. The error I am getting when trying to add any sensor is

Error Message:"80041008: One of the parameters to the call is not correct.

Is there something I have to do with 64-bit virtual R2 servers ? Thanks.

2008r2 64-bit wmi

Created on Feb 4, 2011 4:41:42 PM by  squek (0) 1



Best Answer

Accepted Answer

Votes:

0

Your Vote:

Up

Down

I was able to fix this issue. We were also getting the dreaded generic microsoft code:

FIRST, do this: (Make sure that you KNOW what your account that you defined in http://www.poweradmin.com/help/enableWMI.aspx

SECOND, Make sure that the WMI Service is set to Automatic on the servers you are trying to use. Then, either start or restart the service. (I prefer to reboot the server, but I know how that works sometimes!).

THIRD, (and I think this is where the problem is), you must supply your credentials to the WMI instance. For me, I left the DOMAIN OR COMPUTER name section blank, and formatted my username like so: domainname\username

FOURTH, go back to your instance of PRTG and attempt to connect. For me, ALL steps in this order resolved the issue.

Oh, and, if you dont reboot your server, you might want to wait a good 10 minutes before attempting step 3 & 4. Takes WMI a minute to apply permissions and yada yada yada.

Created on Jun 8, 2011 7:53:00 PM by  Daniel Abraham (50) 1 1



9 Replies

Votes:

0

Your Vote:

Up

Down

Hello,

it seems as if there is something wrong with the WMI Classes on this host. Please see: I have tried a lot of things to fix my WMI. What else can I try to avoid reinstalling Windows?

Best Regards.

Created on Feb 4, 2011 4:51:58 PM by  Torsten Lindner [Paessler Support]



Votes:

0

Your Vote:

Up

Down

It looks more like something with MS Windows 2008 R2 64-bit rather than any misconfigurations or corruptions.

Created on Feb 4, 2011 5:11:16 PM by  squek (0) 1



Votes:

0

Your Vote:

Up

Down

Please be assured we do have a lot of 2008 R2 servers in our lab, and a lot of our other users have 2008 R2 which are doing fine in terms of WMI Monitoring. But sometimes there is an error in the WMI Repository (or a not sufficient permission to access a WMI Class), which then leads to such error-messages.

Created on Feb 4, 2011 5:17:26 PM by  Torsten Lindner [Paessler Support]

Last change on Apr 29, 2011 2:25:46 PM by  Torsten Lindner [Paessler Support]



Votes:

0

Your Vote:

Up

Down

Good to know. The only other attributes is that this is a virtual 64 bit server. The link you sent me to fix the WMI relates to OS before this one as some of the options don't even exist any more. Hence the question earlier.

Created on Feb 4, 2011 5:24:57 PM by  squek (0) 1



Votes:

0

Your Vote:

Up

Down

Tried the same on another MS Webserver 2008R2 64-bit system with the same results. Are these servers missing something?

Created on Feb 4, 2011 6:06:39 PM by  squek (0) 1



Votes:

0

Your Vote:

Up

Down

More. I used the Paessler WMI Tester and I get results back from the target server. I have rebooted the probe computer but does not seem to fix the problem. It certainly looks like the problem is at the monitor end. I have tried two MS Windows 2008 R2 Web edition server and they don't work. It works fine on 2003 server and on regular 2008 std edition servers.

Created on Feb 4, 2011 9:13:09 PM by  squek (0) 1



Votes:

0

Your Vote:

Up

Down

Hello,

please see WMI: Error 80041008 - Incorrect parameter, I'm afraid there is no solution we could present in this case.

Best Regards.

Created on Feb 9, 2011 10:43:08 AM by  Torsten Lindner [Paessler Support]



Accepted Answer

Votes:

0

Your Vote:

Up

Down

I was able to fix this issue. We were also getting the dreaded generic microsoft code:

FIRST, do this: (Make sure that you KNOW what your account that you defined in http://www.poweradmin.com/help/enableWMI.aspx

SECOND, Make sure that the WMI Service is set to Automatic on the servers you are trying to use. Then, either start or restart the service. (I prefer to reboot the server, but I know how that works sometimes!).

THIRD, (and I think this is where the problem is), you must supply your credentials to the WMI instance. For me, I left the DOMAIN OR COMPUTER name section blank, and formatted my username like so: domainname\username

FOURTH, go back to your instance of PRTG and attempt to connect. For me, ALL steps in this order resolved the issue.

Oh, and, if you dont reboot your server, you might want to wait a good 10 minutes before attempting step 3 & 4. Takes WMI a minute to apply permissions and yada yada yada.

Created on Jun 8, 2011 7:53:00 PM by  Daniel Abraham (50) 1 1



Votes:

0

Your Vote:

Up

Down

Made an account just so I can say thanks! to Daniel Abraham. I was searching and searching trying to figure out why my WMI sensor wasnt working and turned out I just needed to remote the Domain or Computer section of the device settings! Then it worked fine. Thanks for letting everyone know.

Created on Apr 1, 2020 2:18:43 PM by  alexOxford50 (0)



Please log in or register to enter your reply.


Disclaimer: The information in the Paessler Knowledge Base comes without warranty of any kind. Use at your own risk. Before applying any instructions please exercise proper system administrator housekeeping. You must make sure that a proper backup of all your data is available.