What is this?

This knowledgebase contains questions and answers about PRTG Network Monitor and network monitoring in general.

Learn more

PRTG Network Monitor

Intuitive to Use. Easy to manage.
More than 500,000 users rely on Paessler PRTG every day. Find out how you can reduce cost, increase QoS and ease planning, as well.

Free Download

Top Tags

View all Tags

can i monitor cpu on asa5520 using snmp?



hi all, i am using PRTG 7.2 and i am trying to monitor CPU utilization on ASA 5520 using SNMP ,i did all needed configuration on both firewall and prtg but i cant get the CPU ,i do monitor the interfaces but CPU and memeory are not displayed , i had tried other sensors types but it gave me snmp error thanks alot for your support and your efforts

Regards Ahmad

asa5520 cpu snmp

Created on Feb 25, 2011 5:32:43 PM

5 Replies




have you tried the SNMP Library Sensors ("Paessler Common OID Library") already?

best regards.

Created on Feb 25, 2011 5:36:07 PM by  Torsten Lindner [Paessler Support]



actually i didnt know how to find CPU OID in ASA5520 ? can you help me with that thanks

Created on Feb 25, 2011 6:23:49 PM




roun the auto discovery against your ASA, that should add the CPU and RAM sensor.

Created on Feb 27, 2011 9:35:55 AM by  Aurelio Lombardi [Paessler Support]



i tried doing that but it didnt work,,i found the oid for CPU and memory,, IOS old values:

CPU: enterprises.cisco.local.lsystem.avgBusy5.0 . (see nearby values for other timescales) This might still work for you.

Memory: enterprises.cisco.local.lsystem.freeMem.0 . obsolete as of IOS 11.1


CPU: cpmCPUTotal5sec . (see nearby values for other timescales) I'm not sure if this will work for lower-end models.

Memory: ciscoMemoryPoolUsed ciscoMemoryPoolFree CISCO-MEMORY-POOL-MIB ... you have to add the used and free to find the total pool size, and add all the

the memory worked well but CPU didnt !!!!!!!!!!!!!!!!!! does anyone know what is the problem ? pool sizes to find the total device memory size.

Created on Feb 27, 2011 1:17:15 PM



when i use snmpwalk or snmpgetnext with other monitoring tool it does report data but with snmpget it doesnt ???? so can you advise regarding this issue ,and if prtg is using snmpget or not for polling data ? and how can i change this configuration ?

thnaks for your support ahmad

Created on Feb 27, 2011 2:59:30 PM

Disclaimer: The information in the Paessler Knowledge Base comes without warranty of any kind. Use at your own risk. Before applying any instructions please exercise proper system administrator housekeeping. You must make sure that a proper backup of all your data is available.