New Question
 
 
PRTG Network Monitor

Intuitive to Use.
Easy to manage.

200.000 administrators have chosen PRTG to monitor their network. Find out how you can reduce cost, increase QoS and ease planning, as well.

Free PRTG
Download >>

 

What is this?

This knowledgebase contains questions and answers about PRTG Network Monitor and network monitoring in general. You are invited to get involved by asking and answering questions!

Learn more

 

Top Tags


View all Tags


Why when I connect to the PRTG server using a hostname is AJAX not available?

Votes:

0

Your Vote:

Up

Down

When I browse to the PRTG server using IE (version 8.0.7601.17514) using the server's host name, the AJAX interface is not selectable. The login screen says that "My browser is not supported". However, when I browse to the server using its IP address, I CAN select the AJAX interface. Why is that?

ajax browser-is-not-supported compatibility-view ie8 ie9

Created on Mar 24, 2011 9:36:21 PM by  oreo9810 (0) 1

Last change on Apr 8, 2011 9:08:12 AM by  Tobias Lange [Paessler Support]



Best Answer

Accepted Answer

Votes:

0

Your Vote:

Up

Down

Hello,

IE 8 and IE9 have the "Compatibility View" option. If this option is activated the ajax view in PRTG is not supported.

We will be putting a header into the HTML which causes the compatibility view to be killed.

If you want to do this by your own right now, please find htmlheader_mini.htm in the includes folder in your PRTG program folder and paste this code below the <head> tag:

<#system type="browserdependent" browsertype="MSIE" version="8" browsercontent="<meta http-equiv='X-UA-Compatible' content='IE=8' />"> <#system type="browserdependent" browsertype="MSIE" version="7" browsercontent="<meta http-equiv='X-UA-Compatible' content='IE=8' />"> <#system type="browserdependent" browsertype="MSIE" version="9" browsercontent="<meta http-equiv='X-UA-Compatible' content='IE=9' />">

additional Information:

If a website is opened with compatibility view once IE remembers this setting and opens the site the next time automatically in compatibility view. To check if your website name is listed in the compatibility view list please open the menu in IE, go to "Tools->Compatibility View Settings" and check if your host name is in there. Remove your host name and you should get the normal behavior.

Best regards

Created on Apr 8, 2011 8:37:36 AM by  Tobias Lange [Paessler Support]

Last change on Apr 8, 2011 9:05:43 AM by  Tobias Lange [Paessler Support]



3 Replies

Votes:

0

Your Vote:

Up

Down

Hello,

that should not come from PRTG, in anyway, please consider upgrading to IE9 or use Firefox or Chrome.

Best Regards.

Created on Mar 25, 2011 12:44:44 PM by  Torsten Lindner [Paessler Support]



Votes:

0

Your Vote:

Up

Down

This behavior is caused by the fact that IE9 by default shows intranet sites in compatibility view.

To change this behavior follow the steps below:

  • 1. Right click the header of your IE9 window and enable the command bar.
  • 2. Navigate to menu item "Page/Compatibility view settings"
  • 3. Uncheck the "Display intranet sites in Compatibility View" checkbox

The AJAX GUI option immediately comes available now.

Created on Apr 8, 2011 8:36:13 AM by  PRTG Tools Family [prtgtoolsfamily.com] (12,885) 3 4



Accepted Answer

Votes:

0

Your Vote:

Up

Down

Hello,

IE 8 and IE9 have the "Compatibility View" option. If this option is activated the ajax view in PRTG is not supported.

We will be putting a header into the HTML which causes the compatibility view to be killed.

If you want to do this by your own right now, please find htmlheader_mini.htm in the includes folder in your PRTG program folder and paste this code below the <head> tag:

<#system type="browserdependent" browsertype="MSIE" version="8" browsercontent="<meta http-equiv='X-UA-Compatible' content='IE=8' />"> <#system type="browserdependent" browsertype="MSIE" version="7" browsercontent="<meta http-equiv='X-UA-Compatible' content='IE=8' />"> <#system type="browserdependent" browsertype="MSIE" version="9" browsercontent="<meta http-equiv='X-UA-Compatible' content='IE=9' />">

additional Information:

If a website is opened with compatibility view once IE remembers this setting and opens the site the next time automatically in compatibility view. To check if your website name is listed in the compatibility view list please open the menu in IE, go to "Tools->Compatibility View Settings" and check if your host name is in there. Remove your host name and you should get the normal behavior.

Best regards

Created on Apr 8, 2011 8:37:36 AM by  Tobias Lange [Paessler Support]

Last change on Apr 8, 2011 9:05:43 AM by  Tobias Lange [Paessler Support]



Please log in or register to enter your reply.


Disclaimer: The information in the Paessler Knowledge Base comes without warranty of any kind. Use at your own risk. Before applying any instructions please exercise proper system administrator housekeeping. You must make sure that a proper backup of all your data is available.