New Question
 
 
PRTG Network Monitor

Intuitive to Use.
Easy to manage.

200.000 administrators have chosen PRTG to monitor their network. Find out how you can reduce cost, increase QoS and ease planning, as well.

Free PRTG
Download >>

 

What is this?

This knowledgebase contains questions and answers about PRTG Network Monitor and network monitoring in general. You are invited to get involved by asking and answering questions!

Learn more

 

Top Tags


View all Tags


Folder sensor - Cannot access folder: The folder doesn't exist (code: PE032)

Votes:

0

Your Vote:

Up

Down

I can only get the Folder sensor to work on probes, when ever I try to add a Folder sensor to a Device that is NOT a probe, PRTG cannot access the folder.

Have not had an issue with other Sensors, even the WMI sensors are all working ok (CPU Load, DISk Free etc).

- Tried changing the security settings - Added user "Everyone" with full rights to the folder. - Tried sharing the folder. - And tried on multiple devices. But always get same error. { Folder sensor - Cannot access folder: The folder doesn't exist (code: PE032) }

Any ideas?

cannot-access-folder folder pe032 sensor

Created on Mar 16, 2010 11:18:23 PM by  phil (0) 1



6 Replies

Accepted Answer

Votes:

0

Your Vote:

Up

Down

The folder sensor needs an UNC path starting with a share on the target computer. The UNC name of the target computer has to be omitted as it is automatically taken from the sensor's device.

Let's say you want to monitor the temp folder on the C: drive of your target computer. You'll have to enter C$\temp as path.

Paths beginning with C:\ would always refer to the C: drive of the probe computer, independent from the device the sensor is situated in.

- Volker

Created on Mar 17, 2010 1:01:18 PM by  Volker Uffelmann [Paessler Support]

Last change on Mar 17, 2010 1:02:48 PM by  Volker Uffelmann [Paessler Support]



Votes:

0

Your Vote:

Up

Down

OK, that means, if I have a shared folder named "datas\folder" and is letter is "F", I have to configure "F$\folder"

What about Linux machine, if I have a SMB shared folder "/datas/folder", what should I configure ? I try "/datas/folder", "folder", "/folder"....All not working

Any advice

Created on Apr 9, 2013 1:44:53 PM by  Olivier Paudex (90) 1 1



Votes:

0

Your Vote:

Up

Down

It depends how the share is defined and maybe "mounted". Please also try the Share Disk Free Sensor. And also see the tips in the following KB article for Troubleshooting Share Monitoring with PRTG.

Created on Apr 9, 2013 4:04:57 PM by  Torsten Lindner [Paessler Support]

Last change on Apr 14, 2014 12:32:42 PM by  Gerald Schoch [Paessler Support]



Votes:

0

Your Vote:

Up

Down

Hi

I have created an share with "Map Network Drive" 10.10.20.20\Data\Backup. It is an folder on an QNAB (NAS) Drive. I get this share: Q:\ on the Server. If I use Q$ on the FolderSensor it just say "code: PE032" What shout the Paths then be ?

Best regards - Jan

Created on Jan 15, 2015 10:31:27 PM by  Jan Iversen (0) 1



Votes:

0

Your Vote:

Up

Down

If the folder is mounted directly, you should be able to use q:\ as the path.

Created on Jan 18, 2015 8:48:57 AM by  Greg Campion [Paessler Support]



Votes:

1

Your Vote:

Up

Down

Just a note to all having trouble accessing a folder with a sensor. (error PE032)

We also suddenly were unable to monitor the Spool folder of a new print server like we always have on the previous print server and received PE032 errors.

I could access the
PRINTERNAME\$E\Spool
without issues from other servers/probes and the account used in PRTG had full access rights. (on the new server, oddly enough
IP ADDRESS\$E\Spool
did also not work)

When I created a Temp folder on E:, like we have on C:, I could also not access it. When I changed the sensor to monitor the Temp folder on C: instead (so C$\Temp) we had no trouble accessing it and the sensor went green.

Change it back to E$\Temp and the sensor errored out again...

Finally I was able to solve this (or work around this rather) by changing the Spool folder hosting Server settings in PRTG to use the FQDN rather than the IP address in the "IPv4 Address/DNS Name" section and the same in the "Service URL" section. No more errors after that.

Created on May 30, 2018 7:44:53 AM by  ahoppe (40) 1

Last change on May 30, 2018 7:50:41 AM by  Luciano Lingnau [Paessler Support]



Please log in or register to enter your reply.


Disclaimer: The information in the Paessler Knowledge Base comes without warranty of any kind. Use at your own risk. Before applying any instructions please exercise proper system administrator housekeeping. You must make sure that a proper backup of all your data is available.