What is this?

This knowledgebase contains questions and answers about PRTG Network Monitor and network monitoring in general. You are invited to get involved by asking and answering questions!

Learn more

PRTG Network Monitor

Intuitive to Use. Easy to manage.
300.000 administrators have chosen PRTG to monitor their network. Find out how you can reduce cost, increase QoS and ease planning, as well.

Free Download

Top Tags


View all Tags

WMI Query works in tester, not in PRTG

Votes:

0

Your Vote:

Up

Down

Hi -

I'm trying to get CPU utilization on a Windows Server 2008 system. This should be easy, and I have dozens of other servers on which the WMI CPU sensor works just fine.

I have one particular machine however from which I cannot get any results. I discovered the performance counters were corrupted on the server and rebuilt them. I can now successfully query WMI and get CPU utilization via the WMI Tester and via a third party WMI utility. However, when I use the WMI CPU sensor in PRTG, either with the normal or alternate query, I do not get any results. (Sensor is Up and OK, but no data is received.)

I have also tried a custom WMI query - which likewise works in the WMI Tester - but does not work within the application itself.

Any suggestions would be appreciated.

Thanks, James

cpu-load wmi wmi-tester

Created on Sep 27, 2011 5:11:55 PM by  James Prudente (0) 1



6 Replies

Votes:

0

Your Vote:

Up

Down

Dear James,

technically the Tester and PRTG are the same, therefore it might be worth a try running the PRTG Probe Service under the same account as you ran the Tester under. Does this help?

best regards.

Created on Sep 27, 2011 5:30:38 PM by  Torsten Lindner [Paessler Support]



Votes:

0

Your Vote:

Up

Down

I'm not sure I follow you. The Probe Service runs as Local System. I'm running the WMI Tester on the PRTG server, targeting the problem server, while logged on as a domain admin. The PRTG application uses domain admin credentials to query our Windows servers.

Is there any sort of log I can review on the PRTG installation to see what if any data was received by WMI?

Thanks, James

Created on Sep 27, 2011 5:35:07 PM by  James Prudente (0) 1



Votes:

0

Your Vote:

Up

Down

I am having the same problem. The PRTG server is not part of the domain, but I have domain credentials. From the PRTG server, they WMI Tester works fine, buy I have sensors that occasionally do not respond.

Created on Mar 24, 2015 6:29:53 PM by  CJLockhart (0)



Votes:

0

Your Vote:

Up

Down

So the sensors work every now and then? Or do they fail all the time?

Created on Mar 25, 2015 8:18:08 AM by  Torsten Lindner [Paessler Support]



Votes:

0

Your Vote:

Up

Down

Having the same issue right now, the Tester gives ma all the Information i ask for (Memory, Processor, Disks etc.), but WMI Sensors are grayed out.

The structure is the following: PRTG Probe in own LAN Target-WMI-System in own LAN

From Probe to Target, WMI is enabled on the Firewall. Telnet say OK and WMI Tester says ok (WMI 135 TCP and the High Ports).

The User i used for WMI Tester is the same as the one in the PRTG Windows Credentials Setting (Domainadmin). Password is correct, i copied it and pasted the same copy in the Tester and in the PRTG Webinterface. The same with Username and domain and IP.

When i establish a WMI Sensor through the PRTG Webinterface, it's gray and it says there is no Data.

Created on Dec 17, 2020 4:00:14 PM by  leonardbarth (10) 1



Votes:

0

Your Vote:

Up

Down

Hello,

in the tester, did you enable the option to check for the port? ("Advanced" tab). If yes, please contact the support with a support bundle and error description.

Created on Dec 21, 2020 1:08:23 PM by  Arne Seifert [Paessler Support]



Please log in or register to enter your reply.


Disclaimer: The information in the Paessler Knowledge Base comes without warranty of any kind. Use at your own risk. Before applying any instructions please exercise proper system administrator housekeeping. You must make sure that a proper backup of all your data is available.