New Question
 
 
PRTG Network Monitor

Intuitive to Use.
Easy to manage.

300.000 administrators have chosen PRTG to monitor their network. Find out how you can reduce cost, increase QoS and ease planning, as well.

Free PRTG
Download >>

 

What is this?

This knowledgebase contains questions and answers about PRTG Network Monitor and network monitoring in general. You are invited to get involved by asking and answering questions!

Learn more

 

Top Tags


View all Tags


Sensor errors after upgrade

Votes:

0

Your Vote:

Up

Down

Hi *,

After upgrading to PRTG version 9.1.6.1962 (coming from some 9.1.5 version), at times, I am experiencing some error messages. These are: Timeout, executable did not return. (code: PE018) DNS could not be resolved Socket Error # 11004 (socket error # 11004) DNS could not be resolved (socket error # 11004)

The one with PE018 in it is related to the http full page sensor. The DNS messages show up on the ping sensor, the TCP connect sensor and the http sensor.

Previous versions did not show these errors.

What could be wrong here?

Grtz - Will

dns http-full-web-page prtg

Created on Dec 28, 2011 9:38:52 AM by  Will Moonen (0) 1



7 Replies

Votes:

0

Your Vote:

Up

Down

For troubleshooting could you please tell us which website you monitor with the HTTP Fullpage sensor? Does the error occur on every HTTP Fullpage Sensor or only on some of them?

As to the other sensors, which DNS could not be resolved. Is it a public one?

Created on Dec 28, 2011 3:33:32 PM by  Aurelio Lombardi [Paessler Support]



Votes:

0

Your Vote:

Up

Down

I have tried the fullpage sensor on 2 homepages being http://maasshuttles.nl and http://projena.info. I'm experiencing the same issue with both.

The DNS message is not specific enough. It might be that the DNS server itself could not be resolved. Which seems somewhat strange because it is pointing to the IP adresses of the DNS-servers of the ISP. Or it might be that the DNS servers of the ISP could not resolve the domain name. Which seems also strange since everything works fine when starting the browser on the same system where PRTG resides.

Either way, DNS problem also happens occasionally - say 3-5 times every 24 hours when using a test interval of 10 minutes. Additionally, I tried with 3 sensors - TCP connect, ping and http. The issue occurred in all 3 cases.

I never experienced this in the previous version (i.e. some 9.1.5 release).

Created on Dec 28, 2011 3:59:42 PM by  Will Moonen (0) 1



Votes:

0

Your Vote:

Up

Down

Hello,

we do see the same issues when monitoring those two sites with HTTP Full Page Sensors:

RESOURCE NOT FOUND http projena.info/
RESOURCE NOT FOUND http maasshuttles.nl/

or

-2146697208 http maasshuttles.nl/

so this rather seems to be an issue on the websites than in PRTG.

Created on Dec 30, 2011 1:14:04 PM by  Torsten Lindner [Paessler Support]



Votes:

0

Your Vote:

Up

Down

Do you see them permanent? Or every once and a while?

The message you are showing are 'http projena.info/'. Shouldn't that be 'http://projena.info'?

Created on Dec 30, 2011 1:28:42 PM by  Will Moonen (0) 1



Votes:

0

Your Vote:

Up

Down

We only see the errors every now and then. The responses are missing a few characters but the sensors are targeting the correct pages.

Created on Dec 30, 2011 3:14:20 PM by  Torsten Lindner [Paessler Support]



Votes:

0

Your Vote:

Up

Down

Could it be that the error message is related to an exceeded timeout? In other words, when a web page takes to long to complete, the treshold is exceeded. And instead of showing a nice timeout message stating that the pageload did not complete within the specified amount of time, some error handling kicks-in showing something strange about an executable that did not complete.

I did some more investigation by fiddling around with the thresholds. And with lower settings, the message comes more often than with higher settings. In fact, when set to one second, the error is always there.

Created on Dec 30, 2011 3:52:53 PM by  Will Moonen (0) 1



Votes:

0

Your Vote:

Up

Down

You are right, the error - message is actually a timeout and should say that. We'll change this.

Created on Jan 2, 2012 12:48:09 PM by  Torsten Lindner [Paessler Support]



Please log in or register to enter your reply.


Disclaimer: The information in the Paessler Knowledge Base comes without warranty of any kind. Use at your own risk. Before applying any instructions please exercise proper system administrator housekeeping. You must make sure that a proper backup of all your data is available.