What is this?

This knowledgebase contains questions and answers about PRTG Network Monitor and network monitoring in general.

Learn more

PRTG Network Monitor

Intuitive to Use. Easy to manage.
More than 500,000 users rely on Paessler PRTG every day. Find out how you can reduce cost, increase QoS and ease planning, as well.

Free Download

Top Tags

View all Tags

Active Directory Replication "Access Denied"



Using the Active Directory Replication sensor, I always get an error saying "Replication access was denied"

Even running the sensor with domain admin credentials gives me this error.

access denied replication

Created on Jan 31, 2012 9:38:21 AM

6 Replies

Accepted Answer



This article applies as of PRTG 23

How to enable access for the Active Directory Replication Errors sensor

Replication access is a security setting that has to be enabled for the user whose credentials are used when running the sensor.

If you're using an account without domain admin rights, additional steps are necessary to enable this setting. We recommend that you follow the steps in How do I monitor Active Directory (AD) replication without domain admin rights?.

If you're using an account with domain admin rights, you can follow the steps below to enable Active Directory replication access:

1. Open the Active Directory Users and Computers snap-in.

2. On the View menu, click Advanced Features.

3. Right-click the domain object, such as "mydomain.com", and then click Properties.

4. On the Security tab, select the account of the user whose credentials are used to run the sensor (or add it if it does not exist here).

5. Click to select the Monitor active directory replication checkbox from the list.

6. Click Apply, and then click OK.

Now you should be able to use the sensor without error messages.


Created on Jan 31, 2012 10:16:41 AM

Last change on Jul 25, 2023 12:44:15 PM by  Jacqueline Conforti [Paessler Support]



How can I change credentials for running this type of sensor? Changing "Credentials for Windows Systems" does not work.

Thanks, Andrea

Created on Jan 17, 2013 5:32:05 PM



The sensor does indeed use the "Credentials for Windows Systems". No other. Which error do you get then on the sensor?

Created on Jan 18, 2013 10:23:01 AM by  Torsten Lindner [Paessler Support]

Last change on Jan 18, 2013 10:23:42 AM by  Torsten Lindner [Paessler Support]



I tried this permissions setup but it doesn´t work. I had a user who were a member of the "Domain Admins" group. I want to remove his membership but without this one the PRTG probe is unable to read the replication status - "ACCESS DENIED" error. What other permissions are mandatory for this sensor?

Created on Jul 2, 2015 9:55:38 AM



The question should be directed at Microsoft, which group memberships are necessary to have at least read access to the AD-Replication counters.

Created on Jul 2, 2015 11:12:05 AM by  Torsten Lindner [Paessler Support]



Hi there I lost a lot of time in troubleshooting because of a similar issue:

"Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED))

The cause of the issue in the end was not the permission on Domain level (Domain Admin and Domain user should be enough), it simply was a special caracter in the password. I changed the special caracter in the password and afterwards it worked....

Created on Mar 2, 2022 2:11:30 PM

Disclaimer: The information in the Paessler Knowledge Base comes without warranty of any kind. Use at your own risk. Before applying any instructions please exercise proper system administrator housekeeping. You must make sure that a proper backup of all your data is available.