New Question
 
 
PRTG Network Monitor

Intuitive to Use.
Easy to manage.

200.000 administrators have chosen PRTG to monitor their network. Find out how you can reduce cost, increase QoS and ease planning, as well.

Free PRTG
Download >>

 

What is this?

This knowledgebase contains questions and answers about PRTG Network Monitor and network monitoring in general. You are invited to get involved by asking and answering questions!

Learn more

 

Top Tags


View all Tags


Message queue sensor doesn't show queue's in public

Votes:

0

Your Vote:

Up

Down

I would like to monitor how many messages are in a message queue listed under the public folder. The Message queue sensor only shows \public, but doesn't me choose the queue names.

The message queue service is running and I am able to see the queues through a wmi script with the same account I am using for the sensor.

In the field where I should fill in the queue name, an unchangeable message appears: "Message Queuing Service is running on ServerName".

Could anybody help me with this problem?

message-queue public queue-name

Created on Feb 9, 2012 12:08:01 PM by  Brian (0) 1



7 Replies

Votes:

0

Your Vote:

Up

Down

Hello,

which exact version of PRTG are you running? Just to check, you are referring to the Windows MSMQ Queue Length Sensor

best regards.

Created on Feb 9, 2012 5:54:39 PM by  Torsten Lindner [Paessler Support]



Votes:

0

Your Vote:

Up

Down

Hey Torsten,

Thanks for the fast reply. Yes I was referring to the Windows MSMQ Queue Length sensor. I am using PRTG Network Monitor 9.2.0.2170. When I am using the ListQueues tool, I do get a list of the queue's under public. Sorry I didn't note this information in the first post.

Created on Feb 9, 2012 7:31:58 PM by  Brian (0) 1



Votes:

0

Your Vote:

Up

Down

The Sensor should show all Queues when you try to add it. Does it not in your case? Is the target machine in the same domain as the PRTG Host? Which error do you get? Maybe send in some screenshots to [email protected]

Created on Feb 10, 2012 2:28:21 PM by  Torsten Lindner [Paessler Support]



Votes:

0

Your Vote:

Up

Down

Hi Brian,

If the ListQueues tool does show the queues, it's most likely a credentials issue. Try entering the same Windows credentials (username/password) on the device settings as the credentials used when running the tool.

Regards,

Created on Feb 13, 2012 10:32:44 AM by  PRTG Tools Family [prtgtoolsfamily.com] (12,885) 3 4



Votes:

0

Your Vote:

Up

Down

Thanks for trying to help Torsten and Gerard!

It appeared to be something else and I now know what the problem was. I'll try to explain.

I found out that the message queue (in general, not the sensor) only works with the real server hostname and not with alias names.

When we get our servers deliverd, the servers get an hostname like PL390. Because we have a lot of servers, we give all the servers an alias like appserver-prd01 for example.

Because that is the name we use for the servers, I've always been monitoring the servers by their aliases. It works perfectly for services monitoring and custom wmi scripts and I didn't know that the message queue only works with the real server name, so I just added the sensor to the devices without changing the servernames PRTG was looking at.

Anyway, I had to change the IPv4 Address/DNS Name for all my servers and now the Windows MSMQ Queue Length sensor works again.

The only thing I don't know now, is how make PRTG give a down-alarm when there are like 5 messages in the queue and a warning if there are two. I do get to see the values now, but without the ability to give up a 'Condition Warning' and a 'Condition Down', I don't really see the point monitoring the amount of messages.

Where should define those conditions?

Created on Feb 21, 2012 11:11:40 AM by  Brian (0) 1



Votes:

0

Your Vote:

Up

Down

H Brian,

On the sensors channels tab, choose to enable limits and next set the upper warning and error limit.

Regards,

Created on Feb 21, 2012 5:44:25 PM by  PRTG Tools Family [prtgtoolsfamily.com] (12,885) 3 4



Votes:

0

Your Vote:

Up

Down

That works great! Thanks a lot for all the help!

Created on Feb 22, 2012 7:48:12 AM by  Brian (0) 1



Please log in or register to enter your reply.


Disclaimer: The information in the Paessler Knowledge Base comes without warranty of any kind. Use at your own risk. Before applying any instructions please exercise proper system administrator housekeeping. You must make sure that a proper backup of all your data is available.