What is this?

This knowledgebase contains questions and answers about PRTG Network Monitor and network monitoring in general. You are invited to get involved by asking and answering questions!

Learn more

PRTG Network Monitor

Intuitive to Use. Easy to manage.
More than 500,000 users rely on Paessler PRTG every day. Find out how you can reduce cost, increase QoS and ease planning, as well.

Free Download

Top Tags


View all Tags

Why does my PRTG web server run on localhost?

Votes:

0

Your Vote:

Up

Down

Suddenly my PRTG web server is not available via its IP address any more, but instead I can only reach it via https://127.0.0.1 (resp. http://127.0.0.1). What happened?

ip-setting localhost network-card prtg prtg-server-administrator web-server

Created on Apr 3, 2012 12:07:43 PM by  Daniel Zobel [Product Manager]

Last change on Apr 3, 2012 12:14:13 PM by  Daniel Zobel [Product Manager]



6 Replies

Accepted Answer

Votes:

0

Your Vote:

Up

Down

This article applies to PRTG Network Monitor 9 or later

PRTG's IP Settings

If PRTG does not find a network card on startup it will switch the IP setting to Localhost, regardless of the configuration you entered before. This setting will remain, even if a network card is available later on.

So, for example, if you disabled or removed the network card on the machine running the PRTG core server, and PRTG did not find a network card on services start up, it might have changed the IP setting to use "localhost".

To check your settings, please log in to the machine running your PRTG core server, open the PRTG Server Administrator and check the settings in the Web Server tab. Change settings as needed.

Created on Apr 3, 2012 12:10:07 PM by  Daniel Zobel [Product Manager]

Last change on Apr 3, 2012 12:10:53 PM by  Daniel Zobel [Product Manager]



Votes:

0

Your Vote:

Up

Down

This appears to be my issue as well, as my local PRTG server has switched to serving out its website from the 127.0.0.1 address. I looked under web settings are they appropriate to be using the local machine's IP address, but still the server is starting on the localhost IP.

Running "netstat -o" doesn't show any local connections open on the server's IP address port 80 or 8080, and yet PRTG gives up and starts on 127.0.0.1:8080. I suppose I should open a new question since the one I'm replying to is 10 years old, but I'll hope for someone to notice me and reply here first.

Background: I'm trying PRTG to monitor a few devices on my home network. It was running OK and serving out the website from the local host's IP address for the first month. I realized I hadn't looked at it for a few weeks, and it had stopped monitoring, so I started it back up. It took me a short time, to notice it had switched to the localhost address.

Reference: A question posted here on 4/3/2012: Why does my PRTG web server run on localhost?

Suddenly my PRTG web server is not available via its IP address any more, but instead I can only reach it via https://127.0.0.1 (resp. http://127.0.0.1). What happened?

Created on Oct 28, 2022 12:16:19 AM by  admsguy (0) 1



Votes:

0

Your Vote:

Up

Down

Hi there,

please let me know whether also other software / webserver are running on your server? If so, please disable the application to check whether PRTG uses the other IPs again. Please check also the last startup in the "Core.log" file why the other IPs are not used.

Created on Nov 1, 2022 8:32:27 AM by  Moritz Heller [Paessler Support]



Votes:

0

Your Vote:

Up

Down

Hello Moritz. Sorry, but I don't see a core.log file under the "PRTG Network Monitor" directory. I only see mibparser.log, PRTG Setup Log.log, and dh.log, none of which seem to have any entries about this issue.

Can you please give me a clue, to help me locate the core.log file you referenced?

Created on Nov 1, 2022 10:22:49 PM by  admsguy (0) 1



Votes:

0

Your Vote:

Up

Down

Hello Moritz. Thanks for the response! My issue appears to be resolved now.

I don't have any other software running, that serves out a web page, so there was nothing to stop.

Out of desperation, I restarted the PRTG software again, this time using the Administration Tool, after changing the IP Selection back to "All IP addresses available". It looks like the PRTG web server started up, and is listening on port 8080 on both 127.0.0.1 and my computer's 10.0.0.x address. The network probe seems happy now. Is it normal for it to be listening on both IP addresses? If so, I think it's working as desired now.

I found the PRTG core.log file under \ProgramData\Paessler\PRTG Network Monitor\Logs\core. I did see messages about "port 80 already occupied", which I guess is why it used 8080 instead, but no idea why it thought 80 was in use. I'm not sure how the problem resolved itself, as I didn't stop any other software. Maybe those ports were marked still in use, when the PRTG software restarted earlier.

Created on Nov 1, 2022 11:17:15 PM by  admsguy (0) 1



Votes:

0

Your Vote:

Up

Down

HI there,

Thank you for the update, glad you got it working again. Per default, PRTG listens to all IPs available on the server. Therefore it's normal that localhost and your 10.0.0.x IPs are used.

If port 80 is still in use, you can use
netstat -ano
and
tasklist | find "YourPID"
to check which service occupies the port.

Created on Nov 2, 2022 9:33:30 AM by  Moritz Heller [Paessler Support]

Last change on Nov 2, 2022 9:33:46 AM by  Moritz Heller [Paessler Support]



Please log in or register to enter your reply.


Disclaimer: The information in the Paessler Knowledge Base comes without warranty of any kind. Use at your own risk. Before applying any instructions please exercise proper system administrator housekeeping. You must make sure that a proper backup of all your data is available.