New Question
 
 
PRTG Network Monitor

Intuitive to Use.
Easy to manage.

200.000 administrators have chosen PRTG to monitor their network. Find out how you can reduce cost, increase QoS and ease planning, as well.

Free PRTG
Download >>

 

What is this?

This knowledgebase contains questions and answers about PRTG Network Monitor and network monitoring in general. You are invited to get involved by asking and answering questions!

Learn more

 

Top Tags


View all Tags


[LINUX] Interface index traffic

Votes:

0

Your Vote:

Up

Down

Hello,

First, sorry for my english :p

I use PRTG to monitor network devices (router running on Debian Linux).
I monitor the network interfaces without problems.
But if an interface goes from one state UP to DOWN then UP then I have a problem with indexes (interface is No such NAME SNMP error).

The interfaces are configured as follow:
- display alarm if disconnected
- snmp v2c
- 64bit counter (i tried 32 bit but unsuccesfull)
- multi-get use
- Port name: (Alias​​: [ifalias]) (Port: [port])
- automatic update if name changes in the device
- use ifAlias

is there a way to "fix" the indexes on Linux? Any solution ?

Thank you.

index interface linux

Created on Apr 13, 2012 12:03:01 PM by  kevingouzy (0) 1

Last change on Apr 13, 2012 12:34:12 PM by  Konstantin Wolff [Paessler Support]



7 Replies

Votes:

0

Your Vote:

Up

Down

Hi, what NET-SNMP version are you using? I just tried to recreate the issue you have but I was not successful...
Addtional I'm afraid the RFCs do not require the ifIndex persistant.
------
The requirement for constancy (between re-initializations) of an interface's ifIndex value is met by requiring that after an interface is dynamically removed, its ifIndex value is not re-used by a different dynamically added interface until after the following re-initialization of the network management system.
------ (quote from RFC 2863)
But as mentioned above, I'm not facing these issues with the following version of NET-SNMP (5.4.3dfsg-2.2ubuntu1).
Best regards

Created on Apr 13, 2012 12:45:07 PM by  Konstantin Wolff [Paessler Support]



Votes:

0

Your Vote:

Up

Down

NET-SNMP version: 5.4.1

the problem is only with linux device, no problem with CISCO (re-index is OK)

Created on Apr 13, 2012 12:54:15 PM by  kevingouzy (0) 1



Votes:

0

Your Vote:

Up

Down

just an info, my problem appears only for ppp (adsl) and nas (sdsl) interfaces no problem for interfaces like ETH1,ETH0..etc..

Created on Apr 13, 2012 2:34:22 PM by  kevingouzy (0) 1



Votes:

0

Your Vote:

Up

Down

Sorry, my problem is only with PPP interfaces....

Created on Apr 16, 2012 6:47:16 AM by  kevingouzy (0) 1



Votes:

0

Your Vote:

Up

Down

any idea ?

Created on Apr 16, 2012 12:33:06 PM by  kevingouzy (0) 1



Votes:

0

Your Vote:

Up

Down

Hi,
I'm afraid we do not have a solution for that and I'm not quite sure if there is a solution at all. Sorry.
Maybe a other user knows more about that. Best regards

Created on Apr 16, 2012 1:23:36 PM by  Konstantin Wolff [Paessler Support]



Votes:

0

Your Vote:

Up

Down

hi,

I have a same problem, =)

network up and down, then up, I have problem.

so,

  1. snmpwalk -v2c -cxxx localhost | grep ifIndex IF-MIB::ifIndex.1 = INTEGER: 1 (lo) IF-MIB::ifIndex.2 = INTEGER: 2 (eth0) IF-MIB::ifIndex.3 = INTEGER: 3 (eth1) IF-MIB::ifIndex.6 = INTEGER: 6 (bond0) <-- increase count +1

that's is problem,

I'm using OpenSuse 11.4. do you know how to change from ifIndex.6 to ifIndex.1 ??

regard, thanks

Created on Apr 19, 2012 8:49:27 AM by  samahee (0)



Please log in or register to enter your reply.


Disclaimer: The information in the Paessler Knowledge Base comes without warranty of any kind. Use at your own risk. Before applying any instructions please exercise proper system administrator housekeeping. You must make sure that a proper backup of all your data is available.