New Question
 
 
PRTG Network Monitor

Intuitive to Use.
Easy to manage.

200.000 administrators have chosen PRTG to monitor their network. Find out how you can reduce cost, increase QoS and ease planning, as well.

Free PRTG
Download >>

 

What is this?

This knowledgebase contains questions and answers about PRTG Network Monitor and network monitoring in general. You are invited to get involved by asking and answering questions!

Learn more

 

Top Tags


View all Tags


Netflow Sensor Error "could not bind socket..."

Votes:

0

Your Vote:

Up

Down

I had setup netflow on our Cisco ASA and directed traffic to the PRTG server over UDP 2055. The sensor was up and running for about five minutes, then it alarmed with the following error:

"Could not bind socket. Address and Port are already in use."

I have verified that the ASA is sounding packets with no errors using "sh flow-export counters" command. Running debug I do not see any errors on the ASA itself.

I took a quick look at the forums and I did read that a reboot of the PRTG server may be necessary. I would like to avoid that if possible, we have about 3000 sensors running with no problems, it is just the Netflow sensor that is throwing the error.

asa netflow socket-error

Created on Sep 20, 2012 4:30:39 PM by  mrjoshuaw (0) 1



4 Replies

Votes:

0

Your Vote:

Up

Down

Hello,

you can also restart the PRTG Probe Service, that should suffice as well (not a full restart of the entire machine), but will also cause a short gap in the monitoring. The other thing you can try is setting the port on which the Netflow Sensor listens to 2155 (for example) wait a few minutes, then set it back to 2055. Or pause the sensor for at least 5 minutes.

best regards.

Created on Sep 20, 2012 7:43:54 PM by  Torsten Lindner [Paessler Support]



Votes:

0

Your Vote:

Up

Down

I have the same issue for a customer of ours using PRTG v 12.2.2.2211. >> We created a NetFlow configuration on Cisco Nexus 7000. >> Wireshark on the PRTG server shows the flow packets arriving OK. >> we configured a v9 NetFlow sensor on the probe >> "netstat -an" on the PRTG server shows our NetFlow v9 probe listening on UDP port 9555 (which is what we configured on the Nexus switch) >> after a period of time the NetFlow sensor goes into error state "could not bind to socket, address or port already in use" (or something along those lines)

tried restarting probe - no effect tried switching UDP port - no effect

any suggestions please ? thanks

Created on Nov 16, 2012 12:04:15 PM by  Patrick Gahan (0) 1



Votes:

0

Your Vote:

Up

Down

I had this same problem with netflow ports. When running netstat -an on the server the sockets weren't opened, when I changed the port number then immediately changed it back then the port opened correctly and I was able to receive the flows. Before I changed the port number it would have problems, even after reboots. After manually changing the port number then back it seems to work fine, even after a reboot.

Also I think somewhere in there I changed my probe config to listen on the specific IP rather than the "auto" setting that is available.

So perhaps there's some bug relating to the probe ip being set to auto and opening udp ports?

Created on Dec 6, 2012 7:24:13 PM by  Dan Dill (0)



Votes:

0

Your Vote:

Up

Down

We will try to reproduce this, however the IP-Setting for outgoing monitoring requests in the "PRTG Probe Admin"-Tool does not have any effect on Netflow Sensors, as on those you select the NIC/IP where to listen for the Netflows specifically. And also Netflows are listened to, not sent out monitoring requests, so an influence there is not very likely, we'll test it though!

Created on Dec 7, 2012 2:13:28 PM by  Torsten Lindner [Paessler Support]



Please log in or register to enter your reply.


Disclaimer: The information in the Paessler Knowledge Base comes without warranty of any kind. Use at your own risk. Before applying any instructions please exercise proper system administrator housekeeping. You must make sure that a proper backup of all your data is available.