What is this?

This knowledgebase contains questions and answers about PRTG Network Monitor and network monitoring in general. You are invited to get involved by asking and answering questions!

Learn more

PRTG Network Monitor

Intuitive to Use. Easy to manage.
More than 500,000 users rely on Paessler PRTG every day. Find out how you can reduce cost, increase QoS and ease planning, as well.

Free Download

Top Tags


View all Tags

Custom Sensor LimitMaxWarning not enabled?

Votes:

0

Your Vote:

Up

Down

Trying to set and enable limits on a channel of a custom sensor. Here's my output:

<result> <Channel>Packet Loss</Channel> <Unit>Percent</Unit> <Value>$loss</Value> <ShowChart>0</ShowChart> <LimitMaxWarning>25</LimitMaxWarning> <LimitMaxError>50</LimitMaxError> <LimitMode>1</LimitMode> <!-- I've tried 0 or 1 here --> </result>

It's adding the 25/50 #'s into the channel but not enabling limits. How is that done? I understand this is only read on the first sensor scan.

Thanks! -Andrew

custom-exe custom-sensor limits

Created on Dec 17, 2012 4:35:40 PM by  Andrew (50) 1 1



Best Answer

Accepted Answer

Votes:

0

Your Vote:

Up

Down

Updated to version 12.4.7.3507

Now when <LimitMode> is explicitly set to 1 it works as expected. Omitting <LimitMode> or setting it to 0 puts the correct values in the textboxes but does not enable the “Enable Limits” radio button.

The API documentation will be updated to reflect this.

Thank you Konstantin for your help. -Andrew

Created on Jan 8, 2013 3:35:43 PM by  Andrew (50) 1 1



3 Replies

Votes:

0

Your Vote:

Up

Down

Hi,
may you please send screenshots showing the issue to [email protected] and refer to this thread.
Best regards

Created on Dec 19, 2012 12:13:45 PM by  Konstantin Wolff [Paessler Support]



Votes:

0

Your Vote:

Up

Down

Email sent. THank you.

Created on Dec 19, 2012 4:09:25 PM by  Andrew (50) 1 1



Accepted Answer

Votes:

0

Your Vote:

Up

Down

Updated to version 12.4.7.3507

Now when <LimitMode> is explicitly set to 1 it works as expected. Omitting <LimitMode> or setting it to 0 puts the correct values in the textboxes but does not enable the “Enable Limits” radio button.

The API documentation will be updated to reflect this.

Thank you Konstantin for your help. -Andrew

Created on Jan 8, 2013 3:35:43 PM by  Andrew (50) 1 1



Please log in or register to enter your reply.


Disclaimer: The information in the Paessler Knowledge Base comes without warranty of any kind. Use at your own risk. Before applying any instructions please exercise proper system administrator housekeeping. You must make sure that a proper backup of all your data is available.