New Question
 
 
PRTG Network Monitor

Intuitive to Use.
Easy to manage.

300.000 administrators have chosen PRTG to monitor their network. Find out how you can reduce cost, increase QoS and ease planning, as well.

Free PRTG
Download >>

 

What is this?

This knowledgebase contains questions and answers about PRTG Network Monitor and network monitoring in general. You are invited to get involved by asking and answering questions!

Learn more

 

Top Tags


View all Tags


Change authentication level when querying WMI

Votes:

1

Your Vote:

Up

Down

Hi Guys.

I have dozens of Custom WMI sensors using WQL to query WMI working perfectly. They all use the default 'CIMV2' namespace.

However, I cannot get WQL to work (via PRTG) for the 'WebAdministration' namespace. Note, the same WQL will work in the Passeler WMI Tester using the 'WebAdministration' namespace.

The problem is the 'WebAdministration' namespace is marked with the RequiresEncryption flag. This cannot be changed in DCOM.

The event log states: Access to this namespace might be denied if the script or application does not have the appropriate authentication level. Change the authentication level to Pkt_Privacy and run the script or application again.

So it seems that the PRTG is using the default authentication level when querying WMI. Please can you advise how to get around this?

authentication namespace wmi wql

Created on Dec 20, 2012 10:30:08 AM by  Philip Druce (1) 1



1 Reply

Votes:

0

Your Vote:

Up

Down

Hi,
I'm afraid it is not possible in PRTG to change the authentication level. So there is also no way around. Sorry.
Best regards

Created on Dec 20, 2012 4:00:47 PM by  Konstantin Wolff [Paessler Support]



Please log in or register to enter your reply.


Disclaimer: The information in the Paessler Knowledge Base comes without warranty of any kind. Use at your own risk. Before applying any instructions please exercise proper system administrator housekeeping. You must make sure that a proper backup of all your data is available.