What is this?

This knowledgebase contains questions and answers about PRTG Network Monitor and network monitoring in general. You are invited to get involved by asking and answering questions!

Learn more

PRTG Network Monitor

Intuitive to Use. Easy to manage.
300.000 administrators have chosen PRTG to monitor their network. Find out how you can reduce cost, increase QoS and ease planning, as well.

Free Download

Top Tags


View all Tags

How can I remove "Forgot your password" from login screen?

Votes:

0

Your Vote:

Up

Down

I need to remove the the "Forgot your password" from the prtg login screen to pass a penn test, does anyone have an ideas on how to do this ?

Regards

Dave

customize login password prtg

Created on May 13, 2010 9:41:43 AM by  davidbrockhurst (1) 1

Last change on May 26, 2010 1:37:53 PM by  Daniel Zobel [Product Manager]



8 Replies

Accepted Answer

Votes:

0

Your Vote:

Up

Down

This article applies to PRTG Network Monitor 13.2.3 through 17.3.33

Customizing Login Screen: Removing the Forgot Password Link

Important note: The current customization approach is unsupported and deprecated as of versions 17.3.34/17.4.35. This customization no longer works. For more details, see How can I re-brand and customize the PRTG web interface using CSS and Javascript?

The preferred solution is to offer a customized login screen to your users, see: How do I customize the PRTG web interface's login screen?

The second best solution is to remove the <a href="/public/forgotpassword.htm">...</a> code from the HTML templates

As of PRTG 13.2.3 or later, find these three files and remove the <a> link from the html.

  1. index.htm in the folder "PRTG Newtork Monitor\webroot\"
  2. index.htm in the folder "PRTG Network Monitor\webroot\m\" (this path is deprecated as of PRTG version 16.3.26)
  3. login.htm in the folder "PRTG Network Monitor\webroot\public"

The HTML code must be removed from <a...> to </a>, including the translation placeholder:

<a class="nohjax" href="/public/forgotpassword.htm"><#lang key="html.index.htm.Forgotyourpassword1" default="Forgot password?"></a>

Afterwards I'd recommend making the file read only, otherwise it will be overwritten when you install an update of PRTG. But this also make it impossible for the installer to update these files in case we release new versions. So use this tip with care.

More

For more information see the instructions on How to Re-Brand and Customize the PRTG Web Interface Using CSS.


Previous (Deprecated) Versions

  1. PRTG 8 through 12: Find these three files and remove the <a> link from the html.
    1. "loginform.htm" in the folder "PRTG Network Monitor\website\includes"
    2. "login.htm" in the folder "PRTG Network Monitor\website\public"
    3. "index.htm" in the folder "PRTG Network Monitor\website\"
  2. PRTG 7: Find the file "loginform.htm" in the folder "PRTG Network Monitor\website\includes" and remove the <a> link from the html.

Created on May 13, 2010 12:42:54 PM by  Dirk Paessler [Founder Paessler AG] (10,983) 3 5

Last change on Mar 22, 2018 12:19:37 PM by  Brandy Greger [Paessler Support]



Votes:

0

Your Vote:

Up

Down

Hello-

I have three files that reference the forgotten password line:

  • login.htm
  • loginform.htm
  • index.htm

I have removed the <a> link from all three files (I even tried to change some of the text in these files), saved the files, but the login page does not change. I've restarted the PRTG server and gone to the login page from another browser/computer just to make sure that the page wasn't cached, but I can't get this to change/update. Any ideas?

Created on May 18, 2011 5:43:28 PM by  stonetear (0) 1

Last change on May 19, 2011 3:51:49 PM by  Daniel Zobel [Product Manager]



Votes:

0

Your Vote:

Up

Down

@stonetear: I have updated the answer above. Your changes should suffice. Please make sure your web browser reloads the page (Shift/CTRL-F5) and that the web browser looks at exactly the PRTG installation that you changed the files for.

Created on May 19, 2011 11:32:47 AM by  Dirk Paessler [Founder Paessler AG] (10,983) 3 5

Last change on May 19, 2011 3:52:06 PM by  Daniel Zobel [Product Manager]



Votes:

0

Your Vote:

Up

Down

Yes, that's what I'm saying. Even after changing all three of those files, restarting PRTG, and trying from several different browsers, the link remains. I've removed the entire line from <a> to </a> for the line that references the forgotten password text and link. Very puzzled here!

Created on May 19, 2011 1:34:23 PM by  stonetear (0) 1



Votes:

0

Your Vote:

Up

Down

Please make sure you actually edited the files at the right location and clear your browser cache.

Created on May 20, 2011 10:16:10 AM by  Daniel Zobel [Product Manager]



Votes:

0

Your Vote:

Up

Down

I have done so.

I have also tried editing some basic text in welcome.htm (simply adding or removing words), saving the file, restarting PRTG, trying from multiple computers, and the text does not change. It's almost like PRTG is caching a copy itself somehow, or drawing the text from an alternate 'original' copy of the file.

I'm not sure what I could be missing, it's very straight forward. Edit htm file, restart PRTG server service, try to load page from three different PCs, making sure that the caches are cleared.

I know this works for some files, because I have successfully modified many of the other files (including CSS files), but some values/website files refuse to display updated text no matter how many times I edit them, restart the server, or refresh my browsers.

Created on May 27, 2011 1:01:50 PM by  stonetear (0) 1



Votes:

0

Your Vote:

Up

Down

When editing HTML file of PRTG you must make sure that you do not edit text inside the <#LANG> placeholders, e.g.

<#lang key="html.welcome.box4a" default="Download the Windows GUI">

If you change this text you are only changing the internal default value of the string inside the translation system. No change will be visible on the site, because the string which is used by the web server is taken from the selected language file, not the HTM template file. So you should remove the <#lang ...> placeholder and replace it with your own text.

Note 1: If you edit file of PRTG your changes will be overwritten by the installer the next time you install an update!

Note 2: A restart of the server service is not required when you change the htm files. PRTG does not cache the files itself (it relies on the OS' file cache)

Created on Jun 2, 2011 2:31:54 PM by  Dirk Paessler [Founder Paessler AG] (10,983) 3 5



Votes:

1

Your Vote:

Up

Down

Another option is to leave pages mentioned above intact and change the functionality of the forgotpassword.htm page.

Locate the \webroot\public\forgotpassword.htm file, remove all content (after having made a safety copy first) and paste the code from below:

<!DOCTYPE HTML>
<html lang="en-US">
    <head>
        <meta charset="UTF-8">
        <meta http-equiv="refresh" content="1;url=login.html">
        <script type="text/javascript">
            window.location.href = "login.html"
        </script>
        <title>Page Redirection</title>
    </head>
    <body>
         If you are not redirected automatically, follow the <a href='login.html'>link to login page</a>
    </body>
</html>

As a result, the user is linked back to the login page when he clicks the 'forgot password' link.

This way, all pages mentioned above can remain unchanged and updates of PRTG will automatically include possible new login pages, not requiring you to repeat any steps.

The new forgotpassword.htm file will need to be flagged as read-only

Created on Apr 15, 2015 12:50:12 PM by  PRTG Tools Family [prtgtoolsfamily.com] (13,263) 3 4

Last change on Apr 16, 2015 8:08:01 AM by  Daniel Zobel [Product Manager]



Please log in or register to enter your reply.


Disclaimer: The information in the Paessler Knowledge Base comes without warranty of any kind. Use at your own risk. Before applying any instructions please exercise proper system administrator housekeeping. You must make sure that a proper backup of all your data is available.