New Question
 
 
PRTG Network Monitor

Intuitive to Use.
Easy to manage.

200.000 administrators have chosen PRTG to monitor their network. Find out how you can reduce cost, increase QoS and ease planning, as well.

Free PRTG
Download >>

 

What is this?

This knowledgebase contains questions and answers about PRTG Network Monitor and network monitoring in general. You are invited to get involved by asking and answering questions!

Learn more

 

Top Tags


View all Tags


Directions for configuring nic?

Votes:

0

Your Vote:

Up

Down

Have configured SPAN on a Catalyst 2950 (the source port is the same port connecting our firewall device to the LAN), and connected the second nic on the server running PRTG Network Monitor to the destination port.

Is there any trick to configuring ip settings for that second nic? I at first had it obtain ip by dhcp and it defaulted to the 169.254.x.x range. I then gave it an ip in our subnet range 172.16.1.0/24.

Also, I'm ONLY seeing UDP traffic to port 138 from my Packet Sniffer sensor.

Feeling like I've missed a basic step - any help would be greatly appreciated!

prtg sniffer span vmware

Created on May 31, 2010 8:01:56 PM by  malik_showers (50) 1 1

Last change on Jun 2, 2010 7:29:56 AM by  Daniel Zobel [Paessler Support]



Best Answer

Accepted Answer

Votes:

0

Your Vote:

Up

Down

Thanks for your reply.

That basic step that I missed: enabling promiscuous mode on the second nic. For anyone running the PRTG software on a VMWare VM, this KB article is helpful: http://communities.vmware.com/message/371531

I enabled promiscuous mode through the VMWare Infrastructure Client and immediately saw better results for the sensor. Will update if there are any other issues.

Created on Jun 1, 2010 12:32:59 PM by  malik_showers (50) 1 1



3 Replies

Votes:

0

Your Vote:

Up

Down

The IP of the second NIC can be a private one like 192.168.x.x—it does not really matter.

Can you check with e.g. wireshark http://www.wireshark.org/

Are you getting more than just the UDP traffic on that interface?

Created on Jun 1, 2010 11:58:26 AM by  Aurelio Lombardi [Paessler Support]

Last change on Jun 2, 2010 7:27:15 AM by  Daniel Zobel [Paessler Support]



Accepted Answer

Votes:

0

Your Vote:

Up

Down

Thanks for your reply.

That basic step that I missed: enabling promiscuous mode on the second nic. For anyone running the PRTG software on a VMWare VM, this KB article is helpful: http://communities.vmware.com/message/371531

I enabled promiscuous mode through the VMWare Infrastructure Client and immediately saw better results for the sensor. Will update if there are any other issues.

Created on Jun 1, 2010 12:32:59 PM by  malik_showers (50) 1 1



Votes:

0

Your Vote:

Up

Down

Further update.

I've now moved Network monitor onto a physical machine, rather than a vm guest. In my case, the sniffer sensor could identify all broadcast packets, but lumped all other traffic under the "Other" protocol. ie I could not see any details for that traffic, such as WWW, Mail, etc.

My best guess is there was some switch > virtual switch miscommunication. Not very well versed in the subject, but I want to update this post in case anyone else stumbles across the same issue.

I'll peruse the Wireshark forums later when I have the time - with the popularity of VMWare and appliance packages, I'm sure this has been solved at some point.

Created on Jun 4, 2010 12:52:41 PM by  malik_showers (50) 1 1



Please log in or register to enter your reply.


Disclaimer: The information in the Paessler Knowledge Base comes without warranty of any kind. Use at your own risk. Before applying any instructions please exercise proper system administrator housekeeping. You must make sure that a proper backup of all your data is available.