New Question
 
 
PRTG Network Monitor

Intuitive to Use.
Easy to manage.

200.000 administrators have chosen PRTG to monitor their network. Find out how you can reduce cost, increase QoS and ease planning, as well.

Free PRTG
Download >>

 

What is this?

This knowledgebase contains questions and answers about PRTG Network Monitor and network monitoring in general. You are invited to get involved by asking and answering questions!

Learn more

 

Top Tags


View all Tags


I receive a Bad Gateway error using XenServer Host sensors. What can I do?

Votes:

0

Your Vote:

Up

Down

When adding Citrix XenServer Host sensors to the corresponding device in PRTG, I do not receive any data, but the sensors are down and return the error message “The remote server returned an error: (502) Bad Gateway.” However, calling the sensor executable file XenServerRRDSensor.exe from the command line with the same parameters PRTG uses works and returns data. How can I resolve this issue?

502 citrix error error-messages host no-data prtg sensor xen xenserver

Created on May 29, 2013 1:07:44 PM by  Gerald Schoch [Paessler Support]

Last change on May 29, 2013 1:15:19 PM by  Gerald Schoch [Paessler Support]



1 Reply

Accepted Answer

Votes:

0

Your Vote:

Up

Down

This article applies to PRTG Network Monitor 13 or later

Resolving a (502) Bad Gateway Error for Citrix XenServer Host Sensor

If you receive the error message "The remote server returned an error: (502) Bad Gateway" with your XenServer Host sensors, first check if you have defined the correct proxy for your network in Control Panel | Network and Internet | Internet Options | Connections | LAN Settings

Make sure that these settings are correct. Then open a command prompt on the system PRTG is running on (or the remote probe), change the working directory to the /PRTG Network Monitor/Sensor System subfolder of your PRTG installation directory.

Run the following command to get a list of all hosts with their IDs on your system: XenServerRRDSensor.exe -host=<host> -user=<user> -pass=<password> -act=listHosts -https=true

Then run the following command and use a host ID retrieved with the previous command: XenServerRRDSensor.exe -host=<host> -user=<user> -pass=<password> -act=getHostDetails -id=<hostId> -freq=60 -https=true

If the XenServerRRDSensor.exe command works from your user account and you can retrieve data from your host, then most likely your local system user’s proxy settings refuses PRTG to connect to your host with this sensor type.

Changing Proxy Settings for the Local System

In order to resolve this issue, please do not use a proxy for your local system. You can change proxy settings with the Windows tool BITSAdmin. This is a command line tool you can use to create download or upload jobs and monitor their progress. For more details and how to get the tool, please refer to Microsoft’s Dev Center:

With the following command on your system you can specify proxy settings for your service account: bitsadmin /Util /SetIEProxy LOCALSYSTEM NO_PROXY

The parameter LOCALSYSTEM specifies the type of service account for the proxy usage you define. NO_PROXY specifies the form of proxy detection to use, this is, not to use a proxy server for your local system.

If a proxy is needed for your network, you will have to modify the command accordingly to use your proxy.

Created on May 29, 2013 1:14:55 PM by  Gerald Schoch [Paessler Support]



Please log in or register to enter your reply.


Disclaimer: The information in the Paessler Knowledge Base comes without warranty of any kind. Use at your own risk. Before applying any instructions please exercise proper system administrator housekeeping. You must make sure that a proper backup of all your data is available.