New Question
 
 
PRTG Network Monitor

Intuitive to Use.
Easy to manage.

200.000 administrators have chosen PRTG to monitor their network. Find out how you can reduce cost, increase QoS and ease planning, as well.

Free PRTG
Download >>

 

What is this?

This knowledgebase contains questions and answers about PRTG Network Monitor and network monitoring in general. You are invited to get involved by asking and answering questions!

Learn more

 

Top Tags


View all Tags


PRTG blocks port 80 although I'm using SSL on port 443. How to free port 80?

Votes:

1

Your Vote:

Up

Down

In PRTG Server Administrator, I've set PRTG to SSL. All connections to the PRTG web interface go through port 443. Still, PRTG does not allow another application to use port 80 (I get an error message in the other application).

How can I clear port 80?

port prtg redirect registry ssl web-interface

Created on Jun 8, 2010 9:06:15 AM by  Daniel Zobel [Paessler Support]

Last change on Jul 21, 2010 1:52:00 PM by  Daniel Zobel [Paessler Support]



9 Replies

Accepted Answer

Votes:

2

Your Vote:

Up

Down

This article applies to PRTG Network Monitor 12 or later

PRTG Automatically Determines What Ports to Use

You've set the PRTG web server to use SSL on port 443. However, on startup the PRTG server checks if port 80 is used on the host computer. If it is not, PRTG sets a redirect for port 80: All web connections to this port are redirected to port 443.

This is to avoid users seeing a "Connection failed" message in case they do not include https:// when calling the PRTG web interface.

If you want to use port 80 for other web applications this is—of course—an undesired behavior. There are two solutions for this.

Solution #1: Start Other Services Earlier than PRTG

If you start a program or service that uses port 80 prior to PRTG, port 80 will already be taken on PRTG startup and therefore not be blocked.

This can be achieved, for example, by changing settings in the Windows services. There, you could start the PRTG service depended on e.g. an Apache service so that the Apache web server starts first.

Solution #2: Registry Hack

If solution #1 is not possible in your case, you can add a registry entry that disables port 80 redirection for PRTG.

Important: Please make proper backup before editing the registry!

In the registry editor, go to

32bit: HKLM\Software\Paessler\PRTG Network Monitor\Server\Webserver
64bit: HKLM\Software\Wow6432Node\Paessler\PRTG Network Monitor\Server\Webserver

Note: For the deprecated PRTG versions 7 and 8, you might see the values in the additional sub-key V7 or V8.

There, create a new DWORD value with the name

NoSSLRedirect

Set this value to 1 to disable port 80 redirection. Set it to 0 to enable port 80 redirection again.


See Also

Created on Jun 8, 2010 9:07:52 AM by  Daniel Zobel [Paessler Support]

Last change on May 17, 2017 12:41:10 PM by  Gerald Schoch [Paessler Support]



Votes:

0

Your Vote:

Up

Down

Only for information: On 64 bit the reg path is

HKLM\SOFTWARE\Wow6432Node\Paessler\PRTG Network Monitor\Server\Webserver

Created on Jan 16, 2012 3:35:48 PM by  Manfred (0) 1

Last change on Jan 16, 2012 4:13:00 PM by  Daniel Zobel [Paessler Support]



Votes:

0

Your Vote:

Up

Down

Hello, this solution doesn't work when you use an other port for HTTP. We do not you SSL for PRTG. We have change the HTTP Port from 80 to 83 with the registry hack but with no luck.

Created on Feb 2, 2012 8:29:31 AM by  Manfred (0) 1



Votes:

0

Your Vote:

Up

Down

This hack does not change the HTTP Port, this only disables the redirect from port 80. So the only values which are accepted for 'NoSSLRedirect' are 1 and 0.

Created on Feb 2, 2012 3:39:20 PM by  Torsten Lindner [Paessler Support]



Votes:

0

Your Vote:

Up

Down

I know. The value "NoSSLRedirect" is set to 1. I have set the HTTP Port in the administration to 83 but PTRG use also port 80.

Created on Feb 3, 2012 12:07:38 PM by  Manfred (0) 1



Votes:

0

Your Vote:

Up

Down

Sorry, I made a mistake there, of course the registry hack only works when the PRTG Webserver is set to serve HTTPS on port 443. But if you set the Webserver to serve normal HTTP on another port than 80, port 80 will be free and not used by the "PRTG Server.exe".

Created on Feb 3, 2012 4:21:54 PM by  Torsten Lindner [Paessler Support]



Votes:

0

Your Vote:

Up

Down

Hi,

Before to install the product, I'd like to know if it's possible to set another ports thand 80 and 443 because they're already in use on my server.

Thanks,

Christophe

Created on May 30, 2018 1:24:10 PM by  crahier (0)



Votes:

0

Your Vote:

Up

Down

Hi there,

You can choose any other port that is free on the server. There are no fixed ports. You can change them in the "PRTG Administration Tool" under the "Web Server"-Tab:

Created on May 30, 2018 1:29:10 PM by  Dariusz Gorka [Paessler Support]

Last change on May 30, 2018 1:29:19 PM by  Dariusz Gorka [Paessler Support]



Votes:

0

Your Vote:

Up

Down

Hi,

Thanks, I could install it with the port 8080.

Christophe

Created on May 31, 2018 7:53:29 AM by  crahier (0)



Please log in or register to enter your reply.


Disclaimer: The information in the Paessler Knowledge Base comes without warranty of any kind. Use at your own risk. Before applying any instructions please exercise proper system administrator housekeeping. You must make sure that a proper backup of all your data is available.