New Question
 
 
PRTG Network Monitor

Intuitive to Use.
Easy to manage.

200.000 administrators have chosen PRTG to monitor their network. Find out how you can reduce cost, increase QoS and ease planning, as well.

Free PRTG
Download >>

 

What is this?

This knowledgebase contains questions and answers about PRTG Network Monitor and network monitoring in general. You are invited to get involved by asking and answering questions!

Learn more

 

Top Tags


View all Tags


How can I disable automatic numbering of new objects in the device tree?

Votes:

0

Your Vote:

Up

Down

When I create new objects in PRTG’s device tree like groups, devices, or sensors, I don’t want to have them automatically numbered. For example, there should be no number attached to sensor names when using the auto-discovery. Is there an option to disable auto-numbering?

auto-discovery auto-numbering device-tree number prtg reghack registry unsupported

Created on Jun 17, 2013 11:26:41 AM by  Gerald Schoch [Paessler Support]



6 Replies

Accepted Answer

Votes:

0

Your Vote:

Up

Down

This article applies to PRTG Network Monitor 13.2.4.2288/2289 or later

Disabling Automatic Numbering of Groups, Devices, and Sensors

When adding objects to your device tree in PRTG, an incrementing number is automatically attached to the names of new groups, devices, and sensors. The same is true for new objects added by PRTG’s auto-discovery.

However, it might be the case that you do not want these numbers within your object names. For this concern, there is a registry key option to centrally disable automatic numbering of objects in PRTG altogether. If you apply this registry hack, numbers are not attached to sensor names anymore when using the auto-discovery, for example.

Caution: Please back up your system before manipulating the Windows registry!

Steps to Go

  1. Open the registry editor and navigate to the following key:
    1. On a 64-bit Windows system, navigate to HKEY_LOCAL_MACHINE\Software\Wow6432Node\Paessler\PRTG Network Monitor\Server\Webserver
    2. On a 32-bit Windows version, navigate to HKEY_LOCAL_MACHINE\SOFTWARE\Paessler\PRTG Network Monitor\Server\Webserver
  2. Create a new DWORD: in the current path, right-click, choose New | DWORD Value, and name the new value AutonumbersOff
  3. Set the value of AutonumbersOff to 1: right-click on AutonumbersOff and select Modify…. In the value field, enter 1. Confirm with Ok.
  4. Reboot the server to activate the settings.

With this registry key option, new groups, devices, and sensors will not be automatically named with numbers any more. Setting the value of the DWORD to 0 will enable auto-numbering again.


Note: The result of the registry edit described above is the default behavior for new installations as of PRTG version 15.3.19. As of this version, PRTG does not have an automatic object numbering anymore. If you add new sensors, reports, maps, or libraries, the object name will not get a number appended.

To switch on automatic numbering for new installations, follow the instructions above and use 0 in the value field.

Created on Jun 17, 2013 11:29:32 AM by  Gerald Schoch [Paessler Support]

Last change on Sep 7, 2015 5:12:19 PM by  Gerald Schoch [Paessler Support]



Votes:

0

Your Vote:

Up

Down

In the current Version (17.3.33.2753) the numbering seems to be reintroduced. New Sensors created by Autodiscover will get a Number at the end of their Names. We started with a Version of PRTG prior to 15.3.19, we always had the Autonumbersoff set to 1 and no numbers were added ever since. but after the last update it just started again. Numbers will be added regardless of Autonumbersoff(Tested setting to 1 or removing the dword with restarting the core service in between)

what happened?

Created on Sep 11, 2017 10:07:56 AM by  pit (0)



Votes:

0

Your Vote:

Up

Down

Hello Pit,
thank you for your feedback.

I'm able to confirm your findings. When fixing something else, this was re-introduced as a bug. I'm able to confirm that the automatic numbering is broken in version 17.x.33. Version 17.x.34 (soon to be released) will fix the issue, but sensors that have been deployed already need to be renamed manually or re-added after the update to 17.x.34 to adjust the names.

Please keep an eye on our release notes for news:


Best Regards,
Luciano Lingnau [Paessler Support]

Created on Sep 11, 2017 12:02:11 PM by  Luciano Lingnau [Paessler Support]



Votes:

0

Your Vote:

Up

Down

Great! looking forward to it. i'll just stop creating new sensors until then :)

Created on Sep 12, 2017 2:34:16 PM by  pit (0)



Votes:

0

Your Vote:

Up

Down

I am also running in to problems with the auto numbering. The post from September 11th advised this will be resolved in version 17.x.34, when do we expect this version to be released?

Created on Nov 1, 2017 6:20:24 PM by  kyle (0)



Votes:

0

Your Vote:

Up

Down

Hello kyle,
thank you for the follow-up.

There has been a small delay as we're working hard on the new interface before the stable release. Version 17.x.34 will be skipped but version 17.x.35 is planned for release this month (November 2017) and will include all fixes from version .34 and other fixes as well.

Please excuse the delay, but we want to make sure that we deliver a smooth as possible stable version.

Best Regards,
Luciano Lingnau [Paessler Support]

Created on Nov 2, 2017 9:27:27 AM by  Luciano Lingnau [Paessler Support]



Please log in or register to enter your reply.


Disclaimer: The information in the Paessler Knowledge Base comes without warranty of any kind. Use at your own risk. Before applying any instructions please exercise proper system administrator housekeeping. You must make sure that a proper backup of all your data is available.