What is this?

This knowledgebase contains questions and answers about PRTG Network Monitor and network monitoring in general.

Learn more

PRTG Network Monitor

Intuitive to Use. Easy to manage.
More than 500,000 users rely on Paessler PRTG every day. Find out how you can reduce cost, increase QoS and ease planning, as well.

Free Download

Top Tags

View all Tags

Struggling to Get SNMP Working on Netgear DGN1000 Router



Hi all,

I've forwarded the SNMP ports/service on UDP 161 in and out of my DGN1000 router, sending the outbound directly to, my PC's static IP.

When I try to add an SNMP Bandwidth sensor to the auto-detected router, it fails: 'No response (check: firewalls, routing, snmp settings of device, IPs, SNMP version, community, passwords etc) (SNMP error # -2003)', and if I add the device manually, the same error occurs.

The help suggested I verify the community name, etc, but none of these options are available until the sensor has been planted, I had though, so I'm not sure what I should do.

- HateDread.

netgear router snmp

Created on Jul 10, 2013 8:58:06 AM

3 Replies



Where do you have PRTG set up? If you are forwarding the ports for SNMP to your computer, then if you are monitoring from outside the network, these requests would be being sent to the computer you described. When PRTG would request SNMP information, the requests would then be forwarded to the computer you specified and most likely this computer does not have SNMP enabled for a Bandwidth sensor.

If you are trying to monitor the router from the computer described, you should first check that SNMP is enabled on the device and set up correctly. The easiest way to do this would be to use the SNMP tester that we have. You can run it from the server running PRTG and see if you can read the up-time of the device. If you cannot, then something is not configured correctly with the Router.

You should also be able to query the router directly from a computer that is attached to the router and see the SNMP data.

Created on Jul 10, 2013 1:11:43 PM by  Greg Campion [Paessler Support]



Hi Greg, I have PRTG set up on the computer at the IP I listed - I am routing the SNMP information to this address. Your first paragraph reminded me to enable the SNMP service in Windows 7, which I have now done, but this has not fixed my issue.

I cannot connect to or read information from the router over SNMP using the tester application. Device IP is the router, at, and I am local IP For now, I am using the default community string 'public'. But under both SNMP V1 and V2c, I receive the same error as in my original post.

I realise this now points to another element of my network, i.e. the router setup or how my PC is receiving the SNMP information, but do you have any ideas / troubleshooting steps? I followed the instructions provided to me by Netgear tech support, port/service routing and all.

- HateDread.

Created on Jul 10, 2013 2:22:42 PM




If your computer running PRTG at the .10 address is directly connected to the Netgear router, you shouldn't need any routing rules set up in the router. You would want PRTG to send the Get requests directly to the router. Try removing the routes or port forwarding from the router and see if that works. If not, try temporarily disabling the firewall to see if it's blocking the traffic still.

Also, I noticed in the manual that SNMP is by default disabled so you will need to enable that as well which looks like is done through a menu not normally available. Are you able to read SNMP data from any other device? You may want to check that the firewall on the computer has the firewall open to receive the data back from the router.

Created on Jul 10, 2013 2:59:37 PM by  Greg Campion [Paessler Support]

Disclaimer: The information in the Paessler Knowledge Base comes without warranty of any kind. Use at your own risk. Before applying any instructions please exercise proper system administrator housekeeping. You must make sure that a proper backup of all your data is available.