What is this?

This knowledgebase contains questions and answers about PRTG Network Monitor and network monitoring in general.

Learn more

PRTG Network Monitor

Intuitive to Use. Easy to manage.
More than 500,000 users rely on Paessler PRTG every day. Find out how you can reduce cost, increase QoS and ease planning, as well.

Free Download

Top Tags

View all Tags

failure when set ssh script sensor in aix 5.3



when i add a ssh script sensor in aix 5.3 system。

the first time i can got the right value。 but only the first time is ok。 then prtg can't get any date from the sensor。

so i login in my aix system to check what happend。

i got this

1step:i run tcpdump for catching the communication packet。 but nothing i can get! (the tcp is established from prtg---to--aix when check in netstat -an )

2step:i run who -u in aix 。 it show a lot of account already login in the same user。 (this will take a long time then you can find a lot of same user)

3step:i run ps -ef to check the login process about the login user, it show the process were “Zombie process”

4step:when i killd the Zombie process all , the prtg can get the right value for ssh sensor again。 then the next time also can't get the value。

how can i solve this problem? thanks

aix prtg ssh

Created on Aug 16, 2013 9:10:54 AM

3 Replies




unfortunately there may be a hanging ssh-connection when your handles to files opened in your script are not completely closed.

Please refer to www.snailbook.com for further information.

Kind regards

Created on Aug 16, 2013 1:21:28 PM by  Dieter Loskarn [Paessler Support]



Thanks for u help.

But I still confused how to avoid the problem. And don't know what should I do .

First I'm pretty sure I have no problem with my sash script . It's ok when I add the same ssh script sensor in Linux ( redhat). It's just not work good in aix .

Sencond even I don't use the ssh advanced ssh script sensor . But use the ssh disk free sensor instead . It's still not work good in aix 5.3 . And it show the same situation I have described before (only first time can get the value , then the login user don't auto exit, and the login process became defunct )

Created on Aug 17, 2013 9:30:47 AM




unfortunately this issue is related with the version of the ssh-daemon running on the target system. If there is no updated version for AIX 5.3 you can't use the ssh-scripts.

Maybe it is a valuable way for you to use 'SNMP extensions' (see Net-SNMP tutorials for examples) to retrieve the information from the target server? Keep in mind that the snmp-sensors are only capable of processing a single value!

Kind regards

Created on Aug 19, 2013 1:16:10 PM by  Dieter Loskarn [Paessler Support]

Disclaimer: The information in the Paessler Knowledge Base comes without warranty of any kind. Use at your own risk. Before applying any instructions please exercise proper system administrator housekeeping. You must make sure that a proper backup of all your data is available.