New Question
 
 
PRTG Network Monitor

Intuitive to Use.
Easy to manage.

200.000 administrators have chosen PRTG to monitor their network. Find out how you can reduce cost, increase QoS and ease planning, as well.

Free PRTG
Download >>

 

What is this?

This knowledgebase contains questions and answers about PRTG Network Monitor and network monitoring in general. You are invited to get involved by asking and answering questions!

Learn more

 

Top Tags


View all Tags


My PowerShell sensor returns an error message. What can I do?

Votes:

0

Your Vote:

Up

Down

When I add a Windows Updates Status (PowerShell) sensor to my PRTG installation, an error message appears.

The error message is “An unknown security error occurred”. The connection to the remote server failed and WinRM is unable to process the request. There seems to be an issue with Kerberos authentication.

—or—

The error message is "No Logon Servers Available".

—or—

The error message is "Unauthorized Access".


I also get this error message after creating other PowerShell sensors. What can I do?

authentication error error-messages kerberos powershell prtg security windows-updates-status winrm

Created on Nov 8, 2013 3:54:41 PM by  Gerald Schoch [Paessler Support]

Last change on May 21, 2019 5:37:37 AM by  Maike Behnsen [Paessler Support]



4 Replies

Accepted Answer

Votes:

0

Your Vote:

Up

Down

This article applies to PRTG Network Monitor 19 or later

Tips for Running Sensors Using PowerShell Scripts

There are a few things to consider when using PowerShell sensors. This applies to pre-configured sensors, for example, the Windows Updates Status sensor, as well as to custom sensors that execute a PowerShell script, for example, the EXE/Script Advanced sensor. Please see below for possible resolution steps for PowerShell errors.

"Unknown Security Error" with PowerShell Sensors

If you add a PowerShell sensor to your PRTG installation, you may sometimes get an error message as given below (or similar). However, your computers are in the domain and credentials are valid.

In this case, use the FQDN (Fully Qualified Domain Name) instead of the IP address. You can specify the FQDN in the IPv4 Address/DNS Name field in the settings of the sensor’s parent device.

Error Message:

Connecting to remote server failed with the following error message: WinRM cannot process the request. The following error occurred while using Kerberos authentication: Unknown security error. Possible causes are: -The user name or password specified are invalid. -Kerberos is used when no authentication method and no user name are specified. -Kerberos accepts domain user names, but not local user names. -The Service Principal Name (SPN) for the remote computer name and port does not exist. -The client and remote computers are in different domains and there is no trust between the two domains. After checking for the above issues, try the following: -Check the Event Viewer for events related to authentication. -Change the authentication method; add the destination computer to the WinRM TrustedHosts configuration setting or use HTTPS transport. Note that computers in the TrustedHosts list might not be authenticated. -For more information about WinRM configuration, run the following command: winrm help config. For more information, see the about_Remote_Troubleshooting Help topic.

"No Logon Servers Available" with PowerShell Sensors

If WinRM cannot process the request and you get a No Logon Servers Available error, see I get the error "WinRM cannot process the request" when I try to use a Powershell Sensor.

"Unauthorized Access" with PowerShell Sensors

64-bit Windows systems run two PowerShell versions, the 64-bit and the 32-bit PowerShell version. Because PRTG calls the 32-bit PowerShell version, make sure that you set the correct execution policy not only for the 64-bit version, but also for the 32-bit version. The execution policy should be unrestricted: Set-ExecutionPolicy Unrestricted Otherwise, your PowerShell sensors will throw the error message Unauthorized Access. For more information, see Powershell 32bit or 64bit and Execution Policy.

Note: The user context may be different when the script is executed by the PRTG probe (this is the "LOCAL SYSTEM" account by default) and not by your Windows account when manually running the script.

Created on Nov 8, 2013 3:59:09 PM by  Gerald Schoch [Paessler Support]

Last change on Jul 12, 2019 8:22:14 AM by  Maike Behnsen [Paessler Support]



Votes:

0

Your Vote:

Up

Down

Hi,

I had the same problems: I had to install PowerShell 3.0 (with Management Framework 3) and path to 64bit-Version had to be added to path, system had to be rebooted to recognize the new path, execution policy had to be redefined. And I set the Scope to "LocalMachine". But I always get the following error (copy from
<localprobe>\C$\ProgramData\Paessler\PRTG Network Monitor\Logs (Sensors)
):

& : Die Datei "C:\Program Files (x86)\PRTG Network Monitor\custom 
sensors\EXEXML\PRTG-Veeam-SessionStats.ps1" kann nicht geladen werden, da die 
Ausfhrung von Skripts auf diesem System deaktiviert ist. Weitere 
Informationen finden Sie unter "about_Execution_Policies" unter 
"http://go.microsoft.com/fwlink/?LinkID=135170".
In Zeile:1 Zeichen:138
+ if ($PSVersionTable.PSVersion.Major -ge 5) { Import-Module 
Microsoft.PowerShell. ...
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
~~~
    + CategoryInfo          : Sicherheitsfehler: (:) [], PSSecurityException
    + FullyQualifiedErrorId : UnauthorizedAccess

What is the problem with line 1, Position 138. This is not MY script. Is there something running with the local probe before my script? Or is it the parser after the JSON / XML Result?

Thanks in advance.

KR

Created on Feb 24, 2017 7:44:19 AM by  Stefan (0)

Last change on Feb 24, 2017 8:35:33 AM by  Luciano Lingnau [Paessler Support]



Votes:

0

Your Vote:

Up

Down

Hello Stefan,
thank you for your post.

I kindly ask that you keep the communication about this custom script on the appropriate topic:

However, I'm already able to tell you that the following message:

kann nicht geladen werden, da die Ausführung von Skripts auf diesem System deaktiviert ist

Refers to the powershell execution policy. Keep in mind that the Probe is a 32-bit process and will use the 32-bits powershell, you have to configure the execution-policy in the 32-bits version of powershell. Please refer to:

Best Regards,
Luciano Lingnau [Paessler Support]

Created on Feb 24, 2017 1:02:33 PM by  Luciano Lingnau [Paessler Support]



Votes:

0

Your Vote:

Up

Down

Luciano,

THANK YOU. I set the restriction policy for the 32bit powershell (...\windows\SysWOW64\WindowsPowershell\v1.0\powershell.exe), now it works great.

KR

Stefan

Created on Feb 24, 2017 1:11:21 PM by  Stefan (0)

Last change on Feb 24, 2017 1:41:52 PM by  Luciano Lingnau [Paessler Support]



Please log in or register to enter your reply.


Disclaimer: The information in the Paessler Knowledge Base comes without warranty of any kind. Use at your own risk. Before applying any instructions please exercise proper system administrator housekeeping. You must make sure that a proper backup of all your data is available.