New Question
 
 
PRTG Network Monitor

Intuitive to Use.
Easy to manage.

200.000 administrators have chosen PRTG to monitor their network. Find out how you can reduce cost, increase QoS and ease planning, as well.

Free PRTG
Download >>

 

What is this?

This knowledgebase contains questions and answers about PRTG Network Monitor and network monitoring in general. You are invited to get involved by asking and answering questions!

Learn more

 

Top Tags


View all Tags


Monitor IIS app pools with a computer out of domain

Votes:

0

Your Vote:

Up

Down

Hello,

I'd like to monitor several IIS app pools on the same computer, which is out of the companys domain. Having about 15 IIS process running on this server, I would like to get the memory spent on each process, distinguished by the process username.

However, everytime I try to add one of those types of sensors, I get the same error message : "Could not log in using the specified credentials. Please make sure they are not only valid for the target system, but for the probe system aswell. (Performance Counter error 0xB0000004)"

The sensors I try to add are the following : -PerfCounter IIS Application Pool Sensor -Customized PerfCounter : \WebService(www.XXXXX.org)\MeasuredAsyncI/OBandwidthUsage

Thanks for all your replies.

Theo

iis perfcounter-custom performance-counters

Created on Dec 23, 2013 10:01:26 AM by  userFRC (0) 2



14 Replies

Votes:

0

Your Vote:

Up

Down

Using Performance Counter outside of a domain is quite tricky. The windows dll that is used here does not provide any possibility to use explicit credentials. It automatically uses the credentials of the user calling the dll. This is why we use "impersonation". That means, that the prtg thread, that is running the sensor is temporarily switched into the users context. This only works, if the same user is available on the probe system and on the target system. We strongly recommend to use a domain, but if this is not possible, you might try to add a user to the probe system, with the same login name and the same password as on the target device.

Created on Dec 23, 2013 5:26:35 PM by  Johannes Herrmann [Paessler Support] (1,320) 2 2



Votes:

0

Your Vote:

Up

Down

Hello,

Thanks for your reply. First of all, it is absolutely necessary to have this server outside the company's domain, as it belongs to our DMZ.

I tried to use this method to solve my problem.

Here's what I did:

-I created a user in my working domain, let's call it FRC, for the domain test.

-I created a user on the server outside the domain, whom is also named FRC, in the domain Workgroup.

-I created a new device, with the Windows credentials "server_name"\FRC, password and the IP of the server

-I added a customized performance counter with the following information:

\WebService(entreprise.forco.org)\ServiceUptime

Here is the error message I get :

Could not log in using the specified credentials. Please make sure they are not only valid for the target system, but for the probe system aswell. (Performance Counter error 0xB0000004)

When I change the domain of the device, to set domain = test, I get :

Unable to connect to the specified computer, or the computer is offline. (Performance Counter error 0x800007D0)

I then added administrator rights to the user FRC on the server, but this didn't change anything.

Thanks for your replies,

Regards,

Theo

Created on Feb 11, 2014 3:03:35 PM by  userFRC (0) 2



Votes:

0

Your Vote:

Up

Down

Theo,

First let's verify we have connectivity. Can you ping the IIS Server from the PRTG server? Next, can you upload a screenshot of the IIS Server Device settings in PRTG? Namely the section where it shows the Credentials to use when accessing the device.

Thanks!!

Created on Feb 11, 2014 4:10:00 PM by  Torsten Lindner [Paessler Support]



Votes:

0

Your Vote:

Up

Down

Thanks Torsten.

From the PRTG Probe where the device is created, I can ping the IIS Server.

I tried to make a combined screenshot of the IIS device settings on PRTG on the link below. Please note that this menu is in french, I hope you will understand the main content. http://www.freeimagehosting.net/newuploads/49r5g.png

Thanks ! Theo

Created on Feb 11, 2014 4:46:57 PM by  userFRC (0) 2



Votes:

0

Your Vote:

Up

Down

Theo,

So what is the name of the computer? Is it in a domain or a workgroup?

Thanks!

Created on Feb 11, 2014 8:33:09 PM by  Benjamin Day [Paessler Support]



Votes:

0

Your Vote:

Up

Down

Hello,

I wrote my answer yesterday but this has not been confirmed by the moderation.

I will try again to send it :

Here is my screenshot of the device settings panel in PRTG. As it is in french, please let me know if you need some translations.

http://www.freeimagehosting.net/newuploads/3x2hj.png

Regards,

Theo

Created on Feb 12, 2014 8:13:53 AM by  userFRC (0) 2



Votes:

0

Your Vote:

Up

Down

Theo,

You need to change the domain name to the name of the computer and try testing again. Can you give this a try and let me know what happens?

Created on Feb 12, 2014 4:24:26 PM by  Benjamin Day [Paessler Support]



Votes:

0

Your Vote:

Up

Down

Hello,

This doesn't work.

Below, I compiled 3 screenshots to show you what happens :

First part : I changed the name of the domain to F01S052, that is the name of the server.

Second part : I still get the same error messages even if I try to refresh my sensors

Third part : if I try adding a new "IIS Windows application" sensor, I get the following error message.

http://www.freeimagehosting.net/newuploads/cvh7a.png

Thanks for all your replies.

Best regards,

Theo

Created on Feb 12, 2014 4:57:40 PM by  userFRC (0) 2

Last change on Feb 14, 2014 8:20:21 AM by  userFRC (0) 2



Votes:

0

Your Vote:

Up

Down

Theo,

Just wanting to make sure here, but you have verified the credentials you're giving PRTG work on the box, correct? Meaning, you can log into that box with those credentials, and have rights to IIS.

Thanks!

Created on Feb 13, 2014 11:33:48 PM by  Benjamin Day [Paessler Support]



Votes:

0

Your Vote:

Up

Down

If you mean that I can successfully log on the server with, for example, a TSE, yes this works, I can connect to the remote server with those credentials. I also added the account into local administrators group so that I am pretty sure I have the rights to IIS.

Thanks,

Theo

Created on Feb 14, 2014 8:19:37 AM by  userFRC (0) 2



Votes:

0

Your Vote:

Up

Down

Theo,

The only reason I ask is because this is returning the Microsoft error for Access Denied. This isn't a PRTG error. Can you try opening the IIS console on that server while logged in as this user?

Created on Feb 14, 2014 8:42:43 AM by  Benjamin Day [Paessler Support]



Votes:

0

Your Vote:

Up

Down

I just opened the IIS console with the user svc_telephonie and it works fine. Regards

Created on Feb 14, 2014 8:50:16 AM by  userFRC (0) 2



Votes:

0

Your Vote:

Up

Down

Hello,

I can go on the IIS console and browse the website while logged in as svc_telephonie, the user used to access the device from PRTG.

Created on Feb 18, 2014 2:28:50 PM by  userFRC (0) 2



Votes:

0

Your Vote:

Up

Down

Theo,

Sorry for the delayed response. After discussing with our support guys, they recommend you install a remote probe on that server, and connect it to your core server. Once you link the remote probe and the core server, you can put sensors on this IIS box, and the remote probe will handle the authentication and permissions issues.

Please use the link below to install the remote probe. http://www.paessler.com/manuals/prtg8/install_a_prtg_remote_probe

Again, I apologize for the delay. Let me know if you have any issues getting the Remote Probe installed.

Created on Feb 18, 2014 3:17:37 PM by  Benjamin Day [Paessler Support]



Please log in or register to enter your reply.


Disclaimer: The information in the Paessler Knowledge Base comes without warranty of any kind. Use at your own risk. Before applying any instructions please exercise proper system administrator housekeeping. You must make sure that a proper backup of all your data is available.