What is this?

This knowledgebase contains questions and answers about PRTG Network Monitor and network monitoring in general.

Learn more

PRTG Network Monitor

Intuitive to Use. Easy to manage.
More than 500,000 users rely on Paessler PRTG every day. Find out how you can reduce cost, increase QoS and ease planning, as well.

Free Download

Top Tags

View all Tags

Google Chrome crashes when viewing maps. What can I do?



When showing maps in Google Chrome, the browser crashes completely after a while. If I reload the dashboard manually with F5, it is shown correctly again. However, I do not encounter this problem with dashboards when using Firefox or other browsers.

Why do these crashes happen and what can I do?

browser browser-crash chrome crash dashboard maps prtg

Created on Jan 15, 2014 3:36:06 PM by  Gerald Schoch [Paessler Support]

1 Reply

Accepted Answer



This article applies to PRTG Network Monitor 18 or later

Maps Crash Google Chrome

While showing your PRTG maps as web pages in Google Chrome, your web browser might crash regularly. This error is caused by a memory leak in Google Chrome that comes along in combination with hardware acceleration. At some point, Chrome runs out of memory and, thus, crashes.

In order to avoid this bug until Google provides a fix, you have to disable hardware acceleration regarding the Graphics Processing Unit (GPU). Please see the following steps for a workaround.

How can I check if I'm affected?

You can check this in Google Chrome under Settings | More tools | Task manager. Look for the GPU Process entry. If the memory usage is very high, try one of the workarounds.


There are two options get around this issue. Please try the first option if you can use a different browser. If you cannot use this approach, try the second one.

Option 1: Switch to Firefox

We recommend that you use Mozilla Firefox because it does not have this memory leak issue.

If you cannot switch browsers, please try the following approach:

Option 2: Disable Hardware Acceleration

  1. Open Google Chrome.
  2. Open the browser settings. Enter the following in the address bar: chrome://settings
  3. Scroll down and choose Advanced at the bottom. Show Advanced Chrome Settings
  4. Scroll down to section System.
  5. Disable Use hardware acceleration when available. Disabled Hardware Acceleration
  6. Relaunch Google Chrome and open your PRTG maps again.

This workaround will not solve the issue completely. Disabling hardware acceleration may only help to a certain extent.

Created on Jan 15, 2014 3:38:45 PM by  Gerald Schoch [Paessler Support]

Last change on Mar 21, 2018 11:07:53 AM by  Gerald Schoch [Paessler Support]

Disclaimer: The information in the Paessler Knowledge Base comes without warranty of any kind. Use at your own risk. Before applying any instructions please exercise proper system administrator housekeeping. You must make sure that a proper backup of all your data is available.