What is this?

This knowledgebase contains questions and answers about PRTG Network Monitor and network monitoring in general.

Learn more

PRTG Network Monitor

Intuitive to Use. Easy to manage.
More than 500,000 users rely on Paessler PRTG every day. Find out how you can reduce cost, increase QoS and ease planning, as well.

Free Download

Top Tags

View all Tags

WMI Custom Sensor - No data since startup



Dear PRTG Community

We have copied the following WMI Script to the folder of PRTG (Program Files (x86)\PRTG Network Monitor\Custom Sensors\WMI WQL scripts\):

select name, Orchestrationstatus from MSBTS_Orchestration where name ='Orchestrationname.BizTalk.ITOB.Notification.Main'

We want now to Monitor the Biztalk on a remote machine. We add a custom WMI String Sensor with the namespace "Root\MicrosoftBizTalkServer" and the value "4" that to be returend as return value.

We have full admin rights, dcom configured as well, checked the Port 135, and firewall ist don't enabled. but the sensor still not working:

No data since startup

Can anyone help us please?

prtg wmi wmi-custom-sensor

Created on Jan 21, 2014 9:51:52 AM

3 Replies




thank you very much for your KB-Post. Please bear in mind that the WMI Custom Sensors can only read one field. Please reduce the WQL-Query to only select one column / field. Either 'name' or 'Orchestrationstatus'.

best regards.

Created on Jan 21, 2014 3:11:08 PM by  Torsten Lindner [Paessler Support]



Hello Torsten Our Query give us only one field/result back. We know, that PRTG only can read 1 field. so this is not the problem :-C

Created on Jan 21, 2014 4:04:36 PM



The query definitely selects two columns / fields. Please reduce this to one. Please do try this first.

Created on Jan 21, 2014 4:13:33 PM by  Torsten Lindner [Paessler Support]

Disclaimer: The information in the Paessler Knowledge Base comes without warranty of any kind. Use at your own risk. Before applying any instructions please exercise proper system administrator housekeeping. You must make sure that a proper backup of all your data is available.