New Question
 
 
PRTG Network Monitor

Intuitive to Use.
Easy to manage.

200.000 administrators have chosen PRTG to monitor their network. Find out how you can reduce cost, increase QoS and ease planning, as well.

Free PRTG
Download >>

 

What is this?

This knowledgebase contains questions and answers about PRTG Network Monitor and network monitoring in general. You are invited to get involved by asking and answering questions!

Learn more

 

Top Tags


View all Tags


HTTP error 401 unauthorized

Votes:

0

Your Vote:

Up

Down

Hi,

I have this message when I want to monitor a webpage, even if i specify an AD account that have rights. Could you please help me ?

Thanks

Simon RENAUD | CAPSULE IT System Administrator

9b Villa Pierre Ginier, 75018 Paris, France Phone: 01.84.17.12.02 | Cell Phone: 06.87.52.03.90 | Fax: 01.53.34.14.09 [email protected] | www.capsuletech.com

401 error http

Created on Feb 4, 2014 2:16:13 PM by  licensing-it (0) 1



5 Replies

Votes:

0

Your Vote:

Up

Down

What kind of sensor are you using and what type of webpage are you trying to access? If there is a form that you need to enter credentials in, you may need to do this in a POST format to gain access to the site first.

Created on Feb 5, 2014 11:12:05 AM by  Greg Campion [Paessler Support]



Votes:

0

Your Vote:

Up

Down

Hello,

I think I encounter the same issue, I am absolutely sure of the credential, I can use them to login on the page from anywhere. Same issue => https://kb.paessler.com/en/topic/26533-is-there-a-workaround-for-this-error-http-1-1-401-unauthorized

There is a form to login to be granted to the page.

I tried to change the method to POST as mentioned, I tried to change SNI Inheritance, Protocol Version, I tried to add the credential with domain\username and only username.

I am trying the HTTP (with special cred in device) and HTTP Advanced, and also HTTP Data Advanced.

the URL: http://feto1s112:889/

This is the result's page of APP-V (Microsoft Application Virtualization):

This XML file does not appear to have any style information associated with it. The document tree is shown below. <Publishing Protocol="1.0"> <Packages> <Package PackageId="9abf2a94-dc7c-4abf-8897-bf425b0662d4" VersionId="5ed07d43-4ae7-481f-8e75-ffb87c8d63a5" PackageUrl="
fednet.local\domdata\APPV\MindManager 9\MindManager 9.appv"> <DeploymentConfiguration ConfigurationId="219" Path="policies_2494/30/219" Timestamp="2013-07-10T08:36:28.203"/> <UserConfiguration ConfigurationId="40" Conflict="false" Path="policies_2494/30/40" Timestamp="2013-01-08T13:08:41.917"/> </Package> <Package PackageId="6339018a-896a-44ea-8231-68c98f9dae7f" VersionId="87e3ab54-6cbd-4c2b-9be5-f6260611b133" PackageUrl="
fednet.local\domdata\APPV\Odyscube V7.2-1\Odyscube V7.2.appv"> <UserConfiguration ConfigurationId="1121" Conflict="false" Path="policies_2494/397/1121" Timestamp="2017-02-14T14:34:22.763"/> </Package> </Packages> <NoGroup> <Package PackageId="9abf2a94-dc7c-4abf-8897-bf425b0662d4"/> <Package PackageId="6339018a-896a-44ea-8231-68c98f9dae7f"/> </NoGroup> </Publishing>

Created on Feb 12, 2018 8:16:38 AM by  Yann (300) 1 1



Votes:

0

Your Vote:

Up

Down

Hi there,

Where did you specified the credentials? Please make sure that you use the correct GET/POST parameters in order to send the login details. If you are unsure, then please forward us screenshots of the website you are connecting to and the sensor settings via mail to [email protected]. Please refer to "PAE994632" in the subject.

Best regards.

Created on Feb 12, 2018 11:29:14 AM by  Dariusz Gorka [Paessler Support]



Votes:

0

Your Vote:

Up

Down

Hi,

thanks for your quick reply. This is an internal URL, you won't reach it. But it is for APP-V, it seems to be a result of a web service. I specified the credentials in the device with the HTTP sensor, "HTTP Advanced" and "HTTP Data Advanced" directly in the sensor.

It seems to work with "HTTP XML/REST Value" sensor! But I have to enter credentials directly in the sensor. Shouldn't the sensor inherit credentials from his parent (the device)?

Also I really appreciate the possiblity to open a ticket, but isn't better for all the find a solution direcly here?

Created on Feb 12, 2018 12:56:26 PM by  Yann (300) 1 1



Votes:

0

Your Vote:

Up

Down

Hi there,

Please note that credentials for HTTP-Sites are only added in the sensor itself. There is no credential object in the device/group settings. But, I am glad that it is working now. :)

About the ticket, we usually post the answer of the customer. Unfortunately, in this case the customer didn't send us any information and the thread is already 4 years old.

Best regards.

Created on Feb 12, 2018 1:08:58 PM by  Dariusz Gorka [Paessler Support]

Last change on Feb 12, 2018 1:10:01 PM by  Dariusz Gorka [Paessler Support]



Please log in or register to enter your reply.


Disclaimer: The information in the Paessler Knowledge Base comes without warranty of any kind. Use at your own risk. Before applying any instructions please exercise proper system administrator housekeeping. You must make sure that a proper backup of all your data is available.