What is this?

This knowledgebase contains questions and answers about PRTG Network Monitor and network monitoring in general. You are invited to get involved by asking and answering questions!

Learn more

PRTG Network Monitor

Intuitive to Use. Easy to manage.
More than 500,000 users rely on Paessler PRTG every day. Find out how you can reduce cost, increase QoS and ease planning, as well.

Free Download

Top Tags


View all Tags

strange problem about execute programm (PRTG Monitoer)

Votes:

0

Your Vote:

Up

Down

I am sorry, but my problem is that i want to

- send an Email via the notifications and - execute a bat file that is doing some things on a remote pc

and it did not work.

I received the mail but the script wont work.

So i brought down the problem to a very very simple bat script like

** @echpo off echo this_is_atest >test.txt ****

and select that in the notification. I have checked it on starting by hand and the file "text.txt" appears.

If i test the notication i receive the mail but the second step, the txt file would not be createt.

I am doing that with administrative rights on the Server.

The strange is, that i have other bat Files using in exactly the same way and they work.

Without any idea whats going on there i resartet the server and tryed really all i can do, - different users different rights different scripts but nothing helps.

So do you have a idea whats wrong there?

Thank you

Regards

Guenter

execute-programms notifications prtg

Created on Feb 20, 2014 10:53:17 AM by  guenterfrank (0) 1



3 Replies

Votes:

0

Your Vote:

Up

Down

Are you running this script with admin privileges specifically or do you have the Core service running with Admin credentials? Have you tried to create the txt file in a specific location instead of having PRTG create the file in it's own directory?

Created on Feb 20, 2014 5:50:03 PM by  Greg Campion [Paessler Support]



Votes:

0

Your Vote:

Up

Down

Hi thanks for the Replay,

i tried both, the Service is runnung with (Domain) Administrative credidentals so i left the fields for the User , Domain parameters ect blank. I have also tried to work it out with the (Domain) administrattor but nothinhg happens.

The bat file ist in the EXE Folder in Notifications and i selectet ist from the drop down menue in the notification.

We are using the latest version of prtg, (updatet yesterday)

Very strange is, that we are using another script in another notification an that works.

So i have deletet my notificatition, cloned the working notification, replace the field i needed with the test.bat, tried it but that also wont work...

Is there any thing i can do now?

Regards, have a nice weekend

Guenter

Created on Feb 21, 2014 6:12:48 AM by  guenterfrank (0) 1



Votes:

0

Your Vote:

Up

Down

Have you tried to change the script to write to a specific directory? Also, if you are executing this script through a remote probe, have you copied the exe to that probe?

Created on Feb 21, 2014 4:30:33 PM by  Greg Campion [Paessler Support]



Please log in or register to enter your reply.


Disclaimer: The information in the Paessler Knowledge Base comes without warranty of any kind. Use at your own risk. Before applying any instructions please exercise proper system administrator housekeeping. You must make sure that a proper backup of all your data is available.