What is this?

This knowledgebase contains questions and answers about PRTG Network Monitor and network monitoring in general. You are invited to get involved by asking and answering questions!

Learn more

PRTG Network Monitor

Intuitive to Use. Easy to manage.
More than 500,000 users rely on Paessler PRTG every day. Find out how you can reduce cost, increase QoS and ease planning, as well.

Free Download

Top Tags


View all Tags

SNMP Delay setting not keeping after saving change

Votes:

0

Your Vote:

Up

Down

We are running 14.1.8.1371 and using SNMP sensor to probe a Promise vtrak 610FD causes the SAN to have it's SNMP service timeout due to the number of requests per second. I've tried setting the SNMP Delay but after appling it (either at the PRTG server level, Group Level or device level) resets it back to zero.

Is there a place in the registry/file/db where I could change this so the number of requests per ms doesn't overwhel the vtrak unit?

snmp snmp-delay vtrak

Created on Mar 18, 2014 3:31:53 PM by  Nathaniel (0) 1



5 Replies

Votes:

0

Your Vote:

Up

Down

Hello,

thank you very much for your KB-Post. May I ask, to which value are you trying to set the SNMP Delay? Also, which browser are you using here? Does this also happen on other input fields in PRTG?

best regards.

Created on Mar 19, 2014 1:50:49 PM by  Torsten Lindner [Paessler Support]



Votes:

0

Your Vote:

Up

Down

Hi,

I tried setting it to a range of values from 300ms, 500ms, 1000ms, 2000ms to 5000ms none of which took. Other settings under the SNMP compatibility were keeping when changed (single line get vs. multiple line get).

I am using the PRTG enterprise console which I guest would use my IE11.

Using wireshark I can see each request from the PRTG server going across to the SAN at about 5-10 get requests per second which overloads the SNMP service on the SAN.

Created on Mar 19, 2014 1:55:40 PM by  Nathaniel (0) 1



Votes:

0

Your Vote:

Up

Down

I'm afraid the "SNMP Delay" is limited to 0 ... 100 milliseconds in PRTG. Other inputs will be disregarded (there should be a validation in the input field, but this is sadly broken in the moment, but will be fixed soon). Please try 100 as the largest possible value instead.
Here you may also consider using a longer scanning interval on all SNMP Sensors checking the SAN, that should distribute the SNMP Requests over more time.

Created on Mar 19, 2014 2:32:30 PM by  Torsten Lindner [Paessler Support]



Votes:

0

Your Vote:

Up

Down

Thanks Torsten,

I've increased the delay to 100 milliseconds and set the scan delay to 30 seconds however watching wireshark for SNMP requests to that vTrak SAN shows it having trouble answering all of PRTG's snmp walk requests when I select the sensor library. The MIBs I'm using for this unit are about 1/4 of what is available to the device, but PRTG is still crawling the entire tree, breaking the service. A ticket with Promise says they are not going to resolve this issue with the service so I'm wondering if Paessler could make an option on the MIB scan sensor to only walk the SNMP for the MIBs defined (including the walk to the initial leaf of the SNMP MIB if required).

Created on Mar 21, 2014 2:28:24 PM by  Nathaniel (0) 1



Votes:

0

Your Vote:

Up

Down

A target SNMP Service, that doesn't survive a simple SNMP Walk isn't really a good SNMP Service to be honest. During adding of SNMP Library Sensor PRTG might indeed do a SNMP Walk, but it shouldn't not do that anymore when the sensors are added. This can't be changed, you could try though gathering the OIDs (that you need to monitor), and then use SNMP Custom Sensors to monitor those.

Created on Mar 21, 2014 3:04:09 PM by  Torsten Lindner [Paessler Support]



Please log in or register to enter your reply.


Disclaimer: The information in the Paessler Knowledge Base comes without warranty of any kind. Use at your own risk. Before applying any instructions please exercise proper system administrator housekeeping. You must make sure that a proper backup of all your data is available.