What is this?

This knowledgebase contains questions and answers about PRTG Network Monitor and network monitoring in general. You are invited to get involved by asking and answering questions!

Learn more

PRTG Network Monitor

Intuitive to Use. Easy to manage.
300.000 administrators have chosen PRTG to monitor their network. Find out how you can reduce cost, increase QoS and ease planning, as well.

Free Download

Top Tags


View all Tags

HTTP SSL Certificate Expiry error: URLs do not match

Votes:

0

Your Vote:

Up

Down

Error message: "The URLs in the Sensor Settings and in the Certificate do not match. If the server uses SNI set 'Force SSL V3' to 'No' in the sensor settings."

This error first appeared after upgrading to 14.1.9.1442, prior to upgrading the sensor reported correctly and without error. I've seen elsewhere that the command to run it manually is at \PRTG Network Monitor\Sensor System\SSLCertExpiration.exe, so I ran it manually with only the -u switch (same url as entered in PRTG). It reports the correct information, no errors.

If I copy the executable into the \Custom Sensors\EXE folder and run it that way (using the same -u in parameters) it reports successfully.

Is this a bug in this version?

exe-script-sensor html sslcertexpiration

Created on Mar 26, 2014 8:04:46 PM by  crenstrom (1) 1



6 Replies

Votes:

0

Your Vote:

Up

Down

Further updates: I found some sensors failed when there was a trailing slash after the server name, e.g. https://server.domain.com/. Removing the slash fixed these. However, if the server name on the certificate can't be resolved via dns the check still fails.

The issue I can't resolve is if the dns name doesn't match the certificate. Seems in previous versions this check did not check the name on the certificate... can this check be selectively disabled? Some servers have a certificate for a domain which cannot be registered in our dns, e.g. https://server.anotherdomain.local (connected via vpn), https://server (no domain on cert).

Created on Mar 27, 2014 1:15:25 PM by  crenstrom (1) 1



Votes:

0

Your Vote:

Up

Down

Could you try updating to the newest version to see if that resolves the issue? If the newest version (14.1.9) isn't available for the Auto-Update you can download the software from the Customer Service Center. In order to access the download link to the newest version please log into your online account and download it there. Please use the email address the license is registered to and your password to log in here: https://service.paessler.com/en/login/

Once you have downloaded the newest version there, you can install it directly over the version currently running.  The configuration and database will not be affected by installing the newer version over the old and the configuration is automatically backed up before this process.

Created on Mar 27, 2014 2:03:04 PM by  Torsten Lindner [Paessler Support]



Votes:

0

Your Vote:

Up

Down

We also have this issue - the DNS name in the cert does not contain the internal name of the server and fails the expiry.

This was working for us before - it has only happened since the recent update.

Created on May 1, 2014 11:20:09 AM by  Mark Gold (2) 1



Votes:

0

Your Vote:

Up

Down

To ignore the name of an SSL sensor is an option that we have put back into the sensor. If you are on the newest version, you should be able to select this option in the sensor settings and it will ignore the name.

Created on May 1, 2014 12:38:22 PM by  Greg Campion [Paessler Support]



Votes:

0

Your Vote:

Up

Down

We have selected the option "accept any certificate" (I think this was previously set anyway) But still reports File not found

Created on May 2, 2014 10:57:05 AM by  Mark Gold (2) 1



Votes:

0

Your Vote:

Up

Down

Would it be possible to send us some screenshots of the error you are seeing to [email protected]?

Created on May 2, 2014 11:28:30 AM by  Greg Campion [Paessler Support]



Please log in or register to enter your reply.


Disclaimer: The information in the Paessler Knowledge Base comes without warranty of any kind. Use at your own risk. Before applying any instructions please exercise proper system administrator housekeeping. You must make sure that a proper backup of all your data is available.