What is this?

This knowledgebase contains questions and answers about PRTG Network Monitor and network monitoring in general.

Learn more

PRTG Network Monitor

Intuitive to Use. Easy to manage.
More than 500,000 users rely on Paessler PRTG every day. Find out how you can reduce cost, increase QoS and ease planning, as well.

Free Download

Top Tags

View all Tags

Factory Sensor Scan Interval




I've setup a factory sensor with a series of channels added in and noticed "No Data" due to the factory sensor scanning more frequently than the channels do.

I've adjusted the scanning interval of the factory sensor, but it remains to scan at a 60sec interval (default), instead of the increased time (10minutes).

Is there something I'm missing here?

channel factory prtg sensor

Created on Apr 2, 2014 4:36:20 PM

8 Replies



Please try restarting the core service of PRTG via the Server Admin tool and then check if the scanning interval is saved. If not, please try to change the setting to a different value and save the settings again.

If this doesn't work either, please create a new sensor factory with a scanning interval that suits your needs.

Created on Apr 3, 2014 2:13:20 PM by  Stephan Linke [Paessler Support]



I've done both suggestions and the sensor factory remains at 60sec interval. I created another sensor factory with one channel and it did the same, ignoring the set value of the interval and re-scanning every 60 seconds.

Created on Apr 3, 2014 11:45:03 PM



Sorry for the late reply, I had to talk to a developer first since the factory sensor itself is pretty special.

Are you running the latest version of PRTG? Because the factory sensor itself works like this:

{{{ Sensor - 30 minute interval

Channel - 10 minute interval }}} The Sensor itself will only show the values it gets from the various channels each 30 minutes. It will never trigger an extra scan for the channel.

What I'm trying to say is that the scanning interval is completely independent and you should be able to set it to any value you want.

If you're not on the latest version, please use the auto update or download the latest stable version from https://www.paessler.com/prtg/history/stable

Created on Apr 7, 2014 1:40:16 PM by  Stephan Linke [Paessler Support]



We're running

I'll see if we can update to the latest build and see if that makes any difference.

I tried to create a third test factory sensor, monitoring a single channel of CPUs from a server and it wouldn't go beyond 60 seconds on the factory sensor.

The CPU check I believe is 10 seconds, so the channel's interval is independent from the factory sensor's interval, as you mentioned.

If updating to the latest build doesn't help, what would be the next option to try?

Created on Apr 7, 2014 2:53:14 PM



I updated to the latest build and the issue remains.

I attempted at modifying the parent object of the sensor to another interval (5 minutes) and tried to inherit the properties from that on the factory sensor, but it didn't take. The factory sensors remain at a 60 second interval.

This is how I have the factory sensor setup.

  1. 1:CPU LOAD channel(47601,1)

Primary Channel: CPU Load (%)

The other options are defaults.

Created on Apr 7, 2014 3:45:26 PM



I see. If you don't mind, I'll check back with the developer of the sensor itself, but he probably won't be available until next week. I'll be in touch with you as soon as I got any more information, if thats okay with you? Thank your for your patience! :)

Created on Apr 9, 2014 8:58:30 AM by  Stephan Linke [Paessler Support]



This is fine, keep me posted.


Created on Apr 9, 2014 7:32:06 PM



Could you please open a support ticket for that case ([email protected])? We'd like to have a look at screenshots of the factory sensor screen (including graphs) and the settings of the affected sensor? Thank you :)

Created on Apr 10, 2014 2:32:34 PM by  Stephan Linke [Paessler Support]

Disclaimer: The information in the Paessler Knowledge Base comes without warranty of any kind. Use at your own risk. Before applying any instructions please exercise proper system administrator housekeeping. You must make sure that a proper backup of all your data is available.