What is this?

This knowledgebase contains questions and answers about PRTG Network Monitor and network monitoring in general.

Learn more

PRTG Network Monitor

Intuitive to Use. Easy to manage.
More than 500,000 users rely on Paessler PRTG every day. Find out how you can reduce cost, increase QoS and ease planning, as well.

Free Download

Top Tags

View all Tags

Sensor SNTP



I have some Windows PCs. PING and FreeDiskSpace sensors working except SNTP on all of them. I get "The server did not return a valid time (code: PE085)". On Linux machines it works without problems. Is there any workaround on this?

pe085 sntp valid-time

Created on Apr 10, 2014 8:29:02 PM

5 Replies



In my case this problem affects only Windows 7 x64. Windows XP x32 works fine.

Created on Apr 11, 2014 6:11:42 PM




are the devices you are adding this sensor to all running an the NTP service? The device you add the senor to has to be an NTP server!

Created on Apr 14, 2014 11:15:14 AM by  Aurelio Lombardi [Paessler Support]



No, it was not running. Nor on Windows 7 nor on Windows XP. Windows XP was working fine though sometimes it was stopping returning NTP values. Start --> Run --> GPedit.msc --> [Enter] --> Local Computer Policy --> Computer Configuration --> Administrative Templates --> System --> Windows Time Service --> Time Providers --> Windows NTP Server --> Enable. Now both Windows XP and Windows 7 are working. Thank you!

Created on Apr 16, 2014 7:23:33 AM



After I enabled NTP server my sensor says the server did not return a valid time (code: PE085), I also start the windows time in services.msc

How can I configure this sensor?

Created on Jan 23, 2015 5:12:17 AM



  1. In mostly cases I just try to sync compuers time with the real NTP server. In my case the PRTG core machine and client computers are syncing with the same NTP server.
  2. If above does not work, I try to modify registry further: HKLM\SYSTEM\CurrentControlSet\Services\W32Time\Config\AnnounceFlags to "5"
    HKLM\SYSTEM\CurrentControlSet\Services\W32Time\TimeProviders\NtpServer\Enabled to "1"
    HKLM\SYSTEM\CurrentControlSet\Services\W32Time\TimeProviders\VMICTimeProvider\Enabled to "0"
    The last key is not in every Windows distribution and I leave it as it is. Then
    Start --> Run --> net stop w32time
    Start --> Run --> net start w32time

In one of my cases none of the above solutions helped me and I'm seeking to resolve this problem as well.

Created on Jan 23, 2015 11:01:55 PM

Last change on Jul 29, 2016 5:27:23 AM by  Sebastian Kniege [Paessler Support]

Disclaimer: The information in the Paessler Knowledge Base comes without warranty of any kind. Use at your own risk. Before applying any instructions please exercise proper system administrator housekeeping. You must make sure that a proper backup of all your data is available.