New Question
 
 
PRTG Network Monitor

Intuitive to Use.
Easy to manage.

200.000 administrators have chosen PRTG to monitor their network. Find out how you can reduce cost, increase QoS and ease planning, as well.

Free PRTG
Download >>

 

What is this?

This knowledgebase contains questions and answers about PRTG Network Monitor and network monitoring in general. You are invited to get involved by asking and answering questions!

Learn more

 

Top Tags


View all Tags


IMAP sensor not working properly

Votes:

0

Your Vote:

Up

Down

We got a lot of IMAP sensors against one mailbox, cheking backup tasks. Recently, we've detected that sensors are reporting false positives, 'cause there are mails inside mailbox reporting backup failures. But, sensors are giving ok status after all...

SENSOR CONFIGURATION:

IDENTIFY EMAIL--> Process emails in this mailbox Mailbox Name --> Inbox Identify by "From" Field --> Check using string search Search For --> Identify by "Subject" Field --> Check using regular expression Search For --> (?=.*\bDibuix\b).* Identify by Mail Body --> Don't check Check Last Message Date --> Check for new messages received within the last x hours Warning Threshold (Hours)--> 24 Error Threshold (Hours)--> 26 SENSOR BEHAVIOR Set to Alarm --> If mail body contains Check Method -->String search Search Text --> (?=.*\berror\b).*Error Message

INBOX MAIL

FROM: SUBJECT: Alerta de CA ARCserve Central Host-Based VM Backup-Copia de seguridad de máquinas virtuales-Copia de seguridad completa Estado de la tarea:Incorrecto(vmName:DIBUIX; nodeName:) BODY: Tipo ID de tarea Hora Mensaje Información 566 21/04/2014 0:40:23 Se han cerrado los archivos VMDK de la máquina virtual. Error 566 21/04/2014 0:40:22 Se ha producido un error en la tarea de copia de seguridad.

As you can see, FROM, SUBJECT and BODY coincide with sensor configuration. What am I doing wrong?

imap imap-sensor search smtp-imap string

Created on Apr 25, 2014 9:12:31 AM by  jdr (0) 1

Last change on May 6, 2014 8:52:33 AM by  Torsten Lindner [Paessler Support]



3 Replies

Accepted Answer

Votes:

0

Your Vote:

Up

Down

Hello,

thank you very much for your KB-Post. Please try the IMAP-Sensor first without filters. Does it work then? Please also make sure, that you are on the latest PRTG Version (14.2.9) as well as that no other tool/client access the target inbox (this includes webmail clients).

best regards.

Created on May 6, 2014 8:53:37 AM by  Torsten Lindner [Paessler Support]

Last change on May 6, 2014 1:18:34 PM by  Torsten Lindner [Paessler Support]



Votes:

0

Your Vote:

Up

Down

Hello,

i have a similar Problem. On our Backup Software we are running five Jobs and each of them report an own E-Mail to the same Inbox. The Problem is that even though i put the Check Last Message Date to 24h the Sensor shows only the state of te last incoming E-Mail. I´ve read in the Sensor description that the point "Check Last Message Date" is defined es "mails that were received within the last x hours", but it isn´t working iin Practice.

Created on Apr 21, 2016 8:06:14 AM by  daniel-demeter (0) 1



Votes:

0

Your Vote:

Up

Down

Daniel, can you please send us some screenshots showing the full sensor settings via email to [email protected] (with a note to this KB-Thread)? Also, do any other tools / applications access the inbox (including webmail)?

Created on Apr 22, 2016 9:54:26 AM by  Torsten Lindner [Paessler Support]



Please log in or register to enter your reply.


Disclaimer: The information in the Paessler Knowledge Base comes without warranty of any kind. Use at your own risk. Before applying any instructions please exercise proper system administrator housekeeping. You must make sure that a proper backup of all your data is available.