What is this?

This knowledgebase contains questions and answers about PRTG Network Monitor and network monitoring in general.

Learn more

PRTG Network Monitor

Intuitive to Use. Easy to manage.
More than 500,000 users rely on Paessler PRTG every day. Find out how you can reduce cost, increase QoS and ease planning, as well.

Free Download

Top Tags

View all Tags

Custom OID not working



We have an AKCP sensorprobe 2 and I'm having trouble getting the temperature value from it.

The testing I have done so far

- I have downloaded iReasoning MIB Browser, loaded the MIB for the sensor probe and correctly queried the custom OID and it does return the current temperature.

- I have downloaded the Pessler SNMP Tester 5.1.2, entered the custom OID and matched all the settings to make the same query, and the SNMP Tester returns an error

Value: No response (check: firewalls, routing, snmp settings of device, IPs, SNMP version, community, passwords etc) (SNMP error # -2003)

Both tests were conducted from the PRTG server using the same local user account. The firewall on the PRTG server is OFF and the AKCP Sensorprobe is running the latest version of its code.

I'm not sure why from the same server, same local account and seemingly everything else the same, the MIB Browser can return the right value, but SNMP Tester can not.

Any ideas on what else to try?

custom-oid prtg snmp-error#2003

Created on Jun 24, 2014 9:53:00 PM

8 Replies




did you try to import the MIB with our MIB-Importer to monitor the target then with SNMP Library Sensors. Or at least try scanning against the target with the SNMP Tester and the resulting OIDLib. It may very well be that there is an index-number added to the OID, which should be handled with importing the MIB.

best regards.

Created on Jun 26, 2014 7:59:15 AM by  Torsten Lindner [Paessler Support]




I have loaded the MIB from the Sensorprobe using the MIB Importer. I located the resultant OIDLIB and loaded into the SNMP Tester and did a Scan OIDLIB.

I got these results

Paessler SNMP Tester 5.1.2
27/06/2014 6:24:26 AM (1 ms) : Device:
27/06/2014 6:24:26 AM (1 ms) : SNMP V2c
27/06/2014 6:24:26 AM (1 ms) : Scan OIDLIB C:\Program Files (x86)\PRTG Network Monitor\snmplibs\AKCP SensorProbe.oidlib
Scanning OIDs
from library: "C:\Program Files (x86)\PRTG Network Monitor\snmplibs\AKCP SensorProbe.oidlib"
on device:
27/06/2014 6:24:26 AM Start Scan
27/06/2014 6:24:26 AM SPAGENT-MIB|sp summary|sp status
27/06/2014 6:24:37 AM SPAGENT-MIB|sp summary|sp manuf name
27/06/2014 6:24:48 AM SPAGENT-MIB|sp summary|sp help url
27/06/2014 6:24:58 AM SPAGENT-MIB|sp summary|sp product name

Found OIDs:
No OIDs found

However, the MIBbrowser returned these results.

OID: .
Value: normal (2)
Type: Integer

OID: .
Value: AKCP
Type: OctetString

OID: .
Value: akcp.com/help/sp/index.html
Type: OctetString

OID: .
Value: sensorProbe2 v 2.0
Type: OctetString

The custom OID I am probing is .

and I get these values from the MIB brower sensorProbeTempDegree.0 23 Integer

I've only got about 15 days left in the trial period, and have lots of things to get working to justify the expense. This temperature probe is one of high importance to our environment so I'm keep to demo it.

Created on Jun 26, 2014 8:50:19 PM

Last change on Jun 27, 2014 9:26:54 AM by  Torsten Lindner [Paessler Support]



Were both tools executed on the same machine? Were the same SNMP Settings (Version, Port, Community String) used?

Created on Jun 27, 2014 9:30:38 AM by  Torsten Lindner [Paessler Support]



The SNMP tester is set to SNMP version 2c, where as the MIB browser just says version 2. No "c" is mentioned.

I've tried v1, which doesn't work and v3 isnt supported. Port is 161 on both tools and community string as public on both tools. I have even tried changing the community string to some other value with no success.

Created on Jun 29, 2014 8:14:17 PM



What were the results on both tools with SNMP v1? And also, both are running on the same machine?

Created on Jun 30, 2014 9:18:36 AM by  Torsten Lindner [Paessler Support]



Finally sorted it out, the login password(s) are the community strings. So I've changed the password to be public and its working fine now.


Created on Jun 30, 2014 8:39:01 PM



Hi, I have exact the same Problem. However I do not really understand your solution. What Password do you mean?

Created on Jul 22, 2014 9:28:43 PM



When you login to the web console of the ACKP monitor, the password that you enter in the password box, thats the community string. We has set the password to something we generally use internally but this actually changed the community name to the value of the password. Setting it back to public worked.

Created on Jul 23, 2014 8:34:02 PM

Disclaimer: The information in the Paessler Knowledge Base comes without warranty of any kind. Use at your own risk. Before applying any instructions please exercise proper system administrator housekeeping. You must make sure that a proper backup of all your data is available.