What is this?

This knowledgebase contains questions and answers about PRTG Network Monitor and network monitoring in general.

Learn more

PRTG Network Monitor

Intuitive to Use. Easy to manage.
More than 500,000 users rely on Paessler PRTG every day. Find out how you can reduce cost, increase QoS and ease planning, as well.

Free Download

Top Tags

View all Tags

PRTG Log and Data Store on Share?




I read all entries about the storage of PRTG and it sounds for me that it should work, but still it does not!

I want my PRTG Monitor (WinXP, to store its data and logs on a remote network share/drive (NAS) because the local host is working with CF as HDD. I do not want PRTG writing more then necessary on the local device.

I just played several scenarios, nothing works. I tested network mapping also as nfs. Either PRTG changes the directories by itself back to default or not and still writes on the local drive.

Is there any chance to get this managed? What could be the reason why it does not work?

Kind regards, pah

datastore nas network-share

Created on Nov 12, 2014 7:07:26 PM

4 Replies



Dear pah

This article provides a step-by-step instruction list to change the data path https://kb.paessler.com/en/topic/543

Please make sure that according to the article to stop the PRTG core service before you change the path.

Created on Nov 13, 2014 4:34:44 PM by  Arne Seifert [Paessler Support]




Thanks for your answer. I know this article very well and I tried any possibility to change the drive for logging but it will not work. I also tried to change it via registry, no chance.

Could it be a permission problem? Which user uses the Monitor/Probe to write the data? Maybe because the share is not writable for it? I think about his because "C:\Documents and Settings\All Users\Application Data\Paessler\PRTG Network Monitor" is the default location. Permissions there are:

Administrators (WORKGROUP/Administrators) CREATOR OWNER Power Users (WORKGROUP/Power Users) SYSTEM Users (WORKGROUP/Users)

On the share:

Everyone Lunix User (LINUX-WORKGROUP/User)

Why does it change back to default although an other path is defined? Feels like a routine which gets active if the location is not writable for example.

Kind regards, pah

Created on Nov 14, 2014 7:04:52 AM



Dear pah

Which Windows version are you using on the PRTG Server?

Created on Nov 14, 2014 3:24:54 PM by  Arne Seifert [Paessler Support]




It´s WIN microXP and the solution is to start the services in the user-context which also is permitted to write on the nas / network share. PRTG will only use the credentials from the context in which it was started.

Therefor it is recommended to change the Log On User from "Local System account" to "This account": .\user and in the Paesslers Admin-Tools for the Server & Probe to change the Logs-Directories to the new UNC-Path like:


Restart the services.

Under the "Local System Account" the credentials could never be correct to write on a share. That´s the simple reason!

Works fine now! Hope some one can use this information too.

Regards, pah

Created on Nov 15, 2014 10:33:08 AM

Disclaimer: The information in the Paessler Knowledge Base comes without warranty of any kind. Use at your own risk. Before applying any instructions please exercise proper system administrator housekeeping. You must make sure that a proper backup of all your data is available.