New Question
 
 
PRTG Network Monitor

Intuitive to Use.
Easy to manage.

200.000 administrators have chosen PRTG to monitor their network. Find out how you can reduce cost, increase QoS and ease planning, as well.

Free PRTG
Download >>

 

What is this?

This knowledgebase contains questions and answers about PRTG Network Monitor and network monitoring in general. You are invited to get involved by asking and answering questions!

Learn more

 

Top Tags


View all Tags


Problem with file-content sensor

Votes:

0

Your Vote:

Up

Down

Hi, I can't get the file content sensor to work properly. I get this error message every time:

Cannot access fil,e: The system cannot find file specified(2) (code: PE031)

I've checked some requirements: - File and path, seems correct and the string as well, tried different ones. - account privileges "account is domain admin" - Tried to recreate the sensor several times. - Tried on W2K8 and W2K12 servers.

Any ideas/thoughts?

Cheers R.

error file-content-sensor file-sensor

Created on Dec 8, 2014 1:12:25 PM by  roberto_76 (10) 1



Best Answer

Accepted Answer

Votes:

3

Your Vote:

Up

Down

Hey roberto,

try it with this string:

D$\MBI\Webserver\AppServer\Server1\logs\FarOut.log

You have to connect like from another server. If you try to connect to the folder from PRTG you do something like this:

connect to: <<domainname/ipadress>>\d$\MBI\Webserver\AppServer\Server1\logs\FarOut.log

With this, it will be correctly. Please try it out.

Thank's

Sascha

Created on Dec 9, 2014 12:32:30 PM by  Sascha Lewandowski (2,291) 3 4



7 Replies

Votes:

0

Your Vote:

Up

Down

Do you get the error every now and then, or is the error always there?

Could it be that this file gets recreated by a process instead of having data appended to it?

Created on Dec 9, 2014 8:41:49 AM by  PRTG Tools Family [prtgtoolsfamily.com] (12,885) 3 4



Votes:

0

Your Vote:

Up

Down

Hey roberto,

could it be, that you have anyway the wrong path? Could you post the path to your file, whats in the sensor settings?

The error says that the server can't finde the file you want to monitor. This could be the wrong path or other wrong settings.

With the path i could help you more.

It should look like this:

<<volume name ex. c$>>\<<foldername>>\<<filename>>

Not more, only folder names

The server name is from the "host" where the sensor takes place.

Best

Sascha

Created on Dec 9, 2014 8:51:34 AM by  Sascha Lewandowski (2,291) 3 4

Last change on Dec 9, 2014 8:54:16 AM by  Torsten Lindner [Paessler Support]



Votes:

0

Your Vote:

Up

Down

Hi There,

Thanks for your replies.

@PRTGTools: The error is always there, as soons when I resume the sensor it goes into error state.

@Sascha: This is the full path D:\MBI\Webserver\AppServer\Server1\logs\FarOut.log

I've checked the file "FarOut.log" the string I put there "exit" the word is in there and the file isn't changed.

Created on Dec 9, 2014 10:51:03 AM by  roberto_76 (10) 1



Accepted Answer

Votes:

3

Your Vote:

Up

Down

Hey roberto,

try it with this string:

D$\MBI\Webserver\AppServer\Server1\logs\FarOut.log

You have to connect like from another server. If you try to connect to the folder from PRTG you do something like this:

connect to: <<domainname/ipadress>>\d$\MBI\Webserver\AppServer\Server1\logs\FarOut.log

With this, it will be correctly. Please try it out.

Thank's

Sascha

Created on Dec 9, 2014 12:32:30 PM by  Sascha Lewandowski (2,291) 3 4



Votes:

1

Your Vote:

Up

Down

Please also note that d$ is an administrative share, this share will not be visible to the PRTG probe running on the local system account!

Created on Dec 9, 2014 12:43:35 PM by  PRTG Tools Family [prtgtoolsfamily.com] (12,885) 3 4



Votes:

0

Your Vote:

Up

Down

Ok, my fault, i've missed this information, thank's ;), but the credentials are from domain administrator.

So this will work for you ;), with local as @PRTGToolsFamily says, it won't.

Best

Sascha

Created on Dec 9, 2014 12:49:19 PM by  Sascha Lewandowski (2,291) 3 4



Votes:

0

Your Vote:

Up

Down

@Sascha: This did the trick:" "D$\MBI\Webserver\AppServer\Server1\logs\FarOut.log"

I don't prefer to use UNC path.

Thank you very much!

NB: PRTG IS case sensitive concerning given search string!

Created on Dec 9, 2014 2:30:46 PM by  roberto_76 (10) 1



Please log in or register to enter your reply.


Disclaimer: The information in the Paessler Knowledge Base comes without warranty of any kind. Use at your own risk. Before applying any instructions please exercise proper system administrator housekeeping. You must make sure that a proper backup of all your data is available.