New Question
 
 
PRTG Network Monitor

Intuitive to Use.
Easy to manage.

200.000 administrators have chosen PRTG to monitor their network. Find out how you can reduce cost, increase QoS and ease planning, as well.

Free PRTG
Download >>

 

What is this?

This knowledgebase contains questions and answers about PRTG Network Monitor and network monitoring in general. You are invited to get involved by asking and answering questions!

Learn more

 

Top Tags


View all Tags


Share Disk Free sensor and authentication Access denied (PE030)

Votes:

0

Your Vote:

Up

Down

I'm having issues with a sensor checking the free space on a fileshare I have setup: "Cannot access file share: Access is denied(5) (code: PE030)". The Netapp CIFS Share I try to monitor is accessable through a DFS path
my.domain.com\misc\netappvolumetocheck

Before deploying the sensor, I made sure the domain account I am using has permissions to the share and can browse to and open the files and folders on that share. The said domain account settings are stored in the sensor's parent device under "Inherit Credentials for Windows Systems".

Similar questions I have found in Knowledgebase didnt match. http://kb.paessler.com/en/topic/48173-cannot-access-file:-access-is-denied-5-code:-pe031

I have some other CIFS Shares on that netapp storage to monitor the same way and this works fine. I double checked the settings but cant find any setting- or syntax error in the config. What could go wrong here?

We are using PRTG 15.1.13.1090

account-settings cifs-share free-disk-space--5-

Created on Jan 15, 2015 1:16:09 PM by  René König (110) 1 2



Best Answer

Accepted Answer

Votes:

6

Your Vote:

Up

Down

Hello Greg,

thank's for your reply. I have found a solution for our problem.

We have round about 30 diskspacesensors connected via dfs-path in our PRTG environment. This works fine.

I have checked all the settings and tried a lot of different configurations to troubleshoot and at the end i have found it.

The way to provide a file share via DFS-Servers is important for the sensor. You have to use the FQDN in the DFS path.

eg. in the DFS Console you can set Namespace --> Path to folder -->


Fileservername\Filesharepath [or]
Fileservername.mydomain.com\Filesharepath

Users can access the provided fileshares via smb in both ways, but the diskspacesensor in our PRTG needs the FQDN to access successfuly.

Created on Jan 27, 2015 4:51:10 PM by  René König (110) 1 2



2 Replies

Votes:

1

Your Vote:

Up

Down

Unfortunately at this time this sensor doesn't work with DFS shares, you will have to monitor the shares directly on the hosts. The way that users authenticate through DFS is different than a normal share and our sensor cannot do this at this time. I have created a ticket to see if it's possible to change the sensor to allow this but I cannot say when or if this will be implemented. I will post here when I know more.

Created on Jan 20, 2015 1:21:03 PM by  Greg Campion [Paessler Support]



Accepted Answer

Votes:

6

Your Vote:

Up

Down

Hello Greg,

thank's for your reply. I have found a solution for our problem.

We have round about 30 diskspacesensors connected via dfs-path in our PRTG environment. This works fine.

I have checked all the settings and tried a lot of different configurations to troubleshoot and at the end i have found it.

The way to provide a file share via DFS-Servers is important for the sensor. You have to use the FQDN in the DFS path.

eg. in the DFS Console you can set Namespace --> Path to folder -->


Fileservername\Filesharepath [or]
Fileservername.mydomain.com\Filesharepath

Users can access the provided fileshares via smb in both ways, but the diskspacesensor in our PRTG needs the FQDN to access successfuly.

Created on Jan 27, 2015 4:51:10 PM by  René König (110) 1 2



Please log in or register to enter your reply.


Disclaimer: The information in the Paessler Knowledge Base comes without warranty of any kind. Use at your own risk. Before applying any instructions please exercise proper system administrator housekeeping. You must make sure that a proper backup of all your data is available.