New Question
 
 
PRTG Network Monitor

Intuitive to Use.
Easy to manage.

200.000 administrators have chosen PRTG to monitor their network. Find out how you can reduce cost, increase QoS and ease planning, as well.

Free PRTG
Download >>

 

What is this?

This knowledgebase contains questions and answers about PRTG Network Monitor and network monitoring in general. You are invited to get involved by asking and answering questions!

Learn more

 

Top Tags


View all Tags


How can I stop Google Chrome showing me a “connection not private” message?

Votes:

0

Your Vote:

Up

Down

Every time I connect to the PRTG web interface with a self-signed certificate, Google Chrome shows the security warning message “Your connection is not private”. Is there a possibility to prevent Google Chrome from showing this warning when I log in to my PRTG server?

browser certificate chrome prtg security server warning web-interface

Created on Feb 5, 2015 10:24:39 AM by  Martina Wittmann [Paessler Support]



8 Replies

Accepted Answer

Votes:

5

Your Vote:

Up

Down

This article applies to PRTG Network Monitor 15.3.18 or later

UPDATE: Stop Security Warnings in Google Chrome for Self-Signed Certificates

Google removed the chrome switch flag remember-cert-error-decisions that allowed users to proceed through SSL error for a specified length of time. It is no longer available in current Chrome browser versions (Chrome 44 and later).

Instead, Chrome remembers certificate decisions automatically for one week. (See the Google Chrome Help Forum.)

As a more durable solution, install your own SSL certificate for PRTG’s web server.

More




The following article is outdated as of Google Chrome version 44 or later!

This article applies to PRTG Network Monitor 14 or later

Stop Security Warnings in Google Chrome for Self-Signed Certificates

The security warning which Google Chrome shows when you connect to servers with a self-signed certificate generally includes the following lines: “Your connection is not private. Attackers might be trying to steal your information from [ip address] (for example, passwords, messages, or credit cards).”

Google Chrome Security Warning

Frequent security warnings in Google Chrome like this one cannot be completely stopped. You have to proceed to your PRTG server each time manually. However, you can disable these warnings for a certain period of time. For this purpose, you need to change settings in Google Chrome:

  1. Copy the following link into your Google Chrome browser: chrome://flags/#remember-cert-error-decisions
  2. Following the link, you directly get to the settings Remember decisions to proceed through SSL errors for a specified length of time. Google Chrome Settings for SSL Errors
  3. In the drop-down menu, choose the time period for which you want Google Chrome to stop showing the security warning.Google Chrome Setting Options for SSL Errors For example, if you choose Remember for three months, Google Chrome will not show the certificate security warning again for three months when you connect to the server on which PRTG is running or to another server with a self-signed certificate.

Created on Feb 5, 2015 10:36:04 AM by  Martina Wittmann [Paessler Support]

Last change on Oct 21, 2015 12:30:47 PM by  Martina Wittmann [Paessler Support]



Votes:

9

Your Vote:

Up

Down

For anyone who wants to tweak this setting, it is storred in

C:\Users\[username]\AppData\Local\Google\Chrome\User Data\Default\Preferences
"https://PRTGServer:443,https://PRTGServer:443": {
    "ssl-cert-decisions": {
        "cert_exceptions_map": {
             "4294967094nsxcyQoSU+DPgez1juXuW3ZApexi3tvmPNdt6A71F5Q=": 1
           },
           "decision_expiration_time": "13075818455660695",
           "guid": "7C7881E4-F277-4577-808F-0611817E2542",
           "version": 1
         }
     },

Created on Feb 10, 2015 12:49:56 PM by  PRTG Tools Family [prtgtoolsfamily.com] (12,885) 3 4



Votes:

2

Your Vote:

Up

Down

I had the exact same problem!!! This fixed it:

open network and sharing center On the left side- click on: change advanced sharing settings. click on home or work. go through and check "turn off" for the first three questions. turn on password. Your computer connection was wide open!!!!

Created on Apr 8, 2015 9:21:37 PM by  natureday_com (20)



Votes:

0

Your Vote:

Up

Down

When i put chrome://flags/#remember-cert-error-decisions into the chrome address bar, there seems to no longer be a setting for this. Anyone else seeing this?

Created on Oct 20, 2015 10:56:11 PM by  Tylerstoehr (0) 1

Last change on Oct 21, 2015 12:07:26 PM by  Martina Wittmann [Paessler Support]



Votes:

0

Your Vote:

Up

Down

Sadly Google removed the flag:

chrome:flags/#remember-cert-error-decisions

Created on Feb 28, 2016 12:42:06 AM by  Eugene van der Merwe (0)



Votes:

0

Your Vote:

Up

Down

Sometimes, it's a fault from the server. The issue may exist on your computer, such as wrong date and time, antivirus blocked SSL connections or something else.

I found a useful guide from Google, which will help you to <a href="https://usefulpcguide.com/16666/your-connection-is-not-private/ > resolve your connection is not private error immediately</a>. Check it out and give it a try.

Created on Jun 6, 2016 1:31:49 PM by  tonytran (0) 1

Last change on Aug 29, 2016 7:56:42 AM by  Torsten Lindner [Paessler Support]



Votes:

0

Your Vote:

Up

Down

Sometimes, it's a fault from the server. The issue may exist on your computer, such as wrong date and time, antivirus blocked SSL connections or something else. I found a useful guide from Google, which will help you to resolve your connection is not private error immediately</a>. Check it out and give it a try.

https://usefulpcguide.com/16666/your-connection-is-not-private/

Note: Edit to correct the link as the above was incorrect - 404 not found.

Created on Aug 27, 2016 12:03:56 PM by  tonytran (0) 1



Votes:

1

Your Vote:

Up

Down

Actually found a solution for this error that works. my chrome run sluggish and its giving sometimes has broken pages and privacy error following this Solution 2. on this website https://www.errorsolutions.tech/error/your-connection-is-not-private-chrome-error/ to sort this issue out.

Created on Feb 14, 2018 10:06:56 PM by  MariaDavidson911WN (10)



Please log in or register to enter your reply.


Disclaimer: The information in the Paessler Knowledge Base comes without warranty of any kind. Use at your own risk. Before applying any instructions please exercise proper system administrator housekeeping. You must make sure that a proper backup of all your data is available.