What is this?

This knowledgebase contains questions and answers about PRTG Network Monitor and network monitoring in general. You are invited to get involved by asking and answering questions!

Learn more

PRTG Network Monitor

Intuitive to Use. Easy to manage.
300.000 administrators have chosen PRTG to monitor their network. Find out how you can reduce cost, increase QoS and ease planning, as well.

Free Download

Top Tags


View all Tags

Gmail imap sensor read mail shows error

Votes:

0

Your Vote:

Up

Down

I used the imap sensor to read mail on Gmail A/C, but it showed the following error :

Error establishing secure connection ([TLS10-12] Socket Error # 10060 Connection timed out. [TLS10] Socket Error # 10060 Connection timed out. [SSL30] Socket Error # 10060 Connection timed out. [SSL20] Socket Error # 10060 Connection timed out.)

What's wrong with my setting ?

imap prtg sensor

Created on Mar 3, 2015 3:48:01 AM by  Jacky Leung (50) 1 1

Last change on Sep 23, 2016 10:58:51 AM by  Luciano Lingnau [Paessler]



Best Answer

Accepted Answer

Votes:

0

Your Vote:

Up

Down

it works after change of google setting :

Access for less secure apps -> turned on

round trip also works OK for Gmail.

But it doesn't work for Yahoo Mail and O365, how to solve it ?

Created on Mar 4, 2015 4:15:35 AM by  Jacky Leung (50) 1 1



12 Replies

Votes:

0

Your Vote:

Up

Down

Can you try to set the sensors transpot level security setting to "Use Transport-Level Security if available" and see if that works? Works within my local installation :)

Created on Mar 3, 2015 12:44:11 PM by  Stephan Linke [Paessler Support]



Votes:

0

Your Vote:

Up

Down

I tried all setting below but still failed !

TRANSPORT-LEVEL SECURITY

IMAP Specific

Use Transport-Level Security if available using StartTLS (default) Use Transport-Level Security if available Enforce Transport-Level Security using StartTLS Enforce Transport-Level Security

Any idea

Created on Mar 4, 2015 1:56:14 AM by  Jacky Leung (50) 1 1



Accepted Answer

Votes:

0

Your Vote:

Up

Down

it works after change of google setting :

Access for less secure apps -> turned on

round trip also works OK for Gmail.

But it doesn't work for Yahoo Mail and O365, how to solve it ?

Created on Mar 4, 2015 4:15:35 AM by  Jacky Leung (50) 1 1



Votes:

0

Your Vote:

Up

Down

Do you get the same error with them?

Created on Mar 4, 2015 8:11:11 AM by  Stephan Linke [Paessler Support]



Votes:

0

Your Vote:

Up

Down

imap round trip for O365 OK but the imap server is "smtp.office365.com", not "imap.office365.com", very strange

But imap for Yahoo still failed, same error.

Created on Mar 4, 2015 9:16:58 AM by  Jacky Leung (50) 1 1



Votes:

0

Your Vote:

Up

Down

Well it seems to work when you use the following settings:

SMTP

Server: smtp.mail.yahoo.com
Port: 587
Username: your-yahoo-user
Password: your-yahoo-password
Transport level security: Use transport level security if available

Can you try it with these settings? :) Remember to use the correct settings for the IMAP server in the configuration as well.

Created on Mar 5, 2015 12:44:30 PM by  Stephan Linke [Paessler Support]



Votes:

0

Your Vote:

Up

Down

tried but still failed, same error code 10060

Created on Mar 5, 2015 2:42:26 PM by  Jacky Leung (50) 1 1



Votes:

0

Your Vote:

Up

Down

Anything that blocks the communication between PRTG and yahoo? Are you on the latest version (15.1.14.1610)?

Created on Mar 6, 2015 8:47:56 AM by  Stephan Linke [Paessler Support]



Votes:

0

Your Vote:

Up

Down

Gmail is OK after Access for less secure apps -> turned on in gmail A/C

Any similar setting for Yahoo

Yahoo setting as follows :

smtp device : smtp.mail.yahoo.com imap sensor : port : 993 use transport-level security if available

version of PRTG : 15.1.14.1609

Created on Mar 6, 2015 8:54:27 AM by  Jacky Leung (50) 1 1



Votes:

0

Your Vote:

Up

Down

No I didn't have to set anything similar within my yahoo test account - in fact, there are no security settings like that in their account setup :(

Created on Mar 6, 2015 1:56:19 PM by  Stephan Linke [Paessler Support]



Votes:

0

Your Vote:

Up

Down

problem solved after change from smtp.mail.yahoo.com to imap.mail.yahoo.com

different setting for gmail and yahoo !!

Created on Mar 9, 2015 3:32:55 AM by  Jacky Leung (50) 1 1



Votes:

0

Your Vote:

Up

Down

If you have 2-step authentication turned on for Gmail, you'll need to retrieve an "app password". You can find App Passwords in "My Account" --> "Sign in & Security" --> "Signing in to Google"

Created on Feb 28, 2017 11:51:52 PM by  jhall (0)



Please log in or register to enter your reply.


Disclaimer: The information in the Paessler Knowledge Base comes without warranty of any kind. Use at your own risk. Before applying any instructions please exercise proper system administrator housekeeping. You must make sure that a proper backup of all your data is available.