What is this?

This knowledgebase contains questions and answers about PRTG Network Monitor and network monitoring in general. You are invited to get involved by asking and answering questions!

Learn more

PRTG Network Monitor

Intuitive to Use. Easy to manage.
More than 500,000 users rely on Paessler PRTG every day. Find out how you can reduce cost, increase QoS and ease planning, as well.

Free Download

Top Tags


View all Tags

Port Forwarding / Port Redirection to PRTG Server Administration Tool

Votes:

0

Your Vote:

Up

Down

I have the PRTG Server Administration Tool setup on https port 443 and wish to redirect form a different WAN port. I have Port Forwarded to 443 in the router, but it won't connect.

Please Advise

port-redirection prtg router

Created on Mar 3, 2015 8:27:16 PM by  kasper58 (0) 1



16 Replies

Votes:

0

Your Vote:

Up

Down

Dear Kasper58

Please check if you set up the port forwarding properly. Normally PRTG should connect when the port is forwarded.

Created on Mar 6, 2015 1:36:46 PM by  Arne Seifert [Paessler Support]



Votes:

0

Your Vote:

Up

Down

Aye Port Redirection set cor4ectly. It appears it may be an issue with my modem as it is sending the request to another server, even though the redirection is aimed at PRTG Server Administration Tool server.

Thanks for your help though.

Regards Warren

Created on Mar 6, 2015 2:26:48 PM by  kasper58 (0) 1



Votes:

0

Your Vote:

Up

Down

Please check if your router supports NAT loopback.

Created on Mar 6, 2015 2:37:25 PM by  Arne Seifert [Paessler Support]



Votes:

0

Your Vote:

Up

Down

Hi,

we are having the same problem with a WAN Port redirection.

Internally PRTGs Webserver listens to 443 and our WAN Port is i.e. 8443

After some analysis with Wireshark and Browser Debugging i found out that the PRTG WebServer is doing an HTTP-Redirect to the configured Port (443).

The result is: https://<PublicWANIP>:8443 is redirected back to https://<PublicWANIP>:443 by the PRTG Webserver at the HTTP Layer.

Hopefully this is a litle bit helpful.

The question is: Is there a configurable webserver parameter that stops the HTTP Portredirecting on the PRTG Server?

Regards Christian

Created on Nov 20, 2015 3:49:59 PM by  ChristianB (0) 1



Votes:

0

Your Vote:

Up

Down

Dear Christian

PRTG does not forward the HTTP port. Please check your router settings, or try to set the PRTG webserver to use port 8443 internally as well.

You can review / change the PRTG webserver port via the PRTG Administration Tool from the PRTG program group. Please enable the Expert Configuration to access the port setting.

Created on Nov 23, 2015 3:20:36 PM by  Arne Seifert [Paessler Support]



Votes:

0

Your Vote:

Up

Down

Hi,

using 443 as WAN Port is not acceptable for us. In the Expert Settings we have the manual setting to 443.

I re-checked this behavour with Firefox Developer Tools "Nework Analysis".

When i request the PRTG Site on 8443 from WAN i get no HTTP/200 Status like when i call it from internaly directly on 443. Instead PRTGs HTTP Response is: HTTP/302 - Moved Tempory -> Header:Location: https://<WAN-IP>:443/?

This is in fact something our firewal cannot change (it canncot look and change the SSL traffic between Browser and Server.

regards.

Created on Dec 1, 2015 11:02:50 AM by  ChristianB (0) 1



Votes:

0

Your Vote:

Up

Down

Dear Christian

Please clarify if you can set PRTG internally to 8443 and if you then still can access it from the outside on port 8443.

Created on Dec 1, 2015 12:16:40 PM by  Arne Seifert [Paessler Support]



Votes:

0

Your Vote:

Up

Down

Hi,

if both ports are the same (8443) i can access from external WAN IP.

Created on Dec 1, 2015 12:36:20 PM by  ChristianB (0) 1



Votes:

0

Your Vote:

Up

Down

Dear Christian

Is that a solution which you can work with?

Created on Dec 1, 2015 1:34:15 PM by  Arne Seifert [Paessler Support]



Votes:

0

Your Vote:

Up

Down

Hi,

as long as their is no solution, i have... :-/.

We will disable public access (app, ...) to the system as long there is no solution. Internally we have you use "well known" Ports due to restrictions of Proxy Server settings for the Clients and externally we do not want to use "well Known" Ports for security reasons.

regards Christian

Created on Dec 1, 2015 3:49:48 PM by  ChristianB (0) 1



Votes:

0

Your Vote:

Up

Down

Hi PRTG Support,

we have the very same situation as Christian. We need to use Port 443 to access PRTG internaly. However, for external access we need to use some port > 1023.

As Christian said, external access works fine as long as te external port and PRTGs local port are the same (no matter if 443 or 1101). But if we set PRTGs webserver to port 443 and configure our firewall to forward external port 1101 to port 443 on our PRTG server access fails.

Please advise. I hope there might be a solution to this, as morte than a year has pased since the post from Christian. Thanks a lot.

regards, Bernd

Created on Mar 29, 2017 2:02:54 PM by  Bernd (0) 1



Votes:

0

Your Vote:

Up

Down

Dear Bernd

I am sorry, the PRTG web server cannot be accessed via different ports. Only one port can be used by the web server.

Created on Mar 30, 2017 10:38:26 AM by  Arne Seifert [Paessler Support]



Votes:

0

Your Vote:

Up

Down

Older thread but issue still exists.

Little more info:

HTTP
http://external:80 -> http://internal:80 - works
http://external:8443 -> http://internal:443 - works
HTTPS
https://external:443 -> https://internal:443 - works
https://external:8443 -> https://internal:8443 - works

https://external:8443 -> https://internal:443 - does not work on 'high security' or 'weakened security'

PRTG is most definitely sending a 302 Moved Temporarily to https://external:443. For us this is a different webserver.

This appears to be a bug or something in the way PRTG is handling the HTTPS traffic when it originates from a different port. In the PRTG logs you can see it knows the request came from 8443 so my guess is this is PRTG trying to be smart and respond with, "we got your request but you used the wrong port, we are actually on port 443 now". It is strange that it only does this with HTTPS traffic though.

Created on Aug 1, 2017 3:41:00 AM by  87racer (0)

Last change on Aug 1, 2017 1:58:24 PM by  Arne Seifert [Paessler Support]



Votes:

0

Your Vote:

Up

Down

Dear 87racer

Which port did you configure for the PRTG web server, according to the PRTG Administration Tool (which is a standalone tool, found in the PRTG program group)?

Created on Aug 1, 2017 2:00:19 PM by  Arne Seifert [Paessler Support]



Votes:

0

Your Vote:

Up

Down

Hi guys... any update of this issue? i have the exact same problem...

Created on Aug 14, 2017 3:55:15 PM by  jesusrmz (0)



Votes:

0

Your Vote:

Up

Down

Dear jesusrmz,

please clarify 'this issue'. Do you want to connect to the PRTG webserver externally with a different port than is configured internally? That would not be possible.

Created on Aug 15, 2017 2:37:17 PM by  Arne Seifert [Paessler Support]

Last change on Aug 15, 2017 2:37:30 PM by  Arne Seifert [Paessler Support]



Please log in or register to enter your reply.


Disclaimer: The information in the Paessler Knowledge Base comes without warranty of any kind. Use at your own risk. Before applying any instructions please exercise proper system administrator housekeeping. You must make sure that a proper backup of all your data is available.