New Question
 
 
PRTG Network Monitor

Intuitive to Use.
Easy to manage.

200.000 administrators have chosen PRTG to monitor their network. Find out how you can reduce cost, increase QoS and ease planning, as well.

Free PRTG
Download >>

 

What is this?

This knowledgebase contains questions and answers about PRTG Network Monitor and network monitoring in general. You are invited to get involved by asking and answering questions!

Learn more

 

Top Tags


View all Tags


Discovery SSH host via non standart port

Votes:

0

Your Vote:

Up

Down

I use non standart ports on linux hosts, and specify it in group setttings, but discavery trying use only standart (22) port

discovery reports ssh

Created on Mar 13, 2015 6:18:12 AM by  krause_alexander (0) 1



4 Replies

Votes:

0

Your Vote:

Up

Down

Dear Alexander

Once you saved the template, please find it in the "devicetemplates" subfolder. Please open the odt file in a text editor. You should finde the port node

       <port>
          22
       </port>

You can change the port, save the file and use it for an autodiscovery.

Created on Mar 16, 2015 2:33:15 PM by  Arne Seifert [Paessler Support]

Last change on Mar 16, 2015 2:33:54 PM by  Arne Seifert [Paessler Support]



Votes:

0

Your Vote:

Up

Down

It is not work :(

I create device template, found file and found <port> section, then replace port number 22 to specific nember.

But after "Run autodiscovery with Template" no any ssh sensor found (as previously prtg probe trying connect by TCP 22 to my host)

Created on Mar 17, 2015 11:47:31 AM by  krause_alexander (0) 1



Votes:

0

Your Vote:

Up

Down

I think this problem because SSH check defined in line <check id=ssh meta=ssh ...> always use standard SSH port (22) and ignores any settings in host or group configuration.

This check executed before create SSH sensors and In my configuration this check fails and other SSH sensors not created as indicated in ODT file "requires=ssh" tag :

Half of workaround: create template file, change port to non standart and then change lines (on every SSH sensor line) for change "requires=ssh" tag to "requires=icmp" <create id={...} kind=sshdiskfree requires=ssh ...>

I understand correctly? This is a bug in the PRTG?

Created on Mar 17, 2015 12:50:26 PM by  krause_alexander (0) 1



Votes:

0

Your Vote:

Up

Down

Dear Alexander

Please try to delete the port node altogether. Is the template now using the port entered in the device settings? If that is not the case, please contact [email protected] and send the un-edited template as email file attachment.

Created on Mar 17, 2015 4:08:34 PM by  Arne Seifert [Paessler Support]



Please log in or register to enter your reply.


Disclaimer: The information in the Paessler Knowledge Base comes without warranty of any kind. Use at your own risk. Before applying any instructions please exercise proper system administrator housekeeping. You must make sure that a proper backup of all your data is available.