What is this?

This knowledgebase contains questions and answers about PRTG Network Monitor and network monitoring in general. You are invited to get involved by asking and answering questions!

Learn more

PRTG Network Monitor

Intuitive to Use. Easy to manage.
300.000 administrators have chosen PRTG to monitor their network. Find out how you can reduce cost, increase QoS and ease planning, as well.

Free Download

Top Tags


View all Tags

Windows Network Card - WMI - Failed to find valid network cards

Votes:

0

Your Vote:

Up

Down

Hi,

Whenever I try to add a Windows Network Card type sensor, I get the following error (or very similar to it, depending on the machine):

Failed to find valid network cards. Interface names ['Microsoft Virtual Machine Bus Network Adapter _5','MS TCP Loopback interface'] WMI Table [Win32_PerfRawData_Tcpip_NetworkInterface]

The odd thing this is that the PROBE's "Windows Network Card" sensors work just fine... just not for any other windows device on the network.

Regards,

Dave

network windows wmi

Created on Mar 26, 2015 12:19:33 PM by  airbiscuity (0) 1



Best Answer

Accepted Answer

Votes:

8

Your Vote:

Up

Down

We ran into this same error. What we found is the "#" in the device name caused the error. You can see it in the name "Microsoft Virtual Machine Bus Network Adapter _5", it's substituting an _ for the #. Remove the # altogether and you don't have that issue.

You can change it in the registry. You'll find the "FriendlyName" somewhere in HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\ for the NIC. That key has special permissions so the easiest way is to use psexec.

1. Open a command prompt as Administrator
2. Run psexec -s -i regedt32.exe
3. Navigate to registry key, change the FriendlyName to something without the #
4. Reboot

EDIT BY MOD: Changed formatting

Created on May 11, 2015 7:25:42 PM by  jasond (130) 1

Last change on May 12, 2015 1:10:59 PM by  Konstantin Wolff [Paessler Support]



13 Replies

Votes:

0

Your Vote:

Up

Down

Some additional information on this:

The WMI Network issues only started once going from free/trial edition to the paid edition where I had to install the paid edition of PRTG software.

I've also added a new probe to a brand new network, server is only 3 months old running server 2012r2. Same WMI network sensor problem. I've also tried temporarily disabling windows firewall, still the same problem occurs. The server has also been rebooted along with the external PRTG monitoring server.

The correct windows credentials are being used, and also the PRTG WMI tool can read WMI information without a problem.

.NET Framework 4 is installed as well.

See below for error when adding WMI Network Sensor:

Failed to find valid network cards. Interface names ['WAN Miniport [IP]','WAN Miniport [IPv6]','WAN Miniport [Network Monitor]','Microsoft Kernel Debug Network Adapter','Broadcom NetXtreme Gigabit Ethernet','Broadcom NetXtreme Gigabit Ethernet _2','Intel[R] Gigabit 2P I350-t Adapter','Intel[R] Gigabit 2P I350-t Adapter _2','Local Area Connection* 1','Local Area Connection* 2','Local Area Connection* 3','Local Area Connection* 4',isatap.<3F9E4A04-4F91-44ED-91FC-81B6A63FC935>,'Local Area Connection* 11'] WMI Table [Win32_PerfRawData_Tcpip_NetworkAdapter]

Created on Mar 28, 2015 4:39:43 AM by  airbiscuity (0) 1



Votes:

0

Your Vote:

Up

Down

Please use our WMI Tester, run it on the PRTG Host (or host of the Remote Probe) and scan against this particular target, with the following queries:

SELECT Description, IPAddress, MACAddress FROM Win32_NetworkAdapterConfiguration SELECT Name, BytesTotalPerSec FROM Win32_PerfRawData_Tcpip_NetworkAdapter SELECT Name, BytesTotalPersec FROM Win32_PerfRawData_Tcpip_NetworkInterface

Please then send us the results of these scans.

Created on Mar 30, 2015 8:35:27 AM by  Torsten Lindner [Paessler Support]



Votes:

0

Your Vote:

Up

Down

I have the exact same problem on various virtual machines.

Where can I send the results of the WMI query?

Created on Apr 7, 2015 12:33:25 PM by  arjan (0)



Votes:

0

Your Vote:

Up

Down

Send it to us via email to [email protected] with screenshots showing the error in PRTG.

Created on Apr 7, 2015 1:00:23 PM by  Torsten Lindner [Paessler Support]



Votes:

0

Your Vote:

Up

Down

Hi Arjan an Torstein,

I have an open case with Paessler that has been open since the 30th march 2015.

They say they are investigating the problem and have suggested to use SNMP to monitor bandwidth / traffic as a fall back measure.

You can also use the "contact support" feature from within your PRTG setup to send them additional diagnostic info that will hopefully help solve this issue.

I am eagerly awaiting a response to my support case from Paessler!

Regards,

Dave

Created on Apr 7, 2015 10:46:27 PM by  airbiscuity (0) 1



Votes:

0

Your Vote:

Up

Down

Dave, your issue was caused by a bug in PRTG, that is fixed in current canary builds, and will reach stable with version 15.x.17. Please bear with us.

Created on Apr 8, 2015 7:36:34 AM by  Torsten Lindner [Paessler Support]



Accepted Answer

Votes:

8

Your Vote:

Up

Down

We ran into this same error. What we found is the "#" in the device name caused the error. You can see it in the name "Microsoft Virtual Machine Bus Network Adapter _5", it's substituting an _ for the #. Remove the # altogether and you don't have that issue.

You can change it in the registry. You'll find the "FriendlyName" somewhere in HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\ for the NIC. That key has special permissions so the easiest way is to use psexec.

1. Open a command prompt as Administrator
2. Run psexec -s -i regedt32.exe
3. Navigate to registry key, change the FriendlyName to something without the #
4. Reboot

EDIT BY MOD: Changed formatting

Created on May 11, 2015 7:25:42 PM by  jasond (130) 1

Last change on May 12, 2015 1:10:59 PM by  Konstantin Wolff [Paessler Support]



Votes:

0

Your Vote:

Up

Down

Sorry to resurrect an old topic, but I am not in a position where I can edit the mentioned registry values.

Is there another alternative?

Created on Jul 13, 2015 5:44:00 AM by  acurus_ds (0)



Votes:

0

Your Vote:

Up

Down

Hello acurus_ds,

This bug shouldn't be a problem anymore, the bug is fixed in the latest 15.3.17.xxxx version.

Make sure you're running the latest version (PRTG > Setup > Auto-Update) and try adding the sensors again, if you're still receiving and error, please contact us using the Contact Support form within PRTG so that we can properly troubleshoot your issue.

Created on Jul 13, 2015 9:02:19 AM by  Luciano Lingnau [Paessler]



Votes:

0

Your Vote:

Up

Down

I still have this issue, I have 2 BCM5709C Nics teamed together. I tried to change the "friendlyname" in the registry, and after a reboot , it would add the Number back so I would get "_44 #44".

Any Ideas?

Created on Aug 6, 2015 8:06:30 PM by  jmmarch (0) 1



Votes:

0

Your Vote:

Up

Down

Hello jmmarch, as of PRTG version 15.3.17 and onward the issue should be fixed, hence the registry hack shouldn't be necessary anymore.

Note: Teamed adapters are only supported on Windows 2012 and 2012R2 using the built-in teaming support, third party teaming solutions are not supported by the Windows Network Card sensor.

In such cases consider monitoring via SNMP instead, you can use the following sensor:

Best Regards,

Created on Aug 7, 2015 6:47:46 AM by  Luciano Lingnau [Paessler]



Votes:

0

Your Vote:

Up

Down

I am not sure this relevant this is what i did "I Changed WinHttpAutoProxySvc service from Disabled to Automatic and Started the IP helper service"

Created on Jun 15, 2020 5:06:41 AM by  ramvenkey (0)



Votes:

0

Your Vote:

Up

Down

Hi ramvenkey,

Could you please let me know in which version your workaround helped to solve the issue?

Created on Jun 15, 2020 8:23:17 AM by  Marijan Horsky [Paessler Support]



Please log in or register to enter your reply.


Disclaimer: The information in the Paessler Knowledge Base comes without warranty of any kind. Use at your own risk. Before applying any instructions please exercise proper system administrator housekeeping. You must make sure that a proper backup of all your data is available.