What is this?

This knowledgebase contains questions and answers about PRTG Network Monitor and network monitoring in general. You are invited to get involved by asking and answering questions!

Learn more

PRTG Network Monitor

Intuitive to Use. Easy to manage.
300.000 administrators have chosen PRTG to monitor their network. Find out how you can reduce cost, increase QoS and ease planning, as well.

Free Download

Top Tags


View all Tags

Monitoring ServersCheck Temp Sensors via SNMP

Votes:

0

Your Vote:

Up

Down

I have several temperature sensors I'm monitoring through SNMP from a company called ServersCheck. I found and converted the MIBs to OIDs. The sensors have separate OIDs for value and error state. I can set the error ranges inside the ServersCheck device to tell it when to alert, but this means I have one sensor showing me the value and another showing me the error state. I'd like to configure the value sensor to trigger alarms in PRTG. I've setup the regex \d+\.\d+ to pull out a float from the response and set the default channel to "Extracted Value". This gets me the graphing and such that I'm looking for; however, I'm still not getting error and warning states out of it.

I tried ^[1]*$ for an error regular expression and ^[9]*$ as a warning regex. The though is if the sensor is in the 90s I should get a warning and if it gets into the 100s I should get an alarm (just testing values). When the reported temperature is in these ranges, it does not appear to match.

How can I get the regex to match? Also, can I set these values in the OID Library somehow so I don't have to re-setup each of these settings in each environment or when someone deletes one?

environment serverscheck snmp

Created on Mar 31, 2015 4:40:44 PM by  Josiah Ritchie (120) 1 1



2 Replies

Accepted Answer

Votes:

0

Your Vote:

Up

Down

Hi Josiah,

I assume that you already marked the Extract a numeric value using a regular expression option below the Extended Processing and entered the expression (\d+\.\d+).

Afterwards you can simply click on the channel gauge and enable the limits. Enter 90 for Upper Warning limit and 100 for the Upper error limit.

Best regards

Created on Apr 2, 2015 12:49:01 PM by  Felix Saure [Paessler Support]



Votes:

0

Your Vote:

Up

Down

Ha, thanks! I guess I had tunnel vision. I spent so much time in one area, that I completely lost sight of channel settings. I appreciate the help.

Created on Apr 2, 2015 2:11:27 PM by  Josiah Ritchie (120) 1 1



Please log in or register to enter your reply.


Disclaimer: The information in the Paessler Knowledge Base comes without warranty of any kind. Use at your own risk. Before applying any instructions please exercise proper system administrator housekeeping. You must make sure that a proper backup of all your data is available.