What is this?

This knowledgebase contains questions and answers about PRTG Network Monitor and network monitoring in general.

Learn more

PRTG Network Monitor

Intuitive to Use. Easy to manage.
More than 500,000 users rely on Paessler PRTG every day. Find out how you can reduce cost, increase QoS and ease planning, as well.

Free Download

Top Tags

View all Tags

alarm for trap received in SNMP Trap Receiver



I'm trying to set a notification when i get a dying gasp trap from a device. Every time i get that trap i see this information:


so i tried to create this error filter with the text in the bindings column:

bindings["SNMPv2-MIB::snmpTrapOID.0 = SNMPv2-SMI-v1::enterprises.8886."]

i have the scanning interval set to 30 seconds and set the sensor down immediately when it reports an error.

Nothing happens, i disconnect the device from the power and get the dying gasp trap but the sensor never goes down.

Am i missing something?

filter notifications trap-receiver

Created on Apr 23, 2015 6:23:48 PM

7 Replies




thank you very much for using PRTG. Can you please share a screenshot showing the "Settings" of this sensor? Also, if you use this filter on the "Messages"-Tab in the bindings column, do you then only see the particular traps?

best regards.

Created on Apr 24, 2015 11:52:03 AM by  Torsten Lindner [Paessler Support]



the settings are just what i stated in the question: http://i.imgur.com/UPu3hzB.png the rest are set to default or inherited

And no, it doesn't filter anything. If that what it appears in the bindings column in the received trap messages table in overview tab i understand that would be the correct binding... or not?


Created on Apr 24, 2015 2:40:17 PM



The Filtering condition seems redundant. Please remove the filter for now. Then let the sensor run and gather (everything in traps it receives). After that, go to the "Messages"-Tab of the sensor and change the filter in the column-headers until only the traps are left, that you want alarms on.
Then copy the filter into the settings of the sensor.

Created on Apr 27, 2015 7:21:19 AM by  Torsten Lindner [Paessler Support]



i don't know what filter i could use for this trap http://i.imgur.com/LYpkirV.png because if i write "SNMPv2-MIB::snmpTrapOID.0 = SNMPv2-SMI-v1::enterprises.8886." or a portion of it i don't get any results in the message table.

Created on Apr 27, 2015 3:50:45 PM



I think i found the correct filter and set it to this bindings[]

Now the problem is that dying gasp is a single trap and the sensor won't go down. Is there a way i can set the sensitivity of the sensor to allow it to go down with a single trap?

Created on Apr 27, 2015 5:46:12 PM



You have to define the filter then as "Error Filter" in the sensor settings. Please be aware though the sensor will only go into error state in that interval the trap comes in. In the next interval the sensor will be up again, unless another such trap is received.

Created on Apr 28, 2015 6:52:25 AM by  Torsten Lindner [Paessler Support]



I did define it as an error filter as you can see in the capture i posted above http://i.imgur.com/UPu3hzB.png or as i stated in the original question "tried to create this error filter"

anyways, i already solved it and could get an email when single dying gasp is received.

Created on Apr 28, 2015 3:28:35 PM

Disclaimer: The information in the Paessler Knowledge Base comes without warranty of any kind. Use at your own risk. Before applying any instructions please exercise proper system administrator housekeeping. You must make sure that a proper backup of all your data is available.