What is this?

This knowledgebase contains questions and answers about PRTG Network Monitor and network monitoring in general. You are invited to get involved by asking and answering questions!

Learn more

PRTG Network Monitor

Intuitive to Use. Easy to manage.
More than 500,000 users rely on Paessler PRTG every day. Find out how you can reduce cost, increase QoS and ease planning, as well.

Free Download

Top Tags


View all Tags

Not receiving Netflow Packet

Votes:

0

Your Vote:

Up

Down

Hello,

I tried to configured netflow for Cisco 3650 but I do not see the packet within PRTG. Using Wireshark, I correctly see the Netflow V9 packet coming on port 9996. I used the Netflow V9 Tester from PRTG (NetFlow 9) and I don't see any packet.

Can you please help. I have updated PRTG today to the last version.

Thanks, Fred

cisco netflow-v9 wireshark

Created on Jun 5, 2015 8:06:50 AM by  fgibert (0) 1



11 Replies

Votes:

0

Your Vote:

Up

Down

  1. Do you have sampling enabled in both the sensor and the monitored device by any chance?
  2. Is the flow timeout set correctly (usually scanning interval +1)
  3. What scanning interval is used?

Created on Jun 5, 2015 8:48:47 AM by  Stephan Linke [Paessler Support]



Votes:

0

Your Vote:

Up

Down

  1. Sampling Mode is on and sampling rate is 1 (hope it is the answer you were expecting...)
  2. Active Flow timeout is set to 1 minute
  3. I don't see any scanning interval parameter. Where is it configured?

Created on Jun 5, 2015 8:54:42 AM by  fgibert (0) 1

Last change on Jun 5, 2015 8:59:07 AM by  Stephan Linke [Paessler Support]



Votes:

0

Your Vote:

Up

Down

The scanning interval is set to 60 sec. Sorry, I didn't saw it before.

Created on Jun 5, 2015 9:00:36 AM by  fgibert (0) 1



Votes:

0

Your Vote:

Up

Down

Does the device get a lot of traffic? You could disable the sampling for testing purposes. Remember to disable it on the device as well. The interval can be found below the sensor message field, just above the graph on the right side. Per default it's set to 60 seconds, so the active flow timeout has to be increased to two minutes.

edit
hehe already wrote the post when you posted :) increase the timeout and see if it gets values then.

Created on Jun 5, 2015 9:01:37 AM by  Stephan Linke [Paessler Support]

Last change on Jun 5, 2015 9:04:18 AM by  Stephan Linke [Paessler Support]



Votes:

0

Your Vote:

Up

Down

I receive traffic every 3 seconds from the cisco. Now, I have disabled the sampling and increased the time-out to 2 minutes. How could I disable sampling on the cisco device?

I still don't receive any data.

Tks,

Created on Jun 5, 2015 9:12:27 AM by  fgibert (0) 1



Votes:

0

Your Vote:

Up

Down

Enter global configuration mode and issue the following commands:

show ip flow sampling
interface FastEthernet9/0/0
no ip flow-sampling-mode packet-interval

Created on Jun 5, 2015 9:24:59 AM by  Stephan Linke [Paessler Support]

Last change on Jun 5, 2015 9:25:40 AM by  Stephan Linke [Paessler Support]



Votes:

0

Your Vote:

Up

Down

I already used the Netflow Tester V9 and the problem is that I do not receive anything inside this tool. BUT, I also tried with wireshark and I see all the Netflow packet coming on port 9996.

To resume, I don't understand why I see the packets on Wireshark but not on the tool.

Created on Jun 5, 2015 9:31:22 AM by  fgibert (0) 1



Votes:

0

Your Vote:

Up

Down

Port is configured correctly? Any firewall or antivirus application that might drop the packets?

Created on Jun 5, 2015 9:39:51 AM by  Stephan Linke [Paessler Support]



Votes:

0

Your Vote:

Up

Down

Yes, everything seems to be configured correctly. Normally there is no FW or antivirus application that could block. As I receive the traffic in Wireshark, it should be ok.

Any ideas?

Created on Jun 5, 2015 11:01:43 AM by  fgibert (0) 1



Votes:

0

Your Vote:

Up

Down

I disabled the FW on the Windows server and now I can receive flow on the Netflow 9 Tester. Still don't see anything in the PRTG console.

Should I configure something different?

Created on Jun 5, 2015 11:30:42 AM by  fgibert (0) 1



Votes:

0

Your Vote:

Up

Down

Still no traffic available within the sensor? Did you disable the netflow tester (because it will block the sensor), pause the sensor and unpause it again?

Created on Jun 8, 2015 5:43:28 AM by  Stephan Linke [Paessler Support]



Please log in or register to enter your reply.


Disclaimer: The information in the Paessler Knowledge Base comes without warranty of any kind. Use at your own risk. Before applying any instructions please exercise proper system administrator housekeeping. You must make sure that a proper backup of all your data is available.