What is this?

This knowledgebase contains questions and answers about PRTG Network Monitor and network monitoring in general. You are invited to get involved by asking and answering questions!

Learn more

PRTG Network Monitor

Intuitive to Use. Easy to manage.
300.000 administrators have chosen PRTG to monitor their network. Find out how you can reduce cost, increase QoS and ease planning, as well.

Free Download

Top Tags


View all Tags

WMI Error

Votes:

0

Your Vote:

Up

Down

Hi,

I recently migrated my PRTG Server installation from Amazon to Azure, and whilst it might be unrelated, I'm using full disclosure.

When I try to add a new WMI sensor - on any of my servers it comes back with the following error: Could not create the sensor WMI Service on device <DEVICENAME> (127.0.0.1).

Could not validate sensor preconditions

I have other WMI sensors that are working fine, and even when I try to add them again I get this error.

I also get this error when trying to add wmi sensors on any of my other servers.

PRTG Info: PRTG Version PRTG Network Monitor 15.3.17.2996 Auto-Update Status [12/07/2015 11:40:11 AM] Downloaded version (15.3.17.2996) is not newer than your current version (15.3.17.2996). Operating System Windows Server 2012 (6.2.2 Build 9200 ), 1 CPUs (Single x64 Model 45 Step 7), code page "Windows-1252", on HyperV Server Time 14.07.2015 07:58:19 (UTC+10:00)

precondition sensor wmi

Created on Jul 13, 2015 9:59:29 PM by  Slaziar (0) 1



5 Replies

Votes:

0

Your Vote:

Up

Down

Hi Slaziar,

Please try to enter the Windows Credentials directly in the device settings of the Remote Probe itself. Afterwards, you should be able to add the WMI Sensors to the probe device.

Best regards

Created on Jul 14, 2015 5:34:52 AM by  Felix Saure [Paessler Support]



Votes:

0

Your Vote:

Up

Down

Hi,

I thought I wrote a reply yesterday, but I attempted this with the domain administrator credentials with no success.

Considering that this remote probe has other WMI sensors, and I am having the issue on ALL my remote probe servers, most of which have WMI sensors, this sounds more like a server sided issue.

Regards,

Scott

Created on Jul 14, 2015 8:33:39 PM by  Slaziar (0) 1



Votes:

0

Your Vote:

Up

Down

Hi,

You mentioned that some WMI sensors are working, which exact sensor type does not work? Please do also try to add a new device with the private IP address of the PRTG Server or Remote Probe and see if the sensor works afterwards.

Best regards

Created on Jul 15, 2015 5:34:59 AM by  Felix Saure [Paessler Support]



Votes:

0

Your Vote:

Up

Down

It's strange, I put the windows credentials into the core probe service (on the remote computer mistakenly). When putting it onto the prtg server in Windows Credentials it works.

The question is, why have I been able to have wmi sensors (like WMI service, that I just had problems with) on the core probe before without having to enter Windows credentials, but I have to now?

Thanks,

Scott

Created on Jul 15, 2015 5:49:00 AM by  Slaziar (0) 1



Votes:

0

Your Vote:

Up

Down

Hi Slaziar,

This is a known bug in the current Stable version of PRTG which is already fixed in the recent Preview version. It's just affecting the meta scan of those sensors, this will be most likely the reason why some other WMI sensors worked properly. Please excuse the inconvenience.

Best regards

Created on Jul 15, 2015 6:00:51 AM by  Felix Saure [Paessler Support]



Please log in or register to enter your reply.


Disclaimer: The information in the Paessler Knowledge Base comes without warranty of any kind. Use at your own risk. Before applying any instructions please exercise proper system administrator housekeeping. You must make sure that a proper backup of all your data is available.