New Question
 
 
PRTG Network Monitor

Intuitive to Use.
Easy to manage.

200.000 administrators have chosen PRTG to monitor their network. Find out how you can reduce cost, increase QoS and ease planning, as well.

Free PRTG
Download >>

 

What is this?

This knowledgebase contains questions and answers about PRTG Network Monitor and network monitoring in general. You are invited to get involved by asking and answering questions!

Learn more

 

Top Tags


View all Tags


REST-API through Proxyserver

Votes:

0

Your Vote:

Up

Down

I created my first sensor of type "HTTP XML/REST Wert" to get a simple JSON. The only message I get is (took this from the debug textfile): [Error] Die Verbindung mit dem Remoteserver kann nicht hergestellt werden. Exitcode custom_error

This are the parameters I sent: [Parameters] -u=http://www.pegelonline.wsv.de/webservices/rest-api/v2/stations/5990020/W/currentmeasurement.json -n=value -t=60 -rn -nct -debug=C:\ProgramData\Paessler\PRTG Network Monitor\Logs (Sensors)\Result of Sensor 6755.txt

I can query the data through my browser. As we are using a proxyserver here I am asking me if PRTG takes this into account, as it is configured in the PRTG settings section and if that might be the issue?

Br Dominic

api http http-xml-rest-value-sensor json restful

Created on Oct 20, 2015 10:43:38 AM by  Dominic (151) 1 1



8 Replies

Votes:

0

Your Vote:

Up

Down

Hi Dominic

To test if your proxyserver could be the issue, try creating a simple http sensor and use the same url as above. Proxy can be configured in Setup - System Administration - Core&Probes (first entry "use proxy server)

I created a HTTP XML/REST Wert sensor in my PRTG installation with URL: http://www.pegelonline.wsv.de/webservices/rest-api/v2/stations/5990020/W/currentmeasurement.json XMLNode: value

And I get back 574 (the same as when I browse your URL)

regards Thomas

Created on Oct 20, 2015 2:13:31 PM by  Thomas Umbricht (2,820) 2 3



Votes:

0

Your Vote:

Up

Down

Hi Dominic,

It seems that the proxy server & credentials are not parsed to the sensor. They should show in the debug text file as -ps=proxyserver -pu=proxyuser -pp=proxypassword

Created on Oct 20, 2015 3:14:08 PM by  PRTG Tools Family [prtgtoolsfamily.com] (12,835) 3 4



Votes:

0

Your Vote:

Up

Down

Hi,

I tried using the normal HTTP sensor type, but also there I do not get positive results (this sensor gives a connection time-out). So it looks as the Proxy is not used for sensors ... it is configured as it should, loading the PRTG system patches and license-checking works perfectly.

So I guess PRTG has to answer this ...

Created on Oct 20, 2015 3:15:12 PM by  Dominic (151) 1 1



Votes:

0

Your Vote:

Up

Down

Oh, looks you wrote in the same minute.

So we know the proxy isn't passed - is there any way for a workarround for the time until Paessler might give us the option passing the sets into the sensors settings? As far as I can see the parameters are directly given to the XMLValue.exe, no script or batch to be modified ...

Br Dominic

Created on Oct 21, 2015 7:29:57 AM by  Dominic (151) 1 1



Votes:

0

Your Vote:

Up

Down

Hi Dominic

Hmm thats strange, because: https://www.paessler.com/manuals/prtg/probes_settings

If the Autoupdate works, but the sensor isn't, please configure the proxy again in the HTTP Sensor setting itself and try again, instead of using the global proxy settings.

regards Thomas

Created on Oct 21, 2015 8:22:58 AM by  Thomas Umbricht (2,820) 2 3



Votes:

2

Your Vote:

Up

Down

Dear Dominic

To use a proxy server, please create the HTTP sensor as Custom Exe/Script sensor. This way you can use additional parameters not available through the sensor UI and provide a proxy server address as well.

To do this, please open your PRTG installation folder and copy the file "Sensor System\XMLValue.exe" into the "Custom Sensors\EXE" path. Then create an Exe/Script sensor.

Created on Oct 21, 2015 9:15:22 AM by  Arne Seifert [Paessler Support]



Votes:

0

Your Vote:

Up

Down

Hi Thomas - that was a good hint. I added the proxy to the http sensor and it worked. Then I realized without setting it it uses the inherited settings from "obove", and I did not set the proxy in any group or the root (main group). So I entered it there instead of the system settings dialogue and it run.

But unfortunately it did not work for the REST sensor, as it also do not have a settings section for the proxy (and therefore not the standard behaviour of inheriting the settings from overlaying group).

So it still looks as it might be an PRTG issue?!

Created on Oct 21, 2015 9:25:00 AM by  Dominic (151) 1 1



Votes:

0

Your Vote:

Up

Down

Hi Arne,

thanks a lot, that way it runs smoothly!!

Br Dominic

Created on Oct 21, 2015 10:42:51 AM by  Dominic (151) 1 1



Please log in or register to enter your reply.


Disclaimer: The information in the Paessler Knowledge Base comes without warranty of any kind. Use at your own risk. Before applying any instructions please exercise proper system administrator housekeeping. You must make sure that a proper backup of all your data is available.