New Question
 
 
PRTG Network Monitor

Intuitive to Use.
Easy to manage.

200.000 administrators have chosen PRTG to monitor their network. Find out how you can reduce cost, increase QoS and ease planning, as well.

Free PRTG
Download >>

 

What is this?

This knowledgebase contains questions and answers about PRTG Network Monitor and network monitoring in general. You are invited to get involved by asking and answering questions!

Learn more

 

Top Tags


View all Tags


I cannot add VMware sensors because of "wrong" password although it is correct. What can I do?

Votes:

0

Your Vote:

Up

Down

I have an issue with credentials and the configuration of my VMware sensors. For example, when I try to add a VMware Virtual Machine (SOAP) sensor, I get an error message that registering cannot be completed because of a wrong username or password. The add sensor dialog fails and I cannot add the VMware sensor.

I double-checked the credentials for VMware that I provide in the settings of the device that represents my vCenter in PRTG. They are correct but do not work. What can be the reason for this? Do I have to consider something for the vCenter password?

add-sensor credentials error prtg vmware vmwaresensor

Created on Oct 29, 2015 3:34:29 PM by  Gerald Schoch [Paessler Support]



1 Reply

Accepted Answer

Votes:

0

Your Vote:

Up

Down

This article applies to PRTG Network Monitor 15 or later

Resolving the "Wrong" Credentials Issue when Adding VMware Sensors

Before you can add VMware sensors to PRTG, you have to provide Credentials for VMware on the parent device to which you want to add the sensor and that represents your target VMware server. Usually it works if you use the credentials of a user with sufficient rights (for example, read-only) to obtain statistics from VMware, but please consider:

Do not use special characters in Single Sign-On (SSO) passwords!

Otherwise you will not be able to add the sensor at all because the Add Sensor dialog aborts with an error message about incorrect user name or password. The following special characters do not work in SSO passwords for vCenter servers:

  • Non-ASCII characters (including the euro (€) sign, for example)
  • Ampersand (&)
  • Semicolon ( ; )
  • Double quotation mark ( " )
  • Single quotation mark ( ' )
  • Circumflex ( ^ )
  • Backslash ( \ )
  • Percentage (%)

Please change the password for your vCenter accordingly and use this password in the settings of the target device in PRTG.

Note: This issue is not caused by PRTG but is a known bug of VMware. For details, please see this article in the VMware Knowledge Base.

Created on Oct 29, 2015 3:36:12 PM by  Gerald Schoch [Paessler Support]



Please log in or register to enter your reply.


Disclaimer: The information in the Paessler Knowledge Base comes without warranty of any kind. Use at your own risk. Before applying any instructions please exercise proper system administrator housekeeping. You must make sure that a proper backup of all your data is available.