New Question
 
 
PRTG Network Monitor

Intuitive to Use.
Easy to manage.

200.000 administrators have chosen PRTG to monitor their network. Find out how you can reduce cost, increase QoS and ease planning, as well.

Free PRTG
Download >>

 

What is this?

This knowledgebase contains questions and answers about PRTG Network Monitor and network monitoring in general. You are invited to get involved by asking and answering questions!

Learn more

 

Top Tags


View all Tags


Temperature sensor does nog work Raspberry Pi2

Votes:

0

Your Vote:

Up

Down

I just setted up a Raspberry Pi 2 with the newest version of rasbian. I have completed the setup for linux miniprobe to connect it to prtg.

The miniprobe works 100% and cpu, ram ect. works fine in prtg. The temperature sensor works in the pi. i can readout the temperatures. But the sensor in PRTG gives a error message. Error: DS18B20 sensor failed. See log for details

Do i need to make a script within the pi or should it work?

prtg rasbian raspberry-pi temperature

Created on May 18, 2016 12:55:12 PM by  wiekart (0) 1



6 Replies

Votes:

0

Your Vote:

Up

Down

Hi,
have you followed the instructions for the installation of the DS18B20?
Best regards

Created on May 19, 2016 11:54:12 AM by  Konstantin Wolff [Paessler Support]



Votes:

0

Your Vote:

Up

Down

Yes i have. Inside the Pi i get correct temperatures of the sensor. i reinstalled the pi serveral times but still doesnt work

Created on May 31, 2016 1:51:41 PM by  wiekart (0) 1



Votes:

0

Your Vote:

Up

Down

What are the results when you execute the following command:

ls -al /sys/bus/w1/devices

Could you post the results?

Created on Jun 2, 2016 1:51:33 PM by  Konstantin Wolff [Paessler Support]



Votes:

0

Your Vote:

Up

Down

Command "ls -al /sys/bus/w1/devices" :

[email protected]:/sys/bus/w1/devices $ ls -al /sys/bus/w1/devices
total 0
drwxr-xr-x 2 root root 0 Jun  2 15:00 .
drwxr-xr-x 4 root root 0 May 31 14:17 ..
lrwxrwxrwx 1 root root 0 Jun  2 14:57 28-0315651429ff -> ../../../devices/w1_bus_master1/28-0315651429ff
lrwxrwxrwx 1 root root 0 Jun  2 14:57 w1_bus_master1 -> ../../../devices/w1_bus_master1

Created on Jun 2, 2016 3:00:47 PM by  wiekart (0) 1

Last change on Jun 7, 2016 12:50:20 PM by  Konstantin Wolff [Paessler Support]



Votes:

0

Your Vote:

Up

Down

In the probe.log i get the error:

Ooops Something went wrong with 'mpds18b20' sensor 4406. Error: global name '__init__' is not defined

Created on Jun 2, 2016 3:05:56 PM by  wiekart (0) 1



Votes:

0

Your Vote:

Up

Down

I Fixed it,

in the sensor code of the temperature sensor there is a comment i have removed. PythonMiniProbe/miniprobe/sensors/ds18b20.py

and changed:

#import __init__

TO:

import __init__

Now it works

Created on Jun 3, 2016 7:30:35 AM by  wiekart (0) 1

Last change on Jun 7, 2016 12:50:05 PM by  Konstantin Wolff [Paessler Support]



Please log in or register to enter your reply.


Disclaimer: The information in the Paessler Knowledge Base comes without warranty of any kind. Use at your own risk. Before applying any instructions please exercise proper system administrator housekeeping. You must make sure that a proper backup of all your data is available.